aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-07-02 22:19:47 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-07-02 22:19:47 +0000
commit6127b3053014197ef7482300ef9f7e0578036020 (patch)
tree586307ea48ee3b59d080be05ebdf15a39e8c7304 /www
parent8af44443479e5b2379fac728373b944d323dc16f (diff)
downloadports-6127b3053014197ef7482300ef9f7e0578036020.tar.gz
ports-6127b3053014197ef7482300ef9f7e0578036020.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/dotproject/Makefile5
-rw-r--r--www/sarg/Makefile27
2 files changed, 18 insertions, 14 deletions
diff --git a/www/dotproject/Makefile b/www/dotproject/Makefile
index 8a16eb111377..127bba4faf43 100644
--- a/www/dotproject/Makefile
+++ b/www/dotproject/Makefile
@@ -22,11 +22,12 @@ USE_APACHE= 20+
SUB_FILES= pkg-message
-OPTIONS= LDAP "Enable ldap support" On
+OPTIONS_DEFINE= LDAP
+OPTIONS_DEFAULT=LDAP
.include <bsd.port.pre.mk>
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_PHP+= ldap xml
.endif
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index cd654c3424f5..2df58e773b8c 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -17,8 +17,11 @@ COMMENT= Squid log analyzer and HTML report generator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS= GD "Enable GD support" on\
- PHP "Install PHP for reporting generating" on
+OPTIONS_DEFINE= GD PHP
+OPTIONS_DEFAULT=GD PHP
+
+GD_DESC= Enable GD support
+PHP_DESC= Install PHP for reporting generating
USE_AUTOTOOLS= autoconf aclocal
USE_GMAKE= yes
@@ -33,24 +36,24 @@ MAN1= sarg.1
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-CONFIGURE_ARGS+= --disable-nls
-.else
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USE_GETTEXT= yes
USE_ICONV= yes
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+=--disable-nls
.endif
-.if !defined(WITHOUT_GD)
-LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+.if ${PORT_OPTIONS:MGD}
+LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
.endif
-.if !defined(WITHOUT_PHP)
-CONFIGURE_ARGS+= --enable-sargphp="${ETCDIR}"
+.if ${PORT_OPTIONS:MPHP}
+CONFIGURE_ARGS+=--enable-sargphp="${ETCDIR}"
PLIST_SUB+= PHP=""
.else
-CONFIGURE_ARGS+= --disable-sargphp
+CONFIGURE_ARGS+=--disable-sargphp
PLIST_SUB+= PHP="@comment "
.endif
@@ -59,7 +62,7 @@ post-extract:
@${CHMOD} 0755 ${WRKSRC}/configure
post-patch:
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e '/^LIBS/ s/$$/ -lintl/' ${WRKSRC}/Makefile.in
.endif