aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-08-17 12:41:26 +0000
committerClement Laforet <clement@FreeBSD.org>2004-08-17 12:41:26 +0000
commit696614c16dc188fe65722ba39dacd7ea867385bb (patch)
tree8488241fa16076bf45a1c61fa367cc8a20d178c2 /www
parent3190699a5ed4f827101c4a93f4c5a98f41780d1b (diff)
downloadports-696614c16dc188fe65722ba39dacd7ea867385bb.tar.gz
ports-696614c16dc188fe65722ba39dacd7ea867385bb.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/apache2/Makefile18
-rw-r--r--www/apache2/files/patch-docs:conf:httpd-std.conf.in37
-rw-r--r--www/apache2/pkg-plist2
-rw-r--r--www/apache20/Makefile18
-rw-r--r--www/apache20/files/patch-docs:conf:httpd-std.conf.in37
-rw-r--r--www/apache20/pkg-plist2
6 files changed, 86 insertions, 28 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index f9c115b0e05a..156efc00b756 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -9,7 +9,8 @@
PORTNAME= apache
PORTVERSION= 2.0.50
-CATEGORIES= www ipv6
+PORTREVISION= 1
+CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
http://sheepkiller.nerim.net/ports/${PORTNAME}/:powerlogo
DISTNAME= httpd-${PORTVERSION}
@@ -77,10 +78,13 @@ WITH_HTTP_PORT?= 80
.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
-.elif defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
-CONFIGURE_ARGS+= --disable-v4-mapped
.else
+CATEGORIES+= ipv6
+. if defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
+CONFIGURE_ARGS+= --disable-v4-mapped
+. else
CONFIGURE_ARGS+= --enable-v4-mapped
+. endif
.endif
.if !defined(WITHOUT_SSL)
@@ -185,8 +189,10 @@ post-patch:
@${RM} -f ${WRKSRC}/docs/docroot/*.bak
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache.sh > ${WRKDIR}/apache2.sh
+.if !defined(WITH_APR_FROM_PORTS)
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache2libs.sh > ${WRKDIR}/apache2libs.sh
+.endif
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
@@ -205,10 +211,12 @@ pre-install:
post-install:
@${MKDIR} ${PREFIX}/etc/apache2/Includes
- @${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."
- @${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
+.if !defined(WITH_APR_FROM_PORTS)
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/000.apache2libs.sh startup file."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2libs.sh ${PREFIX}/etc/rc.d/000.apache2libs.sh
+.endif
+ @${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."
+ @${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
@@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/apache2/files/patch-docs:conf:httpd-std.conf.in b/www/apache2/files/patch-docs:conf:httpd-std.conf.in
index 31c157a66b46..12128e97a5a1 100644
--- a/www/apache2/files/patch-docs:conf:httpd-std.conf.in
+++ b/www/apache2/files/patch-docs:conf:httpd-std.conf.in
@@ -1,5 +1,5 @@
--- docs/conf/httpd-std.conf.in.orig Sat Apr 24 20:13:43 2004
-+++ docs/conf/httpd-std.conf.in Sun Jul 25 11:37:58 2004
++++ docs/conf/httpd-std.conf.in Tue Aug 17 12:11:17 2004
@@ -68,7 +68,7 @@
#
<IfModule !mpm_netware.c>
@@ -34,7 +34,7 @@
</Directory>
#
-@@ -365,8 +366,11 @@
+@@ -365,24 +366,29 @@
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
@@ -46,15 +46,36 @@
#
# Control access to UserDir directories. The following is an example
# for a site where these directories are restricted to read-only.
-@@ -384,6 +388,8 @@
- # </LimitExcept>
- #</Directory>
-
-+</IfModule>
+ #
+-#<Directory /home/*/public_html>
+-# AllowOverride FileInfo AuthConfig Limit Indexes
+-# Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
+-# <Limit GET POST OPTIONS PROPFIND>
+-# Order allow,deny
+-# Allow from all
+-# </Limit>
+-# <LimitExcept GET POST OPTIONS PROPFIND>
+-# Order deny,allow
+-# Deny from all
+-# </LimitExcept>
+-#</Directory>
++<Directory /home/*/public_html>
++ AllowOverride FileInfo AuthConfig Limit Indexes
++ Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
++ <Limit GET POST OPTIONS PROPFIND>
++ Order allow,deny
++ Allow from all
++ </Limit>
++ <LimitExcept GET POST OPTIONS PROPFIND>
++ Order deny,allow
++ Deny from all
++ </LimitExcept>
++</Directory>
+
++</IfModule>
+
#
# DirectoryIndex: sets the file that Apache will serve if a directory
- # is requested.
@@ -472,7 +478,7 @@
# logged here. If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
diff --git a/www/apache2/pkg-plist b/www/apache2/pkg-plist
index b37c326e8eca..f9b69059d301 100644
--- a/www/apache2/pkg-plist
+++ b/www/apache2/pkg-plist
@@ -14,7 +14,7 @@ etc/apache2/mime.types-dist
@unexec if cmp -s %D/etc/apache2/ssl.conf %D/etc/apache2/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
etc/apache2/ssl-std.conf
@exec [ -f %B/ssl.conf ] || cp %B/%f %B/ssl.conf
-etc/rc.d/000.apache2libs.sh
+%%PORTS_APR%%etc/rc.d/000.apache2libs.sh
etc/rc.d/apache2.sh
include/apache2/ap_compat.h
include/apache2/ap_config.h
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index f9c115b0e05a..156efc00b756 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -9,7 +9,8 @@
PORTNAME= apache
PORTVERSION= 2.0.50
-CATEGORIES= www ipv6
+PORTREVISION= 1
+CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
http://sheepkiller.nerim.net/ports/${PORTNAME}/:powerlogo
DISTNAME= httpd-${PORTVERSION}
@@ -77,10 +78,13 @@ WITH_HTTP_PORT?= 80
.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
-.elif defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
-CONFIGURE_ARGS+= --disable-v4-mapped
.else
+CATEGORIES+= ipv6
+. if defined(WITH_IPV6_V6ONLY) && defined(WITHOUT_V4MAPPED)
+CONFIGURE_ARGS+= --disable-v4-mapped
+. else
CONFIGURE_ARGS+= --enable-v4-mapped
+. endif
.endif
.if !defined(WITHOUT_SSL)
@@ -185,8 +189,10 @@ post-patch:
@${RM} -f ${WRKSRC}/docs/docroot/*.bak
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache.sh > ${WRKDIR}/apache2.sh
+.if !defined(WITH_APR_FROM_PORTS)
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/apache2libs.sh > ${WRKDIR}/apache2libs.sh
+.endif
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
@@ -205,10 +211,12 @@ pre-install:
post-install:
@${MKDIR} ${PREFIX}/etc/apache2/Includes
- @${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."
- @${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
+.if !defined(WITH_APR_FROM_PORTS)
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/000.apache2libs.sh startup file."
@${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2libs.sh ${PREFIX}/etc/rc.d/000.apache2libs.sh
+.endif
+ @${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."
+ @${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh
@@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/apache20/files/patch-docs:conf:httpd-std.conf.in b/www/apache20/files/patch-docs:conf:httpd-std.conf.in
index 31c157a66b46..12128e97a5a1 100644
--- a/www/apache20/files/patch-docs:conf:httpd-std.conf.in
+++ b/www/apache20/files/patch-docs:conf:httpd-std.conf.in
@@ -1,5 +1,5 @@
--- docs/conf/httpd-std.conf.in.orig Sat Apr 24 20:13:43 2004
-+++ docs/conf/httpd-std.conf.in Sun Jul 25 11:37:58 2004
++++ docs/conf/httpd-std.conf.in Tue Aug 17 12:11:17 2004
@@ -68,7 +68,7 @@
#
<IfModule !mpm_netware.c>
@@ -34,7 +34,7 @@
</Directory>
#
-@@ -365,8 +366,11 @@
+@@ -365,24 +366,29 @@
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
@@ -46,15 +46,36 @@
#
# Control access to UserDir directories. The following is an example
# for a site where these directories are restricted to read-only.
-@@ -384,6 +388,8 @@
- # </LimitExcept>
- #</Directory>
-
-+</IfModule>
+ #
+-#<Directory /home/*/public_html>
+-# AllowOverride FileInfo AuthConfig Limit Indexes
+-# Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
+-# <Limit GET POST OPTIONS PROPFIND>
+-# Order allow,deny
+-# Allow from all
+-# </Limit>
+-# <LimitExcept GET POST OPTIONS PROPFIND>
+-# Order deny,allow
+-# Deny from all
+-# </LimitExcept>
+-#</Directory>
++<Directory /home/*/public_html>
++ AllowOverride FileInfo AuthConfig Limit Indexes
++ Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
++ <Limit GET POST OPTIONS PROPFIND>
++ Order allow,deny
++ Allow from all
++ </Limit>
++ <LimitExcept GET POST OPTIONS PROPFIND>
++ Order deny,allow
++ Deny from all
++ </LimitExcept>
++</Directory>
+
++</IfModule>
+
#
# DirectoryIndex: sets the file that Apache will serve if a directory
- # is requested.
@@ -472,7 +478,7 @@
# logged here. If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
diff --git a/www/apache20/pkg-plist b/www/apache20/pkg-plist
index b37c326e8eca..f9b69059d301 100644
--- a/www/apache20/pkg-plist
+++ b/www/apache20/pkg-plist
@@ -14,7 +14,7 @@ etc/apache2/mime.types-dist
@unexec if cmp -s %D/etc/apache2/ssl.conf %D/etc/apache2/ssl-std.conf; then rm -f %D/etc/apache2/ssl.conf; fi
etc/apache2/ssl-std.conf
@exec [ -f %B/ssl.conf ] || cp %B/%f %B/ssl.conf
-etc/rc.d/000.apache2libs.sh
+%%PORTS_APR%%etc/rc.d/000.apache2libs.sh
etc/rc.d/apache2.sh
include/apache2/ap_compat.h
include/apache2/ap_config.h