aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-08-16 19:33:50 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-08-16 19:33:50 +0000
commit6d04ca1269626cb297e54063ff05abe41f451beb (patch)
treeb6d50debbc8900580ce6fbc2b2abd147ac9c8c6a /www
parentdadf494e36803d0d79a58340d8489a439952207c (diff)
downloadports-6d04ca1269626cb297e54063ff05abe41f451beb.tar.gz
ports-6d04ca1269626cb297e54063ff05abe41f451beb.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-childtickets/Makefile35
-rw-r--r--www/trac-childtickets/distinfo2
-rw-r--r--www/trac-childtickets/files/pkg-message.in2
-rw-r--r--www/trac-childtickets/pkg-descr20
5 files changed, 60 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 54bed9686f14..9d0b8f44588c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1851,6 +1851,7 @@
SUBDIR += trac-bzr
SUBDIR += trac-calendar
SUBDIR += trac-ccselector
+ SUBDIR += trac-childtickets
SUBDIR += trac-codetags
SUBDIR += trac-customfieldadmin
SUBDIR += trac-customroadmap
diff --git a/www/trac-childtickets/Makefile b/www/trac-childtickets/Makefile
new file mode 100644
index 000000000000..18398fd9b270
--- /dev/null
+++ b/www/trac-childtickets/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: trac-childtickets
+# Date created: 2012-08-16
+# Whom: Radim Kolar <hsn@sendmail.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= childtickets
+PORTVERSION= 2.5.2
+CATEGORIES= www devel python
+MASTER_SITES= http://schema.filez.com/distfiles/
+PKGNAMEPREFIX= trac-
+
+MAINTAINER= hsn@sendmail.cz
+COMMENT= Support for having child-tickets in Trac
+
+LICENSE= BSD
+
+RUN_DEPENDS+= trac>=0.12:${PORTSDIR}/www/trac
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/childticketsplugin/0.12
+
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= Tracchildtickets
+
+SUB_FILES= pkg-message
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/trac-childtickets/distinfo b/www/trac-childtickets/distinfo
new file mode 100644
index 000000000000..bb87d80918c4
--- /dev/null
+++ b/www/trac-childtickets/distinfo
@@ -0,0 +1,2 @@
+SHA256 (childtickets-2.5.2.zip) = a806a3e2f47cf4d36ad1ad6ec35153088580e38e61458d4d5e00a06eaabd17ae
+SIZE (childtickets-2.5.2.zip) = 15305
diff --git a/www/trac-childtickets/files/pkg-message.in b/www/trac-childtickets/files/pkg-message.in
new file mode 100644
index 000000000000..74d85dda14d4
--- /dev/null
+++ b/www/trac-childtickets/files/pkg-message.in
@@ -0,0 +1,2 @@
+See plugin homepage http://trac-hacks.org/wiki/ChildTicketsPlugin for
+more information about post install configuration.
diff --git a/www/trac-childtickets/pkg-descr b/www/trac-childtickets/pkg-descr
new file mode 100644
index 000000000000..8331ca33210e
--- /dev/null
+++ b/www/trac-childtickets/pkg-descr
@@ -0,0 +1,20 @@
+Having child-tickets is extremely useful when it comes to
+managing multiple releases (ie. a single 'bug-report' ticket and
+a single 'bug-fix' ticket for each milestone/branch of
+development), for managing sub-tasks of an issue and for managing
+'bug-fixes' required when developing a new (larger) enhancement.
+
+This plugin modifies the ticket description box and adds a child
+ticket listing table and a 'create' button for adding new child
+tickets. It has the following features:
+
+It is possible to control in trac.ini the following aspects of
+child-ticket creation/viewing:
+
+ allow/disallow child-tickets for a certain type of ticket
+ to define the table headers displayed in the parent ticket
+ to define a default for the child type to be created
+ restrict the type of child-tickets
+ to define which fields are inherited by child-tickets
+
+WWW: http://trac-hacks.org/wiki/ChildTicketsPlugin