aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-12-12 23:29:17 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-12-12 23:29:17 +0000
commita267d4e865b08ae93c52e4f24adb8c9f69166a41 (patch)
tree98aa239ee8d1685d38f0684f972777ad2fb17822 /www
parentddb8318f789741610b0ba319a367bbb4d724065c (diff)
downloadports-a267d4e865b08ae93c52e4f24adb8c9f69166a41.tar.gz
ports-a267d4e865b08ae93c52e4f24adb8c9f69166a41.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mod_ntlm/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/mod_ntlm/Makefile b/www/mod_ntlm/Makefile
index 01209739c4c1..d1f1b4249dd5 100644
--- a/www/mod_ntlm/Makefile
+++ b/www/mod_ntlm/Makefile
@@ -17,12 +17,17 @@ COMMENT= NTLM authentication module for the Apache webserver
USE_APACHE= YES
MAKE_ENV= APXS=${APXS}
+.include <bsd.port.pre.mk>
+
post-patch:
${FIND} ${WRKSRC}/smbval -name "*.inc.c" -type f|${XARGS} \
${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/g"
${REINPLACE_CMD} -e "s/APXS=.*//" ${WRKSRC}/Makefile
${REINPLACE_CMD} -e "s!#include <sys/vfs.*!!" \
${WRKSRC}/smbval/smbencrypt.inc.c
+.if ${OSVERSION} >= 700042
+ ${REINPLACE_CMD} -e "s/extern/static/" ${WRKSRC}/smbval/smblib-priv.h
+.endif
post-install:
.ifndef(NOPORTDOCS)
@@ -31,10 +36,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Documentation/mod_ntlm.html ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.include <bsd.port.post.mk>