aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-30 10:25:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-30 10:25:34 +0000
commit2df76eb0a73bb59d817aa60758a5f10e3e544c3b (patch)
tree07e10c49034b87755dafb03956ad93c5363e0bb7 /www
parent1c97f613254a72e0ae97ea8d817ebe38096d6949 (diff)
downloadports-2df76eb0a73bb59d817aa60758a5f10e3e544c3b.tar.gz
ports-2df76eb0a73bb59d817aa60758a5f10e3e544c3b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/cgihtml/files/Makefile6
-rw-r--r--www/libwww/Makefile1
-rw-r--r--www/qdecoder/Makefile5
-rw-r--r--www/qdecoder/pkg-plist5
-rw-r--r--www/ump/Makefile5
5 files changed, 5 insertions, 17 deletions
diff --git a/www/cgihtml/files/Makefile b/www/cgihtml/files/Makefile
index 907544c6a9fa..10ce3c33e774 100644
--- a/www/cgihtml/files/Makefile
+++ b/www/cgihtml/files/Makefile
@@ -1,13 +1,9 @@
+# $FreeBSD$
# Makefile for cgihtml libraries
LIB = cgihtml
MAJ = 1
-MIN = 0
-.if ($(PORTOBJFORMAT) == "elf")
SHLIB_VER = $(MAJ)
-.else
-SHLIB_VER = $(MAJ).$(MIN)
-.endif
OBJS = string-lib.o cgi-llist.o cgi-lib.o html-lib.o
HDRS = ${OBJS:.o=.h}
diff --git a/www/libwww/Makefile b/www/libwww/Makefile
index 9f6666c74d8b..e6c7953f78e7 100644
--- a/www/libwww/Makefile
+++ b/www/libwww/Makefile
@@ -21,7 +21,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-shared --enable-static --with-zlib
USE_PERL5_BUILD=yes
-MAKE_ENV= objformat=${PORTOBJFORMAT}
USE_LDCONFIG= yes
post-patch:
diff --git a/www/qdecoder/Makefile b/www/qdecoder/Makefile
index 51bdf6b2f59a..b66b870aecad 100644
--- a/www/qdecoder/Makefile
+++ b/www/qdecoder/Makefile
@@ -14,10 +14,10 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= cjh@FreeBSD.org
COMMENT= CGI library for C/C++ language programming
-GNU_CONFIGURE= YES
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
post-install:
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
${MKDIR} ${PREFIX}/share/doc/qDecoder
.for doc in AUTHORS DISCLAIMER README REFERENCE qDecoder.jpg
${INSTALL_DATA} ${WRKSRC}/${doc} ${PREFIX}/share/doc/qDecoder
@@ -31,5 +31,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/examples/*.html ${PREFIX}/share/examples/qDecoder
${INSTALL_DATA} ${WRKSRC}/examples/*.in ${PREFIX}/share/examples/qDecoder
-
.include <bsd.port.mk>
diff --git a/www/qdecoder/pkg-plist b/www/qdecoder/pkg-plist
index f6b21f7fb4b7..213c180a5bec 100644
--- a/www/qdecoder/pkg-plist
+++ b/www/qdecoder/pkg-plist
@@ -1,10 +1,7 @@
include/qDecoder.h
lib/libqDecoder.a
+lib/libqDecoder.so
lib/libqDecoder.so.2
-@exec ln -sf %f %B/libqDecoder.so
-@unexec rm -f %B/libqDecoder.so
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/doc/qDecoder/AUTHORS
share/doc/qDecoder/DISCLAIMER
share/doc/qDecoder/README
diff --git a/www/ump/Makefile b/www/ump/Makefile
index 46a869fdcca7..5ae864f3e37c 100644
--- a/www/ump/Makefile
+++ b/www/ump/Makefile
@@ -38,6 +38,7 @@ TIMIDITY_VERSION= 2.13.2
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ump --with-default-path=${LOCALBASE}/share/timidity
+CONFIGURE_ENV= LDFLAGS=-export-dynamic
USE_GMAKE= yes
USE_XLIB= yes
USE_XPM= yes
@@ -64,10 +65,6 @@ CONFIGURE_ARGS+= --enable-audio=oss,esd
CONFIGURE_ARGS+= --enable-audio=oss
.endif
-.if ${PORTOBJFORMAT} == "elf"
-CONFIGURE_ENV= LDFLAGS=-export-dynamic
-.endif
-
post-extract:
@${MKDIR} ${WRKSRC}/ump
@for f in ${ZDIST:C/:.*$//}; do \