aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-15 11:44:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-15 11:44:30 +0000
commit484c7ef64b82fb849d2f249021d330448ada39fd (patch)
tree60d4d0c4c493215417acff55a7e731489dfb41c5 /www
parent322bff4f9d11b3820b129d9f2f1310d2a3a7fdc9 (diff)
downloadports-484c7ef64b82fb849d2f249021d330448ada39fd.tar.gz
ports-484c7ef64b82fb849d2f249021d330448ada39fd.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mkapachepw/Makefile29
-rw-r--r--www/mkapachepw/distinfo2
-rw-r--r--www/mkapachepw/pkg-descr15
-rw-r--r--www/mkapachepw/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index acb60a19d4a1..c8bda3c73757 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -226,6 +226,7 @@
SUBDIR += micro_httpd
SUBDIR += middleman
SUBDIR += mini_httpd
+ SUBDIR += mkapachepw
SUBDIR += mknmz-wwwoffle
SUBDIR += mmosaic
SUBDIR += mnogosearch
diff --git a/www/mkapachepw/Makefile b/www/mkapachepw/Makefile
new file mode 100644
index 000000000000..ec55f4f65766
--- /dev/null
+++ b/www/mkapachepw/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: apachepw
+# Date Created: 07 April 2005
+# Whom: tundra
+#
+# $FreeBSD$
+#
+
+PORTNAME= mkapachepw
+PORTVERSION= 1.121
+CATEGORIES= www
+MASTER_SITES= http://www.tundraware.com/Software/mkapachepw/
+
+MAINTAINER= mkapachepw@tundraware.com
+COMMENT= A Group & Password Management Tool For Apache
+
+USE_PYTHON= yes
+
+MANCOMPRESSED= yes
+MAN1= mkapachepw.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in WHATSNEW.txt mkapachepw-license.txt mkapachepw.html mkapachepw.pdf mkapachepw.ps mkapachepw.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mkapachepw/distinfo b/www/mkapachepw/distinfo
new file mode 100644
index 000000000000..6e4287c54328
--- /dev/null
+++ b/www/mkapachepw/distinfo
@@ -0,0 +1,2 @@
+MD5 (mkapachepw-1.121.tar.gz) = c3684b613f124e6425085be0113241ae
+SIZE (mkapachepw-1.121.tar.gz) = 117088
diff --git a/www/mkapachepw/pkg-descr b/www/mkapachepw/pkg-descr
new file mode 100644
index 000000000000..a532fb6446f9
--- /dev/null
+++ b/www/mkapachepw/pkg-descr
@@ -0,0 +1,15 @@
+'mkapachepw' is an Apache user/group management package with a rich set of
+features:
+
+ - automatically create apache users/groups from underlying os users/groups
+ - break large, complex user & group data into separately managed files
+ - specify which particular users/groups are to be included or excluded
+ - catch (and prevent) redefinition of user/groups
+
+'mkapachepw' is a pure-Python application and should run on any Unix system
+that support Python 2.4 or later.
+
+'mkapachepw' is free for individual, non-commerical, personal use. Use in any
+setting where there is any remuneration, direct or indirect, requires payment
+of a licensing fee. Individual, multiple, and enterprise licensing is
+available. Contact mkapachepw@tundraware.com for current pricing.
diff --git a/www/mkapachepw/pkg-plist b/www/mkapachepw/pkg-plist
new file mode 100644
index 000000000000..97987f2a4106
--- /dev/null
+++ b/www/mkapachepw/pkg-plist
@@ -0,0 +1,8 @@
+bin/mkapachepw.py
+%%PORTDOCS%%%%DOCSDIR%%/WHATSNEW.txt
+%%PORTDOCS%%%%DOCSDIR%%/mkapachepw-license.txt
+%%PORTDOCS%%%%DOCSDIR%%/mkapachepw.html
+%%PORTDOCS%%%%DOCSDIR%%/mkapachepw.pdf
+%%PORTDOCS%%%%DOCSDIR%%/mkapachepw.ps
+%%PORTDOCS%%%%DOCSDIR%%/mkapachepw.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%