aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-12-13 21:06:18 +0000
committerClement Laforet <clement@FreeBSD.org>2004-12-13 21:06:18 +0000
commit803d50b3db9e046e091a7aa70a1dab822b9b1725 (patch)
treed71ee6460fd80f098abb55ab186839243231df84 /www
parent19ece46a2743b9b3dd362ea9d83ec7f3664ee6f2 (diff)
downloadports-803d50b3db9e046e091a7aa70a1dab822b9b1725.tar.gz
ports-803d50b3db9e046e091a7aa70a1dab822b9b1725.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/apache13-ssl/Makefile1
-rw-r--r--www/apache13-ssl/files/patch-Makefile.tmpl44
-rw-r--r--www/apache13-ssl/pkg-plist34
3 files changed, 46 insertions, 33 deletions
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index 353398aa4d61..d4260684a900 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -38,6 +38,7 @@ USE_PERL5= yes
HAS_CONFIGURE= yes
USE_RC_SUBR= yes
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} WWWOWN=${WWWOWN}
+MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
MASTER_SITES_APACHE_SSL= \
ftp://ftp.ox.ac.uk/pub/crypto/SSL/Apache-SSL/ \
diff --git a/www/apache13-ssl/files/patch-Makefile.tmpl b/www/apache13-ssl/files/patch-Makefile.tmpl
index c07cc063ec0b..9d5d458d913e 100644
--- a/www/apache13-ssl/files/patch-Makefile.tmpl
+++ b/www/apache13-ssl/files/patch-Makefile.tmpl
@@ -1,6 +1,6 @@
---- Makefile.tmpl.orig Mon Apr 28 15:32:12 2003
-+++ Makefile.tmpl Wed Oct 22 22:59:14 2003
-@@ -270,10 +270,10 @@
+--- Makefile.tmpl.orig Fri Feb 20 23:40:50 2004
++++ Makefile.tmpl Mon Dec 13 21:59:00 2004
+@@ -226,10 +226,10 @@
$(MKDIR) $(root)$(mandir)/man1
$(MKDIR) $(root)$(mandir)/man8
$(MKDIR) $(root)$(sysconfdir)
@@ -13,7 +13,7 @@
$(MKDIR) $(root)$(includedir)
$(MKDIR) $(root)$(includedir)/xml
$(MKDIR) $(root)$(runtimedir)
-@@ -459,33 +459,29 @@
+@@ -415,33 +415,29 @@
# icons and distributed CGI scripts.
install-data:
@echo "===> [data: Installing initial data files]"
@@ -60,7 +60,7 @@
@echo "Copying tree $(TOP)/icons/ -> $(root)$(iconsdir)/"; \
(cd $(TOP)/icons/ && $(TAR) $(TAROPT) - *) |\
(cd $(root)$(iconsdir)/ && $(TAR) -xf -); \
-@@ -506,7 +502,7 @@
+@@ -462,7 +458,7 @@
if [ ".$(TARGET)" = .httpd ]; then \
target_prefix=""; \
else \
@@ -69,7 +69,7 @@
fi; \
(echo "##"; \
echo "## $${target_conf} -- Apache HTTP server configuration file"; \
-@@ -524,10 +520,10 @@
+@@ -480,10 +476,10 @@
-e 's;logs/accept\.lock;$(runtimedir)/$(TARGET).lock;' \
-e 's;logs/apache_runtime_status;$(runtimedir)/$(TARGET).scoreboard;' \
-e 's;logs/httpd\.pid;$(runtimedir)/$(TARGET).pid;' \
@@ -84,25 +84,35 @@
-e 's;conf/magic;$(sysconfdir)/magic;' \
-e 's;conf/srm.conf;$(sysconfdir)/srm.conf;' \
-e 's;conf/access.conf;$(sysconfdir)/access.conf;' \
-@@ -539,8 +535,8 @@
+@@ -495,21 +491,22 @@
-e 's;ServerAdmin you@your.address;ServerAdmin $(conf_serveradmin);' \
-e 's;ServerName new.host.name;ServerName $(conf_servername);' \
> $(TOP)/$(SRC)/.apaci.install.tmp && \
- echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(sysconfdir)/$${target_conf}.default"; \
- $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(sysconfdir)/$${target_conf}.default; \
-+ echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(sysconfdir)/$${target_conf}-dist"; \
-+ $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(sysconfdir)/$${target_conf}-dist; \
- if [ ! -f "$(root)$(sysconfdir)/$${target_conf}" ]; then \
- echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(sysconfdir)/$${target_conf}"; \
- $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(sysconfdir)/$${target_conf}; \
-@@ -549,8 +545,8 @@
+- if [ ! -f "$(root)$(sysconfdir)/$${target_conf}" ]; then \
+- echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(sysconfdir)/$${target_conf}"; \
+- $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(sysconfdir)/$${target_conf}; \
++ mkdir -p $(root)$(EXAMPLESDIR) ; \
++ echo "$(INSTALL_DATA) $(TOP)/conf/$${conf}-dist[*] $(root)$(EXAMPLESDIR)/$${target_conf}-dist"; \
++ $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(EXAMPLESDIR)/$${target_conf}-dist; \
++ if [ ! -f "$(root)$(sysconfdir)/$${target_conf}" ]; then \
++ echo "$(INSTALL_DATA) $(root)$(EXAMPLESDIR)/$${target_conf}-dist $(root)$(sysconfdir)/$${target_conf}"; \
++ $(INSTALL_DATA) $(root)$(EXAMPLESDIR)/$${target_conf}-dist $(root)$(sysconfdir)/$${target_conf}; \
+ else \
+ echo "[PRESERVING EXISTING CONFIG FILE: $(root)$(sysconfdir)/$${target_conf}]"; \
fi; \
done
-@for conf in mime.types magic; do \
- echo "$(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}.default"; \
- $(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}.default; \
-+ echo "$(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}-dist"; \
-+ $(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}-dist; \
++ mkdir -p $(root)$(EXAMPLESDIR) ; \
++ echo "$(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(EXAMPLESDIR)/$${conf}-dist"; \
++ $(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(EXAMPLESDIR)/$${conf}-dist; \
if [ ! -f "$(root)$(sysconfdir)/$${conf}" ]; then \
- echo "$(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}"; \
- $(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}; \
+- echo "$(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}"; \
+- $(INSTALL_DATA) $(TOP)/conf/$${conf} $(root)$(sysconfdir)/$${conf}; \
++ $(INSTALL_DATA) $(root)$(EXAMPLESDIR)/$${conf}-dist $(root)$(sysconfdir)/$${conf}; \
+ else \
+ echo "[PRESERVING EXISTING CONFIG FILE: $(root)$(sysconfdir)/$${conf}]"; \
+ fi; \
diff --git a/www/apache13-ssl/pkg-plist b/www/apache13-ssl/pkg-plist
index e9b9b012d41f..3090e36a6a1f 100644
--- a/www/apache13-ssl/pkg-plist
+++ b/www/apache13-ssl/pkg-plist
@@ -3,22 +3,23 @@ bin/checkgid
bin/dbmmanage
bin/htdigest
bin/htpasswd
+@exec mkdir -p %D/etc/apache 2> /dev/null
etc/rc.d/apache.sh
-@unexec if cmp -s %D/etc/apache/access.conf %D/etc/apache/access.conf-dist; then rm -f %D/etc/apache/access.conf; fi
-etc/apache/access.conf-dist
-@exec [ -f %B/access.conf ] || cp %B/%f %B/access.conf
-@unexec if cmp -s %D/etc/apache/httpsd.conf %D/etc/apache/httpsd.conf-dist; then rm -f %D/etc/apache/httpsd.conf; fi
-etc/apache/httpsd.conf-dist
-@exec [ -f %B/httpsd.conf ] || cp %B/%f %B/httpsd.conf
-@unexec if cmp -s %D/etc/apache/magic %D/etc/apache/magic-dist; then rm -f %D/etc/apache/magic; fi
-etc/apache/magic-dist
-@exec [ -f %B/magic ] || cp %B/%f %B/magic
-@unexec if cmp -s %D/etc/apache/mime.types %D/etc/apache/mime.types-dist; then rm -f %D/etc/apache/mime.types; fi
-etc/apache/mime.types-dist
-@exec [ -f %B/mime.types ] || cp %B/%f %B/mime.types
-@unexec if cmp -s %D/etc/apache/srm.conf %D/etc/apache/srm.conf-dist; then rm -f %D/etc/apache/srm.conf; fi
-etc/apache/srm.conf-dist
-@exec [ -f %B/srm.conf ] || cp %B/%f %B/srm.conf
+@unexec if cmp -s %D/etc/apache/access.conf% %D/%%EXAMPLESDIR%%/access.conf-dist; then rm -f %D/etc/apache/access.conf%; fi
+%%EXAMPLESDIR%%/access.conf-dist
+@exec [ -f %D/etc/apache/access.conf% ] || cp %D/%%EXAMPLESDIR%%/access.conf-dist %D/etc/apache/access.conf
+@unexec if cmp -s %D/etc/apache/httpsd.conf% %D/%%EXAMPLESDIR%%/httpsd.conf-dist; then rm -f %D/etc/apache/httpsd.conf%; fi
+%%EXAMPLESDIR%%/httpsd.conf-dist
+@exec [ -f %D/etc/apache/httpsd.conf% ] || cp %D/%%EXAMPLESDIR%%/httpsd.conf-dist %D/etc/apache/httpsd.conf
+@unexec if cmp -s %D/etc/apache/magic% %D/%%EXAMPLESDIR%%/magic-dist; then rm -f %D/etc/apache/magic%; fi
+%%EXAMPLESDIR%%/magic-dist
+@exec [ -f %D/etc/apache/magic% ] || cp %D/%%EXAMPLESDIR%%/magic-dist %D/etc/apache/magic
+@unexec if cmp -s %D/etc/apache/mime.types% %D/%%EXAMPLESDIR%%/mime.types-dist; then rm -f %D/etc/apache/mime.types%; fi
+%%EXAMPLESDIR%%/mime.types-dist
+@exec [ -f %D/etc/apache/mime.types% ] || cp %D/%%EXAMPLESDIR%%/mime.types-dist %D/etc/apache/mime.types
+@unexec if cmp -s %D/etc/apache/srm.conf% %D/%%EXAMPLESDIR%%/srm.conf-dist; then rm -f %D/etc/apache/srm.conf%; fi
+%%EXAMPLESDIR%%/srm.conf-dist
+@exec [ -f %D/etc/apache/srm.conf% ] || cp %D/%%EXAMPLESDIR%%/srm.conf-dist %D/etc/apache/srm.conf
include/apache/ap.h
include/apache/ap_alloc.h
include/apache/ap_compat.h
@@ -632,7 +633,7 @@ www/icons/world1.png
www/icons/world2.gif
www/icons/world2.png
@exec mkdir -p %D/www/proxy
-@unexec rm -f %D/etc/apache2/httpd.conf.bak 2> /dev/null || true
+@unexec rm -f %D/etc/apache/httpsd.conf.bak 2> /dev/null || true
@unexec rmdir %D/etc/apache 2> /dev/null || true
@dirrm include/apache/xml
@dirrm include/apache
@@ -651,3 +652,4 @@ www/icons/world2.png
@dirrm www/icons/small
@dirrm www/icons
@dirrm www/proxy
+@dirrm %%EXAMPLESDIR%%