aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2011-08-30 23:57:21 +0000
committerAnders Nordby <anders@FreeBSD.org>2011-08-30 23:57:21 +0000
commit81b2b426df17ee0d77055003dfe5ef2ffa96fc10 (patch)
treed42b0548f429e9c873d4a643f2b1f6a66d3b1982 /www
parentf34c47019a0684ff3a88a3226f5f3c0787e68db3 (diff)
downloadports-81b2b426df17ee0d77055003dfe5ef2ffa96fc10.tar.gz
ports-81b2b426df17ee0d77055003dfe5ef2ffa96fc10.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/varnish-libvmod-header/Makefile46
-rw-r--r--www/varnish-libvmod-header/distinfo2
-rw-r--r--www/varnish-libvmod-header/files/patch-configure.ac27
-rw-r--r--www/varnish-libvmod-header/files/patch-src-Makefile.am13
-rw-r--r--www/varnish-libvmod-header/files/patch-src-vmod_header.c13
-rw-r--r--www/varnish-libvmod-header/pkg-descr4
-rw-r--r--www/varnish-libvmod-header/pkg-message2
-rw-r--r--www/varnish-libvmod-header/pkg-plist3
9 files changed, 111 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 21515a6c05b3..dada3e4dffa1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1883,6 +1883,7 @@
SUBDIR += uzbl
SUBDIR += validator
SUBDIR += varnish
+ SUBDIR += varnish-libvmod-header
SUBDIR += varnish2
SUBDIR += vdr-plugin-live
SUBDIR += vdradmin-am
diff --git a/www/varnish-libvmod-header/Makefile b/www/varnish-libvmod-header/Makefile
new file mode 100644
index 000000000000..6a07212fa2ae
--- /dev/null
+++ b/www/varnish-libvmod-header/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: varnish-libvmod-header
+# Date created: 2011-08-23
+# Whom: anders
+#
+# $FreeBSD$
+#
+
+PORTNAME= libvmod-header
+DISTVERSION= 0.3-3
+CATEGORIES= www
+MASTER_SITES= https://github.com/KristianLyng/libvmod-header/tarball/master/
+PKGNAMEPREFIX= varnish-
+DISTNAME= KristianLyng-${PORTNAME}-${VMOD_HEADER_HASH}
+DISTFILES= KristianLyng-${PORTNAME}-0.3-3-g${VMOD_HEADER_HASH}.tar.gz
+
+MAINTAINER= anders@FreeBSD.org
+COMMENT= Varnish Module (vmod) for manipulation of duplicated headers
+
+LICENSE= BSD
+
+BUILD_DEPENDS= ${LOCALBASE}/include/varnish/varnishapi.h:${PORTSDIR}/www/varnish \
+ rst2man:${PORTSDIR}/textproc/py-docutils
+
+FETCH_ARGS= -Fpr
+
+USE_AUTOTOOLS= aclocal libtool libtoolize autoheader automake autoconf
+USE_GMAKE= yes
+ACLOCAL_ARGS= -I m4
+LIBTOOLFLAGS= --copy --force
+AUTOMAKE_ARGS= --add-missing --copy --foreign
+CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/varnish
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/varnish
+
+VMOD_HEADER_HASH= 232741d
+
+MAN3= vmod_header.3
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/varnish-libvmod-header/distinfo b/www/varnish-libvmod-header/distinfo
new file mode 100644
index 000000000000..5e91174db9d3
--- /dev/null
+++ b/www/varnish-libvmod-header/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KristianLyng-libvmod-header-0.3-3-g232741d.tar.gz) = e03512adb5cf267ddbc600a616f78cf06c7136ffbe6ccd52fd3441d366705b71
+SIZE (KristianLyng-libvmod-header-0.3-3-g232741d.tar.gz) = 8814
diff --git a/www/varnish-libvmod-header/files/patch-configure.ac b/www/varnish-libvmod-header/files/patch-configure.ac
new file mode 100644
index 000000000000..d6b5ee7ed884
--- /dev/null
+++ b/www/varnish-libvmod-header/files/patch-configure.ac
@@ -0,0 +1,27 @@
+--- configure.ac.orig 2011-08-12 15:36:55.000000000 +0200
++++ configure.ac 2011-08-30 01:46:23.000000000 +0200
+@@ -39,22 +39,8 @@
+ # Check for python
+ AC_CHECK_PROGS(PYTHON, [python3 python3.1 python3.2 python2.7 python2.6 python2.5 python2 python], [AC_MSG_ERROR([Python is needed to build this vmod, please install python.])])
+
+-# Varnish source tree
+-AC_ARG_VAR([VARNISHSRC], [path to Varnish source tree (mandatory)])
+-if test "x$VARNISHSRC" = x; then
+- AC_MSG_ERROR([No Varnish source tree specified])
+-fi
+-VARNISHSRC=`cd $VARNISHSRC && pwd`
+-AC_CHECK_FILE([$VARNISHSRC/include/varnishapi.h],
+- [],
+- [AC_MSG_FAILURE(["$VARNISHSRC" is not a Varnish source directory])]
+-)
+-
+-# Check that varnishtest is built in the varnish source directory
+-AC_CHECK_FILE([$VARNISHSRC/bin/varnishtest/varnishtest],
+- [],
+- [AC_MSG_FAILURE([Can't find "$VARNISHSRC/bin/varnishtest/varnishtest". Please build your varnish source directory])]
+-)
++AC_CHECK_HEADERS([varnish/varnishapi.h], , AC_MSG_ERROR([Could not find varnish/varnishapi.h]))
++AC_CHECK_PROGS(VARNISHTEST, varnishtest, [AC_MSG_ERROR([Could not find varnishtest binary])])
+
+ # vmod installation dir
+ AC_ARG_VAR([VMODDIR], [vmod installation directory @<:@LIBDIR/varnish/vmods@:>@])
diff --git a/www/varnish-libvmod-header/files/patch-src-Makefile.am b/www/varnish-libvmod-header/files/patch-src-Makefile.am
new file mode 100644
index 000000000000..a6cd1c57fa4d
--- /dev/null
+++ b/www/varnish-libvmod-header/files/patch-src-Makefile.am
@@ -0,0 +1,13 @@
+--- src/Makefile.am.orig 2011-08-31 00:29:01.000000000 +0200
++++ src/Makefile.am 2011-08-31 00:29:52.000000000 +0200
+@@ -10,8 +10,8 @@
+ vcc_if.h \
+ vmod_header.c
+
+-vcc_if.c vcc_if.h: $(VARNISHSRC)/lib/libvmod_std/vmod.py $(top_srcdir)/src/vmod_header.vcc
+- @PYTHON@ $(VARNISHSRC)/lib/libvmod_std/vmod.py $(top_srcdir)/src/vmod_header.vcc
++vcc_if.c vcc_if.h: $(LOCALBASE)/share/varnish/vmod.py $(top_srcdir)/src/vmod_header.vcc
++ @PYTHON@ $(LOCALBASE)/share/varnish/vmod.py $(top_srcdir)/src/vmod_header.vcc
+
+ VMOD_TESTS = tests/*.vtc
+ .PHONY: $(VMOD_TESTS)
diff --git a/www/varnish-libvmod-header/files/patch-src-vmod_header.c b/www/varnish-libvmod-header/files/patch-src-vmod_header.c
new file mode 100644
index 000000000000..c352ddf1cbb6
--- /dev/null
+++ b/www/varnish-libvmod-header/files/patch-src-vmod_header.c
@@ -0,0 +1,13 @@
+--- src/vmod_header.c.orig 2011-08-31 00:58:34.000000000 +0200
++++ src/vmod_header.c 2011-08-31 00:59:08.000000000 +0200
+@@ -30,8 +30,8 @@
+ #include <pthread.h>
+
+ #include "vrt.h"
+-#include "bin/varnishd/cache.h"
+-#include "include/vct.h"
++#include "varnish/cache.h"
++#include "vct.h"
+
+ #include "vcc_if.h"
+ #include "config.h"
diff --git a/www/varnish-libvmod-header/pkg-descr b/www/varnish-libvmod-header/pkg-descr
new file mode 100644
index 000000000000..31f233b56184
--- /dev/null
+++ b/www/varnish-libvmod-header/pkg-descr
@@ -0,0 +1,4 @@
+Varnish Module (vmod) for manipulation of duplicated headers (for
+instance multiple set-cookie headers).
+
+WWW: https://github.com/KristianLyng/libvmod-header/
diff --git a/www/varnish-libvmod-header/pkg-message b/www/varnish-libvmod-header/pkg-message
new file mode 100644
index 000000000000..063107f325af
--- /dev/null
+++ b/www/varnish-libvmod-header/pkg-message
@@ -0,0 +1,2 @@
+For information on how to use the header module, see
+https://github.com/KristianLyng/libvmod-header/.
diff --git a/www/varnish-libvmod-header/pkg-plist b/www/varnish-libvmod-header/pkg-plist
new file mode 100644
index 000000000000..f67625d4613c
--- /dev/null
+++ b/www/varnish-libvmod-header/pkg-plist
@@ -0,0 +1,3 @@
+lib/varnish/vmods/libvmod_header.so
+lib/varnish/vmods/libvmod_header.la
+lib/varnish/vmods/libvmod_header.a