aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-02-11 15:03:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-02-11 15:03:36 +0000
commit820e3c57ea58099de9405f9f78c5ceb2d40ff3bc (patch)
tree2b458829b2d32b116ab8cbf627d853a7aaa73def /www
parent289c0fb9c9bcb909c7b608ba48ec36547d8d654b (diff)
downloadports-820e3c57ea58099de9405f9f78c5ceb2d40ff3bc.tar.gz
ports-820e3c57ea58099de9405f9f78c5ceb2d40ff3bc.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/p5-Apache-Peek/Makefile30
-rw-r--r--www/p5-Apache-Peek/distinfo3
-rw-r--r--www/p5-Apache-Peek/pkg-descr5
-rw-r--r--www/p5-Apache-Peek/pkg-plist2
4 files changed, 23 insertions, 17 deletions
diff --git a/www/p5-Apache-Peek/Makefile b/www/p5-Apache-Peek/Makefile
index 426d1be01add..b70d596ab73f 100644
--- a/www/p5-Apache-Peek/Makefile
+++ b/www/p5-Apache-Peek/Makefile
@@ -6,26 +6,30 @@
#
PORTNAME= Apache-Peek
-PORTVERSION= 0.9501
+PORTVERSION= 1.01
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR=Apache
PKGNAMEPREFIX= p5-
-MAINTAINER= leo@florida.sarang.net
-COMMENT= A perl5 data debugging tool for the XS programmer
-
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache/src.pm:${PORTSDIR}/www/mod_perl \
- ${SITE_PERL}/B/Graph.pm:${PORTSDIR}/devel/p5-B-Graph
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A data debugging tool for the XS programmer (under mod_perl)
+
+.if defined(WITH_MODPERL2)
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/mod_perl.pm:${PORTSDIR}/www/mod_perl2 \
+ ${SITE_PERL}/Apache2/Test.pm:${PORTSDIR}/www/p5-Apache-Test
+MOD_PERL= 2
+.else
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
+MOD_PERL= 1
+.endif
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
-MAN3= Apache::Peek.3
-
-.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= -httpd ${LOCALBASE}/sbin/httpd
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
+MAN3= Apache::Peek.3
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Peek/distinfo b/www/p5-Apache-Peek/distinfo
index 579b3f93511c..702c4795042f 100644
--- a/www/p5-Apache-Peek/distinfo
+++ b/www/p5-Apache-Peek/distinfo
@@ -1 +1,2 @@
-MD5 (Apache-Peek-0.9501.tar.gz) = aadaa2f9a37cba78d614e3ba9fd630e8
+MD5 (Apache-Peek-1.01.tar.gz) = 8807a259aec05e324d48aef7780d2272
+SIZE (Apache-Peek-1.01.tar.gz) = 26295
diff --git a/www/p5-Apache-Peek/pkg-descr b/www/p5-Apache-Peek/pkg-descr
index c190436dd2f3..6fcb2fd3be9e 100644
--- a/www/p5-Apache-Peek/pkg-descr
+++ b/www/p5-Apache-Peek/pkg-descr
@@ -1,7 +1,6 @@
-Apache::Peek is Ilya Zakharevich's Devel::Peek module that sends
-output to the browser instead of stderr.
+A data debugging tool for the XS programmer (under mod_perl)
-WWW: http://search.cpan.org/doc/DOUGM/mod_perl-1.24/apache-modlist.html
+WWW: http://stason.org
- Leo Kim
leo@florida.sarang.net
diff --git a/www/p5-Apache-Peek/pkg-plist b/www/p5-Apache-Peek/pkg-plist
index 310b29dd793b..5e9cdb7cfe36 100644
--- a/www/p5-Apache-Peek/pkg-plist
+++ b/www/p5-Apache-Peek/pkg-plist
@@ -3,3 +3,5 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Peek/Peek.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Peek/Peek.so
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Peek
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Apache 2>/dev/null || true