aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 07:56:43 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 07:56:43 +0000
commitddcc0de9218039c78eb34c7bc64fadb4dfe7a707 (patch)
treebee4ba075b3a0b4d3276fe1e92c704118abdbfe3 /www
parentfc366adb105b7bb2dc40e2a7e3e8c2022e37efe2 (diff)
downloadports-ddcc0de9218039c78eb34c7bc64fadb4dfe7a707.tar.gz
ports-ddcc0de9218039c78eb34c7bc64fadb4dfe7a707.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/amphetadesk/Makefile11
-rw-r--r--www/ljdeps/Makefile11
-rw-r--r--www/ljsm/Makefile12
-rw-r--r--www/p5-Apache-ASP/Makefile17
-rw-r--r--www/p5-Apache-Compress/Makefile14
-rw-r--r--www/p5-Apache-PageKit/Makefile15
-rw-r--r--www/p5-AxKit/Makefile16
-rw-r--r--www/p5-Bundle-Slash/Makefile13
-rw-r--r--www/p5-CGI-Compress-Gzip/Makefile15
-rw-r--r--www/p5-FEAR-API/Makefile15
-rw-r--r--www/p5-Jifty/Makefile18
-rw-r--r--www/p5-URI-Fetch/Makefile6
-rw-r--r--www/p5-WWW-Mechanize-GZip/Makefile15
-rw-r--r--www/p5-WWW-iTunesConnect/Makefile16
-rw-r--r--www/p5-libwww/Makefile5
15 files changed, 139 insertions, 60 deletions
diff --git a/www/amphetadesk/Makefile b/www/amphetadesk/Makefile
index f8f5b8b9234f..397ba8f54df5 100644
--- a/www/amphetadesk/Makefile
+++ b/www/amphetadesk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amphetadesk
PORTVERSION= 0.93.1
-PORTREVISION= 4
+PORTREVISION= 6
CATEGORIES= www perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-src/${PORTNAME}-src-v${PORTVERSION}
DISTNAME= ${PORTNAME}-src-v${PORTVERSION}
@@ -16,7 +16,6 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= RSS client that serves HTTP to your local web browser
RUN_DEPENDS= \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
@@ -45,6 +44,12 @@ PORTDOCS= \
*
.endif
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -type f -print0 | \
${XARGS} -0 -x -n 10 \
@@ -118,4 +123,4 @@ do-install:
${INSTALL_DATA} {} ${DATADIR}/{}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/ljdeps/Makefile b/www/ljdeps/Makefile
index 4e62e5164a82..3e4fb2f3f2ae 100644
--- a/www/ljdeps/Makefile
+++ b/www/ljdeps/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ljdeps
PORTVERSION= 1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www perl5
MASTER_SITES= # Undefined
DISTFILES= # Undefined
@@ -19,7 +19,6 @@ RUN_DEPENDS= ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet \
${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
${SITE_PERL}/MIME/Tools.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/URI/URL.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
@@ -38,6 +37,12 @@ EXTRACT_ONLY= # Empty
NO_BUILD= yes
USE_PERL5= yes
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
do-install: # Empty
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/ljsm/Makefile b/www/ljsm/Makefile
index a0c6026284ea..dfa3390850ce 100644
--- a/www/ljsm/Makefile
+++ b/www/ljsm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ljsm
PORTVERSION= 2.9
+PORTREVISION= 1
CATEGORIES= www perl5 deskutils
MASTER_SITES= http://www.offtopia.net/ljsm/
EXTRACT_SUFX= .zip
@@ -14,8 +15,7 @@ EXTRACT_SUFX= .zip
MAINTAINER= ports@FreeBSD.org
COMMENT= Livejournal.com postings recusive copy utility
-RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
PLIST_FILES= bin/ljsm
NO_WRKSUBDIR= yes
@@ -25,10 +25,16 @@ NO_BUILD= yes
EXTRACT_BEFORE_ARGS= -qoaa
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
do-configure:
@${REINPLACE_CMD} -e 's|^#!perl|#!${PERL}|' ${WRKSRC}/ljsm.pl
do-install:
cd ${WRKSRC} && ${INSTALL_SCRIPT} ljsm.pl ${PREFIX}/bin/ljsm
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-ASP/Makefile b/www/p5-Apache-ASP/Makefile
index 06cd21e6d2a0..de24fa98fcb5 100644
--- a/www/p5-Apache-ASP/Makefile
+++ b/www/p5-Apache-ASP/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Apache-ASP
PORTVERSION= 2.61
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,24 +16,23 @@ PKGNAMESUFFIX= ${MODPERL_SUFFIX}
MAINTAINER= perl@FreeBSD.org
COMMENT= Active Server Pages for Apache
-BUILD_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
+RUN_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
${SITE_PERL}/HTML/Clean.pm:${PORTSDIR}/www/p5-HTML-Clean \
${SITE_PERL}/HTML/FillInForm.pm:${PORTSDIR}/www/p5-HTML-FillInForm \
${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/MLDBM/Sync.pm:${PORTSDIR}/databases/p5-MLDBM-Sync \
${SITE_PERL}/Tie/Cache.pm:${PORTSDIR}/devel/p5-Tie-Cache \
${SITE_PERL}/XML/XSLT.pm:${PORTSDIR}/textproc/p5-XML-XSLT \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/${PERL_ARCH}/XML/Sablotron.pm:${PORTSDIR}/textproc/p5-XML-Sablotron
.if !defined(WITHOUT_MODPERL)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/Apache/Filter.pm:${PORTSDIR}/www/p5-Apache-Filter \
${SITE_PERL}/Apache/SSI.pm:${PORTSDIR}/www/p5-Apache-SSI
MODPERL_SUFFIX?=+mod_perl
.endif
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -43,4 +42,10 @@ MAN3= Apache::ASP.3 \
Bundle::Apache::ASP.3 \
Bundle::Apache::ASP::Extra.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Compress/Makefile b/www/p5-Apache-Compress/Makefile
index 2293977f4ad4..8e6be9bcad1d 100644
--- a/www/p5-Apache-Compress/Makefile
+++ b/www/p5-Apache-Compress/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Apache-Compress
PORTVERSION= 1.005
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,18 +15,25 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mm@FreeBSD.org
COMMENT= Auto-compress web files with Gzip
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache.pm:${PORTSDIR}/www/mod_perl \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache.pm:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache.pm:${PORTSDIR}/www/mod_perl
PERL_CONFIGURE= yes
MAN3= Apache::Compress.3
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Changes ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-PageKit/Makefile b/www/p5-Apache-PageKit/Makefile
index d10cc26f9b55..133f826d36e9 100644
--- a/www/p5-Apache-PageKit/Makefile
+++ b/www/p5-Apache-PageKit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Apache-PageKit
PORTVERSION= 1.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,10 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= MVCC web framework using mod_perl, XML and HTML::Template
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/Data/FormValidator.pm:${PORTSDIR}/textproc/p5-Data-FormValidator \
${SITE_PERL}/HTML/FillInForm.pm:${PORTSDIR}/www/p5-HTML-FillInForm \
${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
@@ -33,7 +32,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
${SITE_PERL}/${PERL_ARCH}/XML/LibXSLT.pm:${PORTSDIR}/textproc/p5-XML-LibXSLT \
${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
EXAMPLESDIR?= ${PREFIX}/share/examples/${PORTNAME}
PERL_CONFIGURE= 5.8.0+
@@ -44,6 +43,12 @@ MAN3= Apache::ErrorReport.3 \
Apache::PageKit::Model.3 \
Apache::PageKit::Session.3
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
post-build:
@${FIND} ${WRKSRC} -name '*.orig' -delete
@@ -79,4 +84,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-AxKit/Makefile b/www/p5-AxKit/Makefile
index 838bfe277b1f..244e83b62db0 100644
--- a/www/p5-AxKit/Makefile
+++ b/www/p5-AxKit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= AxKit
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= xml/axkit
@@ -16,8 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= XML Delivery Toolkit for Apache/Perl
-BUILD_DEPENDS= \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+RUN_DEPENDS= \
${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
${SITE_PERL}/${PERL_ARCH}/Apache/libapreq.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test \
@@ -29,7 +28,7 @@ BUILD_DEPENDS= \
${SITE_PERL}/Perl/Tidy.pm:${PORTSDIR}/devel/perltidy \
${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
MAKE_JOBS_SAFE= yes
@@ -67,6 +66,13 @@ CONFIGURE_ARGS= INC='-I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2' \
CONFIGURE_ENV+= PERL_EXTUTILS_AUTOINSTALL='--defaultdeps'
PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
@@ -74,4 +80,4 @@ post-install:
${CP} -R ${WRKSRC}/axkit.org ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-Bundle-Slash/Makefile b/www/p5-Bundle-Slash/Makefile
index c811485b8305..20126c43dccf 100644
--- a/www/p5-Bundle-Slash/Makefile
+++ b/www/p5-Bundle-Slash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Bundle-Slash
PORTVERSION= 2.52
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A bundle to install all modules used for Slash
-BUILD_DEPENDS= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree \
@@ -40,7 +39,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Z
${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
${SITE_PERL}/DBIx/Password.pm:${PORTSDIR}/databases/p5-DBIx-Password
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
USE_APACHE= 1.3+
@@ -48,8 +47,12 @@ USE_MYSQL= yes
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
.if ${APACHE_VERSION} == 13
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq \
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache/Cookie.pm:${PORTSDIR}/www/p5-libapreq \
${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
.endif
diff --git a/www/p5-CGI-Compress-Gzip/Makefile b/www/p5-CGI-Compress-Gzip/Makefile
index 3c2595da1355..67fb61f72379 100644
--- a/www/p5-CGI-Compress-Gzip/Makefile
+++ b/www/p5-CGI-Compress-Gzip/Makefile
@@ -7,6 +7,7 @@
PORTNAME= CGI-Compress-Gzip
PORTVERSION= 1.03
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CGI
@@ -15,13 +16,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= CGI::Compress::Gzip - CGI with automatically compressed output
-BUILD_DEPENDS= p5-IO-Zlib>=1.01:${PORTSDIR}/archivers/p5-IO-Zlib \
- p5-Compress-Zlib>=2:${PORTSDIR}/archivers/p5-Compress-Zlib
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= p5-IO-Zlib>=1.01:${PORTSDIR}/archivers/p5-IO-Zlib
+RUN_DEPENDS= p5-IO-Zlib>=1.01:${PORTSDIR}/archivers/p5-IO-Zlib
PERL_MODBUILD= yes
MAN3= CGI::Compress::Gzip.3 \
CGI::Compress::Gzip::FileHandle.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-FEAR-API/Makefile b/www/p5-FEAR-API/Makefile
index 4adc613d68d2..50c727528f76 100644
--- a/www/p5-FEAR-API/Makefile
+++ b/www/p5-FEAR-API/Makefile
@@ -8,7 +8,7 @@
PORTNAME= FEAR-API
PORTVERSION= 0.489
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ../by-authors/id/X/XE/XERN
@@ -17,8 +17,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Web Scraping Zen
-BUILD_DEPENDS= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib \
- p5-Email-Find>=0:${PORTSDIR}/mail/p5-Email-Find \
+RUN_DEPENDS= p5-Email-Find>=0:${PORTSDIR}/mail/p5-Email-Find \
p5-Exporter-Lite>=0:${PORTSDIR}/devel/p5-Exporter-Lite \
p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
@@ -45,7 +44,7 @@ BUILD_DEPENDS= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib \
p5-XML-RSS-SimpleGen>=0:${PORTSDIR}/textproc/p5-XML-RSS-SimpleGen \
p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -54,4 +53,10 @@ MAN3= FEAR::API.3 \
FEAR::API::Filters.3 \
FEAR::API::Document.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Jifty/Makefile b/www/p5-Jifty/Makefile
index 0318dc3713c6..2464d2ac1ed9 100644
--- a/www/p5-Jifty/Makefile
+++ b/www/p5-Jifty/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Jifty
PORTVERSION= 0.91117
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Jifty -- Just Do It -- Yet another web framework
-BUILD_DEPENDS= \
+RUN_DEPENDS= \
p5-App-CLI>=0.03:${PORTSDIR}/devel/p5-App-CLI \
p5-CGI-Cookie-Splitter>=0:${PORTSDIR}/www/p5-CGI-Cookie-Splitter \
p5-CSS-Squish>=0.05:${PORTSDIR}/textproc/p5-CSS-Squish \
@@ -27,7 +27,6 @@ BUILD_DEPENDS= \
p5-Class-Data-Inheritable>0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
p5-Class-Trigger>=0.12:${PORTSDIR}/devel/p5-Class-Trigger \
p5-Clone>0:${PORTSDIR}/devel/p5-Clone \
- p5-Compress-Zlib>0:${PORTSDIR}/archivers/p5-Compress-Zlib \
p5-Crypt-CBC>0:${PORTSDIR}/security/p5-Crypt-CBC \
p5-Crypt-Rijndael>0:${PORTSDIR}/security/p5-Crypt-Rijndael \
p5-DBD-SQLite>=1.11:${PORTSDIR}/databases/p5-DBD-SQLite \
@@ -93,12 +92,19 @@ BUILD_DEPENDS= \
p5-YAML-Syck>=0.71:${PORTSDIR}/textproc/p5-YAML-Syck \
p5-libwww>0:${PORTSDIR}/www/p5-libwww \
p5-version>0:${PORTSDIR}/devel/p5-version
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
+.include "Makefile.man"
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
post-patch:
${REINPLACE_CMD} -e '/auto_install/d' ${WRKSRC}/Makefile.PL
-.include "Makefile.man"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-URI-Fetch/Makefile b/www/p5-URI-Fetch/Makefile
index 068984c5c1d1..43bc91c3b414 100644
--- a/www/p5-URI-Fetch/Makefile
+++ b/www/p5-URI-Fetch/Makefile
@@ -7,7 +7,7 @@
PORTNAME= URI-Fetch
PORTVERSION= 0.080
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -30,7 +30,9 @@ MAN3= URI::Fetch.3 \
URI::Fetch::Response.3
.if !defined(WITHOUT_ZLIB)
-RUN_DEPENDS+= p5-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Zlib
+. if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+. endif
.endif
.if defined(WITH_CACHE)
diff --git a/www/p5-WWW-Mechanize-GZip/Makefile b/www/p5-WWW-Mechanize-GZip/Makefile
index 7c88e1729abe..4abd7dc7ce8d 100644
--- a/www/p5-WWW-Mechanize-GZip/Makefile
+++ b/www/p5-WWW-Mechanize-GZip/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WWW-Mechanize-GZip
PORTVERSION= 0.12
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Use WWW::Mechanize by requesting gzip-compression from the webserver
-RUN_DEPENDS= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
-BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+BUILD_DEPENDS= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
PERL_CONFIGURE= yes
MAN3= WWW::Mechanize::GZip.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-iTunesConnect/Makefile b/www/p5-WWW-iTunesConnect/Makefile
index 410350611b86..c102869d4f7d 100644
--- a/www/p5-WWW-iTunesConnect/Makefile
+++ b/www/p5-WWW-iTunesConnect/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WWW-iTunesConnect
PORTVERSION= 1.16
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,11 +16,10 @@ DISTNAME= ${PKGNAME}
MAINTAINER= bfoz@bfoz.net
COMMENT= Client interface for Apple's iTunes Connect service
-BUILD_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree \
+RUN_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree \
p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww \
- p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
- p5-IO-Compress-Zlib>=0:${PORTSDIR}/archivers/p5-IO-Compress-Zlib
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= YES
@@ -31,4 +31,10 @@ PLIST_DIRS= %%SITE_PERL%%/WWW \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/iTunesConnect \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-libwww/Makefile b/www/p5-libwww/Makefile
index 2ed69b0d7474..e23bec38525b 100644
--- a/www/p5-libwww/Makefile
+++ b/www/p5-libwww/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libwww
PORTVERSION= 5.836
+PORTREVISION= 1
CATEGORIES= www perl5 devel
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= LWP
@@ -38,7 +39,9 @@ MAN3= Bundle::LWP.3 File::Listing.3 HTML::Form.3 HTTP::Config.3 \
WWW::RobotRules::AnyDBM_File.3 lwpcook.3 lwptut.3
.include <bsd.port.pre.mk>
+
.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-Compress-Zlib>=1.10:${PORTSDIR}/archivers/p5-Compress-Zlib
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
.endif
+
.include <bsd.port.post.mk>