aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-01-22 07:51:24 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-01-22 07:51:24 +0000
commite2c1bce2a412a6dff0aabfa043065fc2537b0261 (patch)
treed76ae956f9276737962bdebe1d640f2757890b39 /www
parentc9e7344a403472475ec308cef27602364ef73c07 (diff)
downloadports-e2c1bce2a412a6dff0aabfa043065fc2537b0261.tar.gz
ports-e2c1bce2a412a6dff0aabfa043065fc2537b0261.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/youtube_dlc/Makefile6
-rw-r--r--www/youtube_dlc/distinfo6
-rw-r--r--www/youtube_dlc/files/extrapatch-manpages20
-rw-r--r--www/youtube_dlc/files/patch-Makefile67
-rw-r--r--www/youtube_dlc/files/patch-youtube__dlc_____init____.py6
-rw-r--r--www/youtube_dlc/files/patch-youtube__dlc_options.py12
-rw-r--r--www/youtube_dlc/pkg-plist5
7 files changed, 66 insertions, 56 deletions
diff --git a/www/youtube_dlc/Makefile b/www/youtube_dlc/Makefile
index ea9b004a4eac..fcc979677bf9 100644
--- a/www/youtube_dlc/Makefile
+++ b/www/youtube_dlc/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= youtube_dlc
-DISTVERSION= 2020.11.11-3
+DISTVERSION= 2021.01.16
CATEGORIES= www
# Implicit approval to commit trivial version updates.
@@ -14,8 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake python shebangfix
SHEBANG_GLOB= devscripts/*.py
USE_GITHUB= yes
-GH_ACCOUNT= blackjack4494
-GH_PROJECT= yt-dlc
+GH_ACCOUNT= pukkandan
+GH_PROJECT= yt-dlp
MAKE_ARGS= PYTHON=${PYTHON_CMD}
NO_ARCH= yes
diff --git a/www/youtube_dlc/distinfo b/www/youtube_dlc/distinfo
index 57cbefb9bbcc..cfca20f4613d 100644
--- a/www/youtube_dlc/distinfo
+++ b/www/youtube_dlc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1605281525
-SHA256 (blackjack4494-yt-dlc-2020.11.11-3_GH0.tar.gz) = 649f8ba9a6916ca45db0b81fbcec3485e79895cec0f29fd25ec33520ffffca84
-SIZE (blackjack4494-yt-dlc-2020.11.11-3_GH0.tar.gz) = 1500493
+TIMESTAMP = 1610922456
+SHA256 (pukkandan-yt-dlp-2021.01.16_GH0.tar.gz) = d413b956c8fdbf9d06165fe41d62f3b90ff42b1bb47d7d13df74a247eba24801
+SIZE (pukkandan-yt-dlp-2021.01.16_GH0.tar.gz) = 1526122
diff --git a/www/youtube_dlc/files/extrapatch-manpages b/www/youtube_dlc/files/extrapatch-manpages
index fba1aa53a43e..4b0bb6f0510e 100644
--- a/www/youtube_dlc/files/extrapatch-manpages
+++ b/www/youtube_dlc/files/extrapatch-manpages
@@ -1,23 +1,23 @@
---- Makefile.orig 2020-10-25 01:01:48 UTC
+--- Makefile.orig 2021-01-17 23:11:52 UTC
+++ Makefile
-@@ -1,4 +1,4 @@
--all: youtube-dlc youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish supportedsites
-+all: youtube-dlc youtube-dlc.1 youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish supportedsites
+@@ -1,6 +1,6 @@
+ all: youtube-dlc man
+ #doc: README.md CONTRIBUTING.md issuetemplates supportedsites
+-man: youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish
++man: youtube-dlc.1 youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish
+
clean:
- rm -rf youtube-dlc.1.temp.md youtube-dlc.1 youtube-dlc.bash-completion README.txt MANIFEST build/ dist/ .coverage cover/ youtube-dlc.tar.gz youtube-dlc.zsh youtube-dlc.fish youtube_dlc/extractor/lazy_extractors.py *.dump *.part* *.ytdl *.info.json *.mp4 *.m4a *.flv *.mp3 *.avi *.mkv *.webm *.3gp *.wav *.ape *.swf *.jpg *.png CONTRIBUTING.md.tmp youtube-dlc youtube-dlc.exe
-@@ -20,8 +20,8 @@ MARKDOWN = $(shell if [ `pandoc -v | head -n1 | cut -d
+@@ -24,6 +24,8 @@ MARKDOWN = $(shell if [ `pandoc -v | head -n1 | cut -d
install: youtube-dlc youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish
install -d $(DESTDIR)$(BINDIR)
install -m 755 youtube-dlc $(DESTDIR)$(BINDIR)
--# install -d $(DESTDIR)$(MANDIR)/man1
--# install -m 644 youtube-dlc.1 $(DESTDIR)$(MANDIR)/man1
+ install -d $(DESTDIR)$(MANDIR)/man1
+ install -m 644 youtube-dlc.1 $(DESTDIR)$(MANDIR)/man1
install -d $(DESTDIR)$(SYSCONFDIR)/bash_completion.d
- install -m 644 youtube-dlc.bash-completion $(DESTDIR)$(SYSCONFDIR)/bash_completion.d/youtube-dlc.sh
+ install -m 644 youtube-dlc.bash-completion $(DESTDIR)$(SYSCONFDIR)/bash_completion.d/youtube-dlc
install -d $(DESTDIR)$(SHAREDIR)/zsh/site-functions
-@@ -91,10 +91,10 @@ supportedsites:
+@@ -95,10 +97,10 @@ youtube-dlc: youtube_dlc/*.py youtube_dlc/*/*.py
#README.txt: README.md
# pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
diff --git a/www/youtube_dlc/files/patch-Makefile b/www/youtube_dlc/files/patch-Makefile
index f4444e775774..f8ed24670859 100644
--- a/www/youtube_dlc/files/patch-Makefile
+++ b/www/youtube_dlc/files/patch-Makefile
@@ -1,17 +1,21 @@
---- Makefile.orig 2020-10-24 05:32:48 UTC
+--- Makefile.orig 2021-01-16 18:54:52 UTC
+++ Makefile
-@@ -1,4 +1,4 @@
--all: youtube-dlc README.md CONTRIBUTING.md README.txt youtube-dlc.1 youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish supportedsites
-+all: youtube-dlc youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish supportedsites
+@@ -1,6 +1,6 @@
+-all: youtube-dlc doc man
+-doc: README.md CONTRIBUTING.md issuetemplates supportedsites
+-man: README.txt youtube-dlc.1 youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish
++all: youtube-dlc man
++#doc: README.md CONTRIBUTING.md issuetemplates supportedsites
++man: youtube-dlc.bash-completion youtube-dlc.zsh youtube-dlc.fish
+
clean:
- rm -rf youtube-dlc.1.temp.md youtube-dlc.1 youtube-dlc.bash-completion README.txt MANIFEST build/ dist/ .coverage cover/ youtube-dlc.tar.gz youtube-dlc.zsh youtube-dlc.fish youtube_dlc/extractor/lazy_extractors.py *.dump *.part* *.ytdl *.info.json *.mp4 *.m4a *.flv *.mp3 *.avi *.mkv *.webm *.3gp *.wav *.ape *.swf *.jpg *.png CONTRIBUTING.md.tmp youtube-dlc youtube-dlc.exe
-@@ -12,22 +12,22 @@ SHAREDIR ?= $(PREFIX)/share
- PYTHON ?= /usr/bin/env python
+@@ -16,16 +16,14 @@ SHAREDIR ?= $(PREFIX)/share
+ PYTHON ?= /usr/bin/env python3
# set SYSCONFDIR to /etc if PREFIX=/usr or PREFIX=/usr/local
-SYSCONFDIR = $(shell if [ $(PREFIX) = /usr -o $(PREFIX) = /usr/local ]; then echo /etc; else echo $(PREFIX)/etc; fi)
-+SYSCONFDIR ?= $(PREFIX)/etc
++SYSCONFDIR = $(PREFIX)/etc
# set markdown input format to "markdown-smart" for pandoc version 2 and to "markdown" for pandoc prior to version 2
MARKDOWN = $(shell if [ `pandoc -v | head -n1 | cut -d" " -f2 | head -c1` = "2" ]; then echo markdown-smart; else echo markdown; fi)
@@ -22,21 +26,10 @@
install -m 755 youtube-dlc $(DESTDIR)$(BINDIR)
- install -d $(DESTDIR)$(MANDIR)/man1
- install -m 644 youtube-dlc.1 $(DESTDIR)$(MANDIR)/man1
-+# install -d $(DESTDIR)$(MANDIR)/man1
-+# install -m 644 youtube-dlc.1 $(DESTDIR)$(MANDIR)/man1
install -d $(DESTDIR)$(SYSCONFDIR)/bash_completion.d
-- install -m 644 youtube-dlc.bash-completion $(DESTDIR)$(SYSCONFDIR)/bash_completion.d/youtube-dlc
-+ install -m 644 youtube-dlc.bash-completion $(DESTDIR)$(SYSCONFDIR)/bash_completion.d/youtube-dlc.sh
+ install -m 644 youtube-dlc.bash-completion $(DESTDIR)$(SYSCONFDIR)/bash_completion.d/youtube-dlc
install -d $(DESTDIR)$(SHAREDIR)/zsh/site-functions
- install -m 644 youtube-dlc.zsh $(DESTDIR)$(SHAREDIR)/zsh/site-functions/_youtube-dlc
-- install -d $(DESTDIR)$(SYSCONFDIR)/fish/completions
-- install -m 644 youtube-dlc.fish $(DESTDIR)$(SYSCONFDIR)/fish/completions/youtube-dlc.fish
-+ install -d $(DESTDIR)$(SHAREDIR)/fish/vendor_completions.d
-+ install -m 644 youtube-dlc.fish $(DESTDIR)$(SHAREDIR)/fish/vendor_completions.d/youtube-dlc.fish
-
- codetest:
- flake8 .
-@@ -65,7 +65,7 @@ youtube-dlc: youtube_dlc/*.py youtube_dlc/*/*.py
+@@ -71,36 +69,36 @@ youtube-dlc: youtube_dlc/*.py youtube_dlc/*/*.py
done
touch -t 200001010101 zip/youtube_dlc/*.py zip/youtube_dlc/*/*.py
mv zip/youtube_dlc/__main__.py zip/
@@ -45,20 +38,36 @@
rm -rf zip
echo '#!$(PYTHON)' > youtube-dlc
cat youtube-dlc.zip >> youtube-dlc
-@@ -75,8 +75,8 @@ youtube-dlc: youtube_dlc/*.py youtube_dlc/*/*.py
- README.md: youtube_dlc/*.py youtube_dlc/*/*.py
- COLUMNS=80 $(PYTHON) youtube_dlc/__main__.py --help | $(PYTHON) devscripts/make_readme.py
+ rm youtube-dlc.zip
+ chmod a+x youtube-dlc
+
+-README.md: youtube_dlc/*.py youtube_dlc/*/*.py
+- COLUMNS=80 $(PYTHON) youtube_dlc/__main__.py --help | $(PYTHON) devscripts/make_readme.py
++#README.md: youtube_dlc/*.py youtube_dlc/*/*.py
++# COLUMNS=80 $(PYTHON) youtube_dlc/__main__.py --help | $(PYTHON) devscripts/make_readme.py
-CONTRIBUTING.md: README.md
- $(PYTHON) devscripts/make_contributing.py README.md CONTRIBUTING.md
+#CONTRIBUTING.md: README.md
+# $(PYTHON) devscripts/make_contributing.py README.md CONTRIBUTING.md
- issuetemplates: devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/1_broken_site.md .github/ISSUE_TEMPLATE_tmpl/2_site_support_request.md .github/ISSUE_TEMPLATE_tmpl/3_site_feature_request.md .github/ISSUE_TEMPLATE_tmpl/4_bug_report.md .github/ISSUE_TEMPLATE_tmpl/5_feature_request.md youtube_dlc/version.py
- $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/1_broken_site.md .github/ISSUE_TEMPLATE/1_broken_site.md
-@@ -88,13 +88,13 @@ issuetemplates: devscripts/make_issue_template.py .git
- supportedsites:
- $(PYTHON) devscripts/make_supportedsites.py docs/supportedsites.md
+-issuetemplates: devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/1_broken_site.md .github/ISSUE_TEMPLATE_tmpl/2_site_support_request.md .github/ISSUE_TEMPLATE_tmpl/3_site_feature_request.md .github/ISSUE_TEMPLATE_tmpl/4_bug_report.md .github/ISSUE_TEMPLATE_tmpl/5_feature_request.md youtube_dlc/version.py
+- $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/1_broken_site.md .github/ISSUE_TEMPLATE/1_broken_site.md
+- $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/2_site_support_request.md .github/ISSUE_TEMPLATE/2_site_support_request.md
+- $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/3_site_feature_request.md .github/ISSUE_TEMPLATE/3_site_feature_request.md
+- $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/4_bug_report.md .github/ISSUE_TEMPLATE/4_bug_report.md
+- $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/5_feature_request.md .github/ISSUE_TEMPLATE/5_feature_request.md
++#issuetemplates: devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/1_broken_site.md .github/ISSUE_TEMPLATE_tmpl/2_site_support_request.md .github/ISSUE_TEMPLATE_tmpl/3_site_feature_request.md .github/ISSUE_TEMPLATE_tmpl/4_bug_report.md .github/ISSUE_TEMPLATE_tmpl/5_feature_request.md youtube_dlc/version.py
++# $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/1_broken_site.md .github/ISSUE_TEMPLATE/1_broken_site.md
++# $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/2_site_support_request.md .github/ISSUE_TEMPLATE/2_site_support_request.md
++# $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/3_site_feature_request.md .github/ISSUE_TEMPLATE/3_site_feature_request.md
++# $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/4_bug_report.md .github/ISSUE_TEMPLATE/4_bug_report.md
++# $(PYTHON) devscripts/make_issue_template.py .github/ISSUE_TEMPLATE_tmpl/5_feature_request.md .github/ISSUE_TEMPLATE/5_feature_request.md
+
+-supportedsites:
+- $(PYTHON) devscripts/make_supportedsites.py docs/supportedsites.md
++#supportedsites:
++# $(PYTHON) devscripts/make_supportedsites.py docs/supportedsites.md
-README.txt: README.md
- pandoc -f $(MARKDOWN) -t plain README.md -o README.txt
diff --git a/www/youtube_dlc/files/patch-youtube__dlc_____init____.py b/www/youtube_dlc/files/patch-youtube__dlc_____init____.py
index ef98307aec80..4303155e1606 100644
--- a/www/youtube_dlc/files/patch-youtube__dlc_____init____.py
+++ b/www/youtube_dlc/files/patch-youtube__dlc_____init____.py
@@ -1,6 +1,6 @@
---- youtube_dlc/__init__.py.orig 2020-10-24 05:32:48 UTC
+--- youtube_dlc/__init__.py.orig 2021-01-16 18:54:52 UTC
+++ youtube_dlc/__init__.py
-@@ -36,7 +36,6 @@ from .utils import (
+@@ -39,7 +39,6 @@ from .utils import (
write_string,
render_table,
)
@@ -8,7 +8,7 @@
from .downloader import (
FileDownloader,
)
-@@ -452,17 +451,13 @@ def _real_main(argv=None):
+@@ -499,17 +498,13 @@ def _real_main(argv=None):
}
with YoutubeDL(ydl_opts) as ydl:
diff --git a/www/youtube_dlc/files/patch-youtube__dlc_options.py b/www/youtube_dlc/files/patch-youtube__dlc_options.py
index 66a5d3d63ca8..157204c5e885 100644
--- a/www/youtube_dlc/files/patch-youtube__dlc_options.py
+++ b/www/youtube_dlc/files/patch-youtube__dlc_options.py
@@ -1,13 +1,13 @@
---- youtube_dlc/options.py.orig 2020-10-24 05:32:48 UTC
+--- youtube_dlc/options.py.orig 2021-01-17 22:30:37 UTC
+++ youtube_dlc/options.py
-@@ -138,10 +138,6 @@ def parseOpts(overrideArguments=None):
+@@ -131,10 +131,6 @@ def parseOpts(overrideArguments=None):
action='version',
help='Print program version and exit')
general.add_option(
- '-U', '--update',
- action='store_true', dest='update_self',
-- help='Update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
+- help='[BROKEN] Update this program to latest version. Make sure that you have sufficient permissions (run with sudo if needed)')
- general.add_option(
- '-i', '--ignore-errors',
- action='store_true', dest='ignoreerrors', default=False,
- help='Continue on download errors, for example to skip unavailable videos in a playlist')
+ '-i', '--ignore-errors', '--no-abort-on-error',
+ action='store_true', dest='ignoreerrors', default=True,
+ help='Continue on download errors, for example to skip unavailable videos in a playlist (default)')
diff --git a/www/youtube_dlc/pkg-plist b/www/youtube_dlc/pkg-plist
index 887787511d19..bec3f63d33b5 100644
--- a/www/youtube_dlc/pkg-plist
+++ b/www/youtube_dlc/pkg-plist
@@ -1,6 +1,7 @@
%%SYMLINK%%bin/youtube-dl
bin/youtube-dlc
-etc/bash_completion.d/youtube-dlc.sh
+etc/bash_completion.d/youtube-dlc
%%MANPAGES%%man/man1/youtube-dlc.1.gz
-share/fish/vendor_completions.d/youtube-dlc.fish
+etc/fish/completions/youtube-dlc.fish
share/zsh/site-functions/_youtube-dlc
+