aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-04-20 17:28:36 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-04-20 17:28:36 +0000
commitf728b2a5082f068bb424c5b8f6c072fbace422ba (patch)
tree5cfacfcd7064b471072027ce8b1917bc636116c0 /www
parent6d57a2c6850cd92367d1f54b4a2041df24348220 (diff)
downloadports-f728b2a5082f068bb424c5b8f6c072fbace422ba.tar.gz
ports-f728b2a5082f068bb424c5b8f6c072fbace422ba.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/apache24/Makefile1
-rw-r--r--www/apache24/files/patch-server__core.c27
2 files changed, 28 insertions, 0 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index a762f78fd37e..144f83f29b09 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -2,6 +2,7 @@
PORTNAME= apache24
PORTVERSION= 2.4.4
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache24/files/patch-server__core.c b/www/apache24/files/patch-server__core.c
new file mode 100644
index 000000000000..7d69fb7564f5
--- /dev/null
+++ b/www/apache24/files/patch-server__core.c
@@ -0,0 +1,27 @@
+Apache issue: https://issues.apache.org/bugzilla/show_bug.cgi?id=52900
+
+Obtained from:
+http://svn.apache.org/viewvc?view=revision&revision=1470183
+============================================================
+--- ./server/core.c.orig 2013-02-06 18:15:16.000000000 +0100
++++ ./server/core.c 2013-04-20 19:11:17.000000000 +0200
+@@ -4768,13 +4768,18 @@
+ AP_DECLARE(apr_uint32_t) ap_random_pick(apr_uint32_t min, apr_uint32_t max)
+ {
+ apr_uint32_t number;
++#if (!__GNUC__ || __GNUC__ >= 5 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 8) || \
++ !__sparc__ || APR_SIZEOF_VOIDP != 8)
++ /* This triggers a gcc bug on sparc/64bit with gcc < 4.8, PR 52900 */
+ if (max < 16384) {
+ apr_uint16_t num16;
+ ap_random_insecure_bytes(&num16, sizeof(num16));
+ RAND_RANGE(num16, min, max, APR_UINT16_MAX);
+ number = num16;
+ }
+- else {
++ else
++#endif
++ {
+ ap_random_insecure_bytes(&number, sizeof(number));
+ RAND_RANGE(number, min, max, APR_UINT32_MAX);
+ }