aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-03-09 22:55:32 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-03-09 22:55:32 +0000
commit1abbbf5e11b4d6d2596ae6c2913e3f01b396ceda (patch)
tree35937c4b3a9bfe443a092d32d2962dabca914885 /www
parentf352e4c4f3298b7bae37653775489018247a95ce (diff)
downloadports-1abbbf5e11b4d6d2596ae6c2913e3f01b396ceda.tar.gz
ports-1abbbf5e11b4d6d2596ae6c2913e3f01b396ceda.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-URI-ToDisk/Makefile31
-rw-r--r--www/p5-URI-ToDisk/distinfo3
-rw-r--r--www/p5-URI-ToDisk/pkg-descr3
-rw-r--r--www/p5-URI-ToDisk/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 94a63154e991..b91945e719d2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -914,6 +914,7 @@
SUBDIR += p5-Tie-TinyURL
SUBDIR += p5-URI-Fetch
SUBDIR += p5-URI-Sequin
+ SUBDIR += p5-URI-ToDisk
SUBDIR += p5-W3C-LinkChecker
SUBDIR += p5-W3C-LogValidator
SUBDIR += p5-WWW-Babelfish
diff --git a/www/p5-URI-ToDisk/Makefile b/www/p5-URI-ToDisk/Makefile
new file mode 100644
index 000000000000..7094e7b6f021
--- /dev/null
+++ b/www/p5-URI-ToDisk/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-URI-ToDisk
+# Date created: 08 March 2008
+# Whom: Cory R King <coryking@mozimedia.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-ToDisk
+PORTVERSION= 1.12
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= URI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= coryking@mozimedia.com
+COMMENT= An object for mapping a URI to an on-disk storage directory
+
+BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Clone>=0.23:${PORTSDIR}/devel/p5-Clone \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-Params-Util>=0.31:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Clone>=0.23:${PORTSDIR}/devel/p5-Clone \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-Params-Util>=0.31:${PORTSDIR}/devel/p5-Params-Util
+
+PERL_CONFIGURE= yes
+
+MAN3= URI::ToDisk.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-URI-ToDisk/distinfo b/www/p5-URI-ToDisk/distinfo
new file mode 100644
index 000000000000..992e25542d1b
--- /dev/null
+++ b/www/p5-URI-ToDisk/distinfo
@@ -0,0 +1,3 @@
+MD5 (URI-ToDisk-1.12.tar.gz) = 8e3bc9be7dda6396cba0c04b2332d1f0
+SHA256 (URI-ToDisk-1.12.tar.gz) = b2d9a645a54c5c153fc032a4db19d0c6c8fc4eac41b6b7614ef6c8184a6dfc95
+SIZE (URI-ToDisk-1.12.tar.gz) = 23565
diff --git a/www/p5-URI-ToDisk/pkg-descr b/www/p5-URI-ToDisk/pkg-descr
new file mode 100644
index 000000000000..b57947697dfd
--- /dev/null
+++ b/www/p5-URI-ToDisk/pkg-descr
@@ -0,0 +1,3 @@
+An object for mapping a URI to an on-disk storage directory
+
+WWW: http://search.cpan.org/dist/URI-ToDisk/
diff --git a/www/p5-URI-ToDisk/pkg-plist b/www/p5-URI-ToDisk/pkg-plist
new file mode 100644
index 000000000000..ef2887f03c8c
--- /dev/null
+++ b/www/p5-URI-ToDisk/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/URI/ToDisk.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/ToDisk/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/URI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/ToDisk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI
+@dirrmtry %%SITE_PERL%%/URI