aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-06-05 02:36:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-06-05 02:36:38 +0000
commit59aaf7d237b24954f69a0b608c671b73da218851 (patch)
treebacaf5e4099f362cc90152fa290c0ed10a2dd2f7 /www
parent34841b97553ce4af1a89c9dd920a8a1863e749f6 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-grequests/Makefile25
-rw-r--r--www/py-grequests/distinfo2
-rw-r--r--www/py-grequests/files/patch-setup.py20
-rw-r--r--www/py-grequests/pkg-descr4
-rw-r--r--www/py-grequests/pkg-plist4
6 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 53d324fbcd78..b8358abb73eb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1489,6 +1489,7 @@
SUBDIR += py-funkload
SUBDIR += py-google-api-python-client
SUBDIR += py-graphite-web
+ SUBDIR += py-grequests
SUBDIR += py-gunicorn
SUBDIR += py-html5lib
SUBDIR += py-httplib2
diff --git a/www/py-grequests/Makefile b/www/py-grequests/Makefile
new file mode 100644
index 000000000000..78db7f598620
--- /dev/null
+++ b/www/py-grequests/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-grequests
+# Date created: 2012-05-31
+# Whom: koobs <koobs.freebsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grequests
+PORTVERSION= 0.1.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs.freebsd@gmail.com
+COMMENT= Pythons Requests + Gevent
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gevent>0:${PORTSDIR}/devel/py-gevent \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/www/py-grequests/distinfo b/www/py-grequests/distinfo
new file mode 100644
index 000000000000..e95943d19115
--- /dev/null
+++ b/www/py-grequests/distinfo
@@ -0,0 +1,2 @@
+SHA256 (grequests-0.1.0.tar.gz) = 73fa312f3d4b62f038a44c0a56cd3b27973b57208befbaaf96db3683fa02e2b9
+SIZE (grequests-0.1.0.tar.gz) = 2424
diff --git a/www/py-grequests/files/patch-setup.py b/www/py-grequests/files/patch-setup.py
new file mode 100644
index 000000000000..0abb3f5abb3e
--- /dev/null
+++ b/www/py-grequests/files/patch-setup.py
@@ -0,0 +1,20 @@
+--- ./setup.py.orig 2012-05-11 08:20:48.000000000 +1000
++++ ./setup.py 2012-06-02 19:09:45.000000000 +1000
+@@ -29,7 +29,7 @@
+
+ """
+
+-from setuptools import setup
++from distutils.core import setup
+
+ setup(
+ name='grequests',
+@@ -41,8 +41,6 @@
+ description='Requests + Gevent',
+ long_description=__doc__,
+ py_modules=['grequests'],
+- zip_safe=False,
+- include_package_data=True,
+ platforms='any',
+ classifiers=[
+ 'Environment :: Web Environment',
diff --git a/www/py-grequests/pkg-descr b/www/py-grequests/pkg-descr
new file mode 100644
index 000000000000..282b8dfe72ef
--- /dev/null
+++ b/www/py-grequests/pkg-descr
@@ -0,0 +1,4 @@
+GRequests allows you to use Requests with Gevent to make asyncronous HTTP
+Requests easily.
+
+WWW: https://github.com/kennethreitz/grequests
diff --git a/www/py-grequests/pkg-plist b/www/py-grequests/pkg-plist
new file mode 100644
index 000000000000..44b2e74dc11e
--- /dev/null
+++ b/www/py-grequests/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/grequests.py
+%%PYTHON_SITELIBDIR%%/grequests.pyc
+%%PYTHON_SITELIBDIR%%/grequests.pyo