aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-27 00:29:11 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-27 00:29:11 +0000
commit69ffa6b7d98af9fe10d386a5bfd5ae3d9a0bd500 (patch)
tree24aad827005215e49e3295c5efbd9c555da4f774 /www
parent51bd54d2672673ff994f50f40130cb0797c88582 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/ocaml-net/Makefile72
-rw-r--r--www/ocaml-net/distinfo4
-rw-r--r--www/ocaml-net/files/patch-Makefile15
3 files changed, 50 insertions, 41 deletions
diff --git a/www/ocaml-net/Makefile b/www/ocaml-net/Makefile
index 92deb1835578..f86676e0182a 100644
--- a/www/ocaml-net/Makefile
+++ b/www/ocaml-net/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= net
-PORTVERSION= 3.5.1
+PORTVERSION= 3.7.3
CATEGORIES= www
MASTER_SITES= http://download.camlcity.org/download/
PKGNAMEPREFIX= ocaml-
@@ -11,19 +11,21 @@ DISTNAME= ocaml${PORTNAME}-${PORTVERSION}
MAINTAINER= jaapb@kerguelen.org
COMMENT= OCaml modules for Internet applications
+LICENSE= GPLv2
+
BUILD_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
CONFLICTS= ocaml-equeue-2* ocaml-netclient-0*
-USES= gmake
-USE_OCAML= yes
+USES= gmake
+USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_OCAMLFIND_PLIST= yes
-HAS_CONFIGURE= yes
+HAS_CONFIGURE= yes
-ALL_TARGET= all opt
+ALL_TARGET= all opt
MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/netplex-admin \
@@ -32,86 +34,77 @@ PLIST_FILES= bin/netplex-admin \
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PKGNAMEPREFIX}${PORTNAME}
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
-
PORTDOCS= *
PORTEXAMPLES= *
OCAML_PKGDIRS= netsys netshm equeue shell netstring rpc-generator \
rpc pop smtp netclient netcgi2 netgssapi netplex \
- netcgi2-plex netcamlbox netmulticore rpc-auth-local
+ netcgi2-plex netcamlbox netmulticore rpc-auth-local \
+ netstring-pcre
OCAML_LDLIBS= ${OCAML_PKGDIRS:S/^/${OCAML_SITELIBDIR}\//}
OPTIONS_DEFINE= SSL NETHTTPD AUTH_DH GTK2 APACHE ZIP SCRAM EXAMPLES DOCS
-OPTIONS_DEFAULT= SSL
+OPTIONS_DEFAULT=SSL
AUTH_DH_DESC= Diffie-Hellman authorization support
NETHTTPD_DESC= Integrated HTTP daemon
SCRAM_DESC= SCRAM support
ZIP_DESC= Compression support
APACHE_DESC= Apache mod connector (experimental)
-CONFIGURE_ARGS+= -disable-gtk
+CONFIGURE_ARGS+=-disable-gtk \
+ -enable-pcre
+
+SSL_BUILD_DEPENDS= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+SSL_RUN_DEPENDS= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+
+AUTH_DH_BUILD_DEPENDS= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
+AUTH_DH_RUN_DEPENDS= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
+
+GTK2_BUILD_DEPENDS= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+GTK2_RUN_DEPENDS= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+
+ZIP_BUILD_DEPENDS= ${SA_DIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip
+ZIP_RUN_DEPENDS= ${SA_DIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip
+
+SCRAM_BUILD_DEPENDS= ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
+SCRAM_RUN_DEPENDS= ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
CONFIGURE_ARGS+= -enable-ssl
-BUILD_DEPENDS+= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
-RUN_DEPENDS+= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
OCAML_PKGDIRS+= equeue-ssl rpc-ssl
-.else
-CONFIGURE_ARGS+= -disable-ssl
.endif
.if ${PORT_OPTIONS:MNETHTTPD}
CONFIGURE_ARGS+= -with-nethttpd
OCAML_PKGDIRS+= nethttpd nethttpd-for-netcgi2
-.else
-CONFIGURE_ARGS+= -without-nethttpd
.endif
.if ${PORT_OPTIONS:MAUTH_DH}
CONFIGURE_ARGS+= -with-rpc-auth-dh
-BUILD_DEPENDS+= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
-RUN_DEPENDS+= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
OCAML_PKGDIRS+= rpc-auth-dh
-.else
-CONFIGURE_ARGS+= -without-rpc-auth-dh
.endif
.if ${PORT_OPTIONS:MGTK2}
CONFIGURE_ARGS+= -enable-gtk2
-BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
-RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
OCAML_PKGDIRS+= equeue-gtk2
-.else
-CONFIGURE_ARGS+= -disable-gtk2
.endif
.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE= 22+
CONFIGURE_ARGS+= -enable-apache -apxs ${APXS} -apache ${HTTPD}
OCAML_PKGDIRS+= netcgi_apache
-.else
-CONFIGURE_ARGS+= -disable-apache
.endif
.if ${PORT_OPTIONS:MZIP}
CONFIGURE_ARGS+= -enable-zip
-BUILD_DEPENDS+= ${SA_DIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip
-RUN_DEPENDS+= ${SA_DIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip
OCAML_PKGDIRS+= netzip
-.else
-CONFIGURE_ARGS+= -disable-zip
.endif
.if ${PORT_OPTIONS:MSCRAM}
CONFIGURE_ARGS+= -enable-crypto
-BUILD_DEPENDS+= ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
-RUN_DEPENDS+= ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
OCAML_PKGDIRS+= netmech-scram
-.else
-CONFIGURE_ARGS+= -disable-crypto
.endif
post-patch:
@@ -124,12 +117,13 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}/
- @(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ @(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}/)
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}/
- @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ @(cd ${WRKSRC}/examples/ && \
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}/)
.endif
.include <bsd.port.mk>
diff --git a/www/ocaml-net/distinfo b/www/ocaml-net/distinfo
index 1a7dbd4f0e45..0cdcecd2e487 100644
--- a/www/ocaml-net/distinfo
+++ b/www/ocaml-net/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ocamlnet-3.5.1.tar.gz) = 1304eea88aacbc08864e7ff8fce58fab495f41c99b6379784121fc9e92ca8426
-SIZE (ocamlnet-3.5.1.tar.gz) = 3290994
+SHA256 (ocamlnet-3.7.3.tar.gz) = 4ddc6928856d57b613de8889708f04a7bba04571b7bf1c525418cf9e3d8b4468
+SIZE (ocamlnet-3.7.3.tar.gz) = 3352779
diff --git a/www/ocaml-net/files/patch-Makefile b/www/ocaml-net/files/patch-Makefile
new file mode 100644
index 000000000000..28913053ebe5
--- /dev/null
+++ b/www/ocaml-net/files/patch-Makefile
@@ -0,0 +1,15 @@
+$NetBSD: patch-Makefile.rules,v 1.1 2012/07/06 09:29:14 wiz Exp $
+
+make package work with DESTDIR support
+--- Makefile.rules.orig 2012-02-29 18:02:51.000000000 +0000
++++ Makefile.rules
+@@ -148,7 +148,8 @@ realuninstall: $(UNINSTOTHER) uninstall-
+ .PHONY: install-findlib
+ install-findlib: META
+ files=`$(COLLECT_FILES) *.mli *.cmi *.cma *.cmxa *.a dll* META $(INSTALL_EXTRA)` && \
+- $(OCAMLFIND) install $(PKGNAME) $$files
++ $(OCAMLFIND) install -destdir $(DESTDIR)/$(PREFIX)/lib/ocaml/site-lib \
++ -ldconf /dev/null $(PKGNAME) $$files
+
+ .PHONY: uninstall-findlib
+ uninstall-findlib: