aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-31 21:59:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-31 21:59:18 +0000
commit8778f4fdb47b180f2eede5d23fdffea05fcda99b (patch)
tree30071d19dcbb4bdd56b097b72e7af109216b5d93 /www
parent6d4d59cc8d0f4386b41f41f8f52bdd681111e76b (diff)
downloadports-8778f4fdb47b180f2eede5d23fdffea05fcda99b.tar.gz
ports-8778f4fdb47b180f2eede5d23fdffea05fcda99b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/rubygem-actionpack52/Makefile6
-rw-r--r--www/rubygem-actionpack52/pkg-descr27
2 files changed, 22 insertions, 11 deletions
diff --git a/www/rubygem-actionpack52/Makefile b/www/rubygem-actionpack52/Makefile
index 18f00dde83f3..d45dbce62dd7 100644
--- a/www/rubygem-actionpack52/Makefile
+++ b/www/rubygem-actionpack52/Makefile
@@ -15,10 +15,10 @@ LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
RUN_DEPENDS= rubygem-actionview52>=${PORTVERSION}:devel/rubygem-actionview52 \
rubygem-activesupport52>=${PORTVERSION}:devel/rubygem-activesupport52 \
- rubygem-rack>=2.0:www/rubygem-rack \
+ rubygem-rack>=2.0,3<3,3:www/rubygem-rack \
rubygem-rack-test>=0.6.3:www/rubygem-rack-test \
- rubygem-rails-dom-testing-rails52>=2.0:textproc/rubygem-rails-dom-testing-rails52 \
- rubygem-rails-html-sanitizer>=1.0.2:textproc/rubygem-rails-html-sanitizer
+ rubygem-rails-dom-testing-rails52>=2.0<3:textproc/rubygem-rails-dom-testing-rails52 \
+ rubygem-rails-html-sanitizer>=1.0.2<2:textproc/rubygem-rails-html-sanitizer
USES= gem
USE_RUBY= yes
diff --git a/www/rubygem-actionpack52/pkg-descr b/www/rubygem-actionpack52/pkg-descr
index 8c1a1f7feac7..f424cc62f012 100644
--- a/www/rubygem-actionpack52/pkg-descr
+++ b/www/rubygem-actionpack52/pkg-descr
@@ -1,12 +1,23 @@
-Action Pack
+Action Pack is a framework for handling and responding to web requests. It
+provides mechanisms for routing (mapping request URLs to actions), defining
+controllers that implement actions, and generating responses by rendering views,
+which are templates of various formats. In short, Action Pack provides the view
+and controller layers in the MVC paradigm.
-The controller and view of the RubyOnRails MVC-Framework is handled
-by the Action Pack, which handles both layers by its two parts:
-Action View and Action Controller. These two layers are bundled
-in a single package due to their heavy interdependence. This is unlike
-the relationship between the Active Record and Action Pack that is
-much more separate.
+It consists of several modules:
+- Action Dispatch, which parses information about the web request, handles
+ routing as defined by the user, and does advanced processing related to HTTP
+ such as MIME-type negotiation, decoding parameters in POST, PATCH, or PUT
+ bodies, handling HTTP caching logic, cookies and sessions.
+- Action Controller, which provides a base controller class that can be
+ subclassed to implement filters and actions to handle requests. The result of
+ an action is typically content generated from views.
-Each of these packages can be used independently outside of Rails.
+With the Ruby on Rails framework, users only directly interface with the Action
+Controller module. Necessary Action Dispatch functionality is activated by
+default and Action View rendering is implicitly triggered by Action Controller.
+However, these modules are designed to function on their own and can be used
+outside of Rails.
WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/actionpack