aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-13 15:48:30 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-13 15:48:30 +0000
commit9bc9a1ea1e61e4a50ee6bf9523827847fa235b89 (patch)
treecd2ed6600c118dd48788edd54a4033911f3b9e98 /www
parent61c0dd3c247a67cce7d632da7627945b5c08eb6d (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/visitors/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/visitors/Makefile b/www/visitors/Makefile
index 6df9a9db06fd..6ec86fb79784 100644
--- a/www/visitors/Makefile
+++ b/www/visitors/Makefile
@@ -16,12 +16,11 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_0.7
PLIST_FILES= bin/visitors
PORTDOCS= doc.html
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/visitors ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/visitors ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>