aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-02-15 16:44:07 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-03-18 14:48:01 +0000
commita53a92662f2c5ce77fcb618bce137cab62f85f1d (patch)
tree883c93aa1c72528988829a3ceca04da94535c37d /www
parent87e27583618b329479f9ae231f9a912ef60ca11b (diff)
downloadports-a53a92662f2c5ce77fcb618bce137cab62f85f1d.tar.gz
ports-a53a92662f2c5ce77fcb618bce137cab62f85f1d.zip
multimedia/dav1d: update to 1.0.0
Changes: https://code.videolan.org/videolan/dav1d/-/releases/1.0.0 Reported by: Repology (cherry picked from commit 3468f1957cf25742c60e1066f1174866c42efe96)
Diffstat (limited to 'www')
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug173405845
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bug155921322
4 files changed, 71 insertions, 0 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index e784ec95b375..aa05825aaff7 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -2,6 +2,7 @@
PORTNAME= firefox
DISTVERSION= 91.7.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
@@ -19,6 +20,7 @@ BUILD_DEPENDS= nspr>=4.32:devel/nspr \
harfbuzz>=2.8.1:print/harfbuzz \
graphite2>=1.3.14:graphics/graphite2 \
png>=1.6.37:graphics/png \
+ dav1d>=1.0.0:multimedia/dav1d \
libvpx>=1.8.2:multimedia/libvpx \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
v4l_compat>0:multimedia/v4l_compat \
diff --git a/www/firefox-esr/files/patch-bug1734058 b/www/firefox-esr/files/patch-bug1734058
new file mode 100644
index 000000000000..c3c16f135cba
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1734058
@@ -0,0 +1,45 @@
+commit 874adf9b96df
+Author: Jon Bauman <jbauman@mozilla.com>
+Date: Tue Oct 26 17:11:36 2021 +0000
+
+ Bug 1734058 - Update dav1d to new version f52aee04fbd711cddab23d0aa9b196e9c963e7b8 from 2021-10-04 21:58:36. r=mjf,haik
+
+ This is a fairly significant update, so required a few changes to Gecko code, but I've commented on the interesting details, so they should be easy to find
+
+ Differential Revision: https://phabricator.services.mozilla.com/D129465
+---
+ dom/media/platforms/agnostic/DAV1DDecoder.cpp | 7 +------
+ image/decoders/nsAVIFDecoder.cpp | 1 +
+ 2 files changed, 2 insertions(+), 6 deletions(-)
+
+diff --git dom/media/platforms/agnostic/DAV1DDecoder.cpp dom/media/platforms/agnostic/DAV1DDecoder.cpp
+index 459531fe8cf0..3c596b1fefe1 100644
+--- dom/media/platforms/agnostic/DAV1DDecoder.cpp
++++ dom/media/platforms/agnostic/DAV1DDecoder.cpp
+@@ -37,13 +37,8 @@ RefPtr<MediaDataDecoder::InitPromise> DAV1DDecoder::Init() {
+ } else if (mInfo.mDisplay.width >= 1024) {
+ decoder_threads = 4;
+ }
+- settings.n_frame_threads =
++ settings.n_threads =
+ static_cast<int>(std::min(decoder_threads, GetNumberOfProcessors()));
+- // There is not much improvement with more than 2 tile threads at least with
+- // the content being currently served. The ideal number of tile thread would
+- // much the tile count of the content. Maybe dav1d can help to do that in the
+- // future.
+- settings.n_tile_threads = 2;
+
+ int res = dav1d_open(&mContext, &settings);
+ if (res < 0) {
+diff --git image/decoders/nsAVIFDecoder.cpp image/decoders/nsAVIFDecoder.cpp
+index 9d1b7496a129..3bb9e8f8d08a 100644
+--- image/decoders/nsAVIFDecoder.cpp
++++ image/decoders/nsAVIFDecoder.cpp
+@@ -581,6 +581,7 @@ class Dav1dDecoder final : AVIFDecoderInterface {
+ Dav1dSettings settings;
+ dav1d_default_settings(&settings);
+ settings.all_layers = 0;
++ settings.max_frame_delay = 1;
+ // TODO: tune settings a la DAV1DDecoder for AV1 (Bug 1681816)
+
+ return dav1d_open(&mContext, &settings);
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 7dbc700f2334..7ebe6b8d5ca2 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -2,6 +2,7 @@
PORTNAME= firefox
DISTVERSION= 98.0.1
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
@@ -18,6 +19,7 @@ BUILD_DEPENDS= nspr>=4.32:devel/nspr \
harfbuzz>=3.1.2:print/harfbuzz \
graphite2>=1.3.14:graphics/graphite2 \
png>=1.6.37:graphics/png \
+ dav1d>=1.0.0:multimedia/dav1d \
libvpx>=1.8.2:multimedia/libvpx \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
v4l_compat>0:multimedia/v4l_compat \
diff --git a/www/firefox/files/patch-bug1559213 b/www/firefox/files/patch-bug1559213
index ceaba53522aa..09b4dcc58e83 100644
--- a/www/firefox/files/patch-bug1559213
+++ b/www/firefox/files/patch-bug1559213
@@ -61,6 +61,28 @@ index 8509aec..eb6f129 100644
if CONFIG["MOZ_OMX"]:
EXPORTS += [
+diff --git media/ffvpx/libavcodec/moz.build media/ffvpx/libavcodec/moz.build
+index 0069865..e806fc8 100644
+--- media/ffvpx/libavcodec/moz.build
++++ media/ffvpx/libavcodec/moz.build
+@@ -112,9 +112,15 @@ if not CONFIG['MOZ_FFVPX_AUDIOONLY']:
+ 'vaapi_vp8.c',
+ 'vaapi_vp9.c',
+ ]
++ if CONFIG["MOZ_SYSTEM_AV1"]:
++ CFLAGS += CONFIG['MOZ_SYSTEM_LIBDAV1D_CFLAGS']
++ OS_LIBS += CONFIG['MOZ_SYSTEM_LIBDAV1D_LIBS']
++ else:
++ USE_LIBS += [
++ 'dav1d',
++ 'media_libdav1d_asm',
++ ]
+ USE_LIBS += [
+- 'dav1d',
+- 'media_libdav1d_asm',
+ 'mozva'
+ ]
+
diff --git toolkit/moz.configure toolkit/moz.configure
index 0069865..e806fc8 100644
--- toolkit/moz.configure