aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-26 18:00:56 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-26 18:00:56 +0000
commit40363decb6b9079305f5e1ef80a1678980ddb9b8 (patch)
tree1c97f160e2bc51080a7d2f18e8bebc1492ca4a5c /www
parent0de276bf920792fde90164a06a2be1631f8e1568 (diff)
downloadports-40363decb6b9079305f5e1ef80a1678980ddb9b8.tar.gz
ports-40363decb6b9079305f5e1ef80a1678980ddb9b8.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Sledge/Makefile33
-rw-r--r--www/p5-Sledge/distinfo1
-rw-r--r--www/p5-Sledge/pkg-descr3
-rw-r--r--www/p5-Sledge/pkg-plist50
5 files changed, 88 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ef21ef37cfaa..87deebefa0b0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -337,6 +337,7 @@
SUBDIR += p5-HTTPD-Log-Filter
SUBDIR += p5-HTTPD-Tools
SUBDIR += p5-ParallelUA
+ SUBDIR += p5-Sledge
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-URI-Sequin
SUBDIR += p5-WWW-Automate
diff --git a/www/p5-Sledge/Makefile b/www/p5-Sledge/Makefile
new file mode 100644
index 000000000000..e4243b7ef848
--- /dev/null
+++ b/www/p5-Sledge/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Sledge
+# Date created: 26 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sledge
+PORTVERSION= 1.10
+CATEGORIES= www perl5
+MASTER_SITES= http://downloads.sourceforge.jp/sledge/2353/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A pure perl, pluggable, lightweight web application framework
+
+BUILD_DEPENDS= ${PM_DEPENDS}
+RUN_DEPENDS= ${PM_DEPENDS}
+
+PM_DEPENDS= ${SITE_PERL}/Bundle/Sledge.pm:${PORTSDIR}/www/p5-Bundle-Sledge
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sledge.3 \
+ Sledge::Doc::Hooks.3 \
+ Sledge::Doc::Tutorial.3 \
+ Sledge::Doc::Install.3 \
+ Sledge::Doc::FAQ.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-Sledge/distinfo b/www/p5-Sledge/distinfo
new file mode 100644
index 000000000000..b7a5c2376905
--- /dev/null
+++ b/www/p5-Sledge/distinfo
@@ -0,0 +1 @@
+MD5 (Sledge-1.10.tar.gz) = ddce28cec8a95cefb771dc107f8a5ca9
diff --git a/www/p5-Sledge/pkg-descr b/www/p5-Sledge/pkg-descr
new file mode 100644
index 000000000000..fae46d270770
--- /dev/null
+++ b/www/p5-Sledge/pkg-descr
@@ -0,0 +1,3 @@
+Sledge is a pure perl, pluggable, lightweight web application framework.
+
+WWW: http://sl.edge.jp/
diff --git a/www/p5-Sledge/pkg-plist b/www/p5-Sledge/pkg-plist
new file mode 100644
index 000000000000..a3d4d4a1c825
--- /dev/null
+++ b/www/p5-Sledge/pkg-plist
@@ -0,0 +1,50 @@
+bin/sledge-setup
+lib/perl5/site_perl/%%PERL_VER%%/Sledge.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Authorizer.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Authorizer/Null.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Charset.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Charset/Default.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Charset/Null.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Charset/Shift_JIS.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Config.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Constants.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Doc/FAQ.pod
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Doc/Hooks.pod
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Doc/Install.pod
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Doc/Tutorial.pod
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Exception.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Exceptions.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/FillInForm.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Install.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Install/Stub.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Pages/Apache.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Pages/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Pages/CGI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Pages/Compat.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Registrar.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Request/CGI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Request/Table.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Request/Upload.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Session.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Session/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Session/MySQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Session/Pg.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Session/SQLite.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/SessionManager.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/SessionManager/Cookie.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/SessionManager/Rewrite.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/SessionManager/StickyQuery.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Template.pm
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/Template/TT.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sledge/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sledge
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/Template
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/SessionManager
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/Session
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/Request
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/Pages
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/Install
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/Doc
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/Charset
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge/Authorizer
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Sledge