aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-05-04 15:12:15 +0000
committerLars Thegler <lth@FreeBSD.org>2005-05-04 15:12:15 +0000
commit9a50223f29e158bb479006ecd78ff5bc50bff1e3 (patch)
tree27327408d417269be1cc31cde14820dc377e985f /www
parentff989b3132eb9cac800115dcd73a29d3d8b17fcf (diff)
downloadports-9a50223f29e158bb479006ecd78ff5bc50bff1e3.tar.gz
ports-9a50223f29e158bb479006ecd78ff5bc50bff1e3.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Template-Timer/Makefile30
-rw-r--r--www/p5-Template-Timer/distinfo2
-rw-r--r--www/p5-Template-Timer/pkg-descr5
-rw-r--r--www/p5-Template-Timer/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ee888ef19797..05c244e70de0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -562,6 +562,7 @@
SUBDIR += p5-Template-Plugin-Class
SUBDIR += p5-Template-Plugin-Comma
SUBDIR += p5-Template-Plugin-MP3
+ SUBDIR += p5-Template-Timer
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-URI-Sequin
SUBDIR += p5-W3C-LinkChecker
diff --git a/www/p5-Template-Timer/Makefile b/www/p5-Template-Timer/Makefile
new file mode 100644
index 000000000000..1dac5cdb60a4
--- /dev/null
+++ b/www/p5-Template-Timer/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Template-Timer
+# Date created: 04 May 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Timer
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Template
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Rudimentary profiling for Template Toolkit
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Timer.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Template-Timer/distinfo b/www/p5-Template-Timer/distinfo
new file mode 100644
index 000000000000..01648d9ea0b3
--- /dev/null
+++ b/www/p5-Template-Timer/distinfo
@@ -0,0 +1,2 @@
+MD5 (Template-Timer-0.02.tar.gz) = 7c988a054c71835d28ecd089c890e1be
+SIZE (Template-Timer-0.02.tar.gz) = 2506
diff --git a/www/p5-Template-Timer/pkg-descr b/www/p5-Template-Timer/pkg-descr
new file mode 100644
index 000000000000..0288f05a42f4
--- /dev/null
+++ b/www/p5-Template-Timer/pkg-descr
@@ -0,0 +1,5 @@
+Template::Timer provides inline timings of the template processing
+througout your code. It's an overridden version of Template::Context
+that wraps the process() and include() methods.
+
+WWW: http://search.cpan.org/dist/Template-Timer
diff --git a/www/p5-Template-Timer/pkg-plist b/www/p5-Template-Timer/pkg-plist
new file mode 100644
index 000000000000..5a3fd280b1cf
--- /dev/null
+++ b/www/p5-Template-Timer/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Template/Timer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Timer/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Timer
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Template 2>/dev/null || true