aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-03-29 10:36:48 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-03-29 10:36:48 +0000
commitc47b6e92c429d0489d990c50cfcfe3abe8f7693b (patch)
tree733d51df2866ad64b644bd2ef66ca46d00f6ea34 /www
parent8518d45e89f7229d06b93dbe47a6a11fda761c6a (diff)
downloadports-c47b6e92c429d0489d990c50cfcfe3abe8f7693b.tar.gz
ports-c47b6e92c429d0489d990c50cfcfe3abe8f7693b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Starman/Makefile32
-rw-r--r--www/p5-Starman/distinfo3
-rw-r--r--www/p5-Starman/pkg-descr3
-rw-r--r--www/p5-Starman/pkg-plist13
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5cd4781d85f9..5f57fae95ac5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1114,6 +1114,7 @@
SUBDIR += p5-Sledge-SessionManager-CookieStore
SUBDIR += p5-Sledge-Template-Expr
SUBDIR += p5-Squatting
+ SUBDIR += p5-Starman
SUBDIR += p5-Syntax-Highlight-HTML
SUBDIR += p5-Syntax-Highlight-Shell
SUBDIR += p5-Task-Catalyst
diff --git a/www/p5-Starman/Makefile b/www/p5-Starman/Makefile
new file mode 100644
index 000000000000..9c376794bfa6
--- /dev/null
+++ b/www/p5-Starman/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Starman
+# Date created: 29 Mar 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Starman
+PORTVERSION= 0.1005
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for high-performance preforking PSGI web server
+
+RUN_DEPENDS= \
+ p5-Data-Dump>0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-HTTP-Parser-XS>0:${PORTSDIR}/www/p5-HTTP-Parser-XS \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Net-Server>=0.91:${PORTSDIR}/net/p5-Net-Server \
+ p5-Plack>=0.9925:${PORTSDIR}/www/p5-Plack
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= starman.1
+MAN3= Plack::Handler::Starman.3 \
+ Starman.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Starman/distinfo b/www/p5-Starman/distinfo
new file mode 100644
index 000000000000..544d4141a651
--- /dev/null
+++ b/www/p5-Starman/distinfo
@@ -0,0 +1,3 @@
+MD5 (Starman-0.1005.tar.gz) = 698ae546af361a1c4fc13553a3a5c22e
+SHA256 (Starman-0.1005.tar.gz) = 519a35496bbc94c07e9a28cb50af8e2918fc5aa37bf0f93435674a87d88f4337
+SIZE (Starman-0.1005.tar.gz) = 34753
diff --git a/www/p5-Starman/pkg-descr b/www/p5-Starman/pkg-descr
new file mode 100644
index 000000000000..e9f1ed61185e
--- /dev/null
+++ b/www/p5-Starman/pkg-descr
@@ -0,0 +1,3 @@
+High-performance preforking PSGI web server.
+
+WWW: http://search.cpan.org/dist/Starman/
diff --git a/www/p5-Starman/pkg-plist b/www/p5-Starman/pkg-plist
new file mode 100644
index 000000000000..c0e5a8bdcf32
--- /dev/null
+++ b/www/p5-Starman/pkg-plist
@@ -0,0 +1,13 @@
+bin/starman
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Starman/.packlist
+%%SITE_PERL%%/HTTP/Server/PSGI/Net/Server/PreFork.pm
+%%SITE_PERL%%/Plack/Handler/Starman.pm
+%%SITE_PERL%%/Starman.pm
+%%SITE_PERL%%/Starman/Server.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Starman
+@dirrmtry %%SITE_PERL%%/HTTP/Server/PSGI/Net/Server
+@dirrmtry %%SITE_PERL%%/HTTP/Server/PSGI/Net
+@dirrmtry %%SITE_PERL%%/HTTP/Server/PSGI
+@dirrmtry %%SITE_PERL%%/Plack/Handler
+@dirrmtry %%SITE_PERL%%/Plack
+@dirrm %%SITE_PERL%%/Starman