aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-20 21:51:35 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-20 21:51:35 +0000
commitded6554ad8fb9162254c54837e756adc660bca6b (patch)
tree3372a622e0615c4be1ef78e85db24d75b127e6ef /www
parent84b15b3f29d492fdfe38e5b7d0876e84a67c4f21 (diff)
downloadports-ded6554ad8fb9162254c54837e756adc660bca6b.tar.gz
ports-ded6554ad8fb9162254c54837e756adc660bca6b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/cherokee-devel/Makefile4
-rw-r--r--www/cherokee-devel/files/cherokee.sh.in45
-rw-r--r--www/cherokee/Makefile4
-rw-r--r--www/cherokee/files/cherokee.sh.in45
4 files changed, 94 insertions, 4 deletions
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
index 41027160890a..4ae23113f620 100644
--- a/www/cherokee-devel/Makefile
+++ b/www/cherokee-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cherokee
PORTVERSION= 0.4.30
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.0x50.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
@@ -18,9 +18,9 @@ COMMENT= An extremely fast and flexible web server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GNOME= gnomehack gnometarget pkgconfig
+USE_RC_SUBR= cherokee.sh
USE_GCC= 3.4+
USE_GETOPT_LONG= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/www/cherokee-devel/files/cherokee.sh.in b/www/cherokee-devel/files/cherokee.sh.in
new file mode 100644
index 000000000000..f35381e205da
--- /dev/null
+++ b/www/cherokee-devel/files/cherokee.sh.in
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: cherokee
+# REQUIRE: %%REQUIRE%%
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable cherokee:
+#
+# cherokee_enable (bool): Set it to "YES" to enable cherokee
+# Default is "NO".
+# cherokee_conf (path): Set full path to config file.
+# Default is "%%PREFIX%%/etc/cherokee.conf".
+#
+
+. %%RC_SUBR%%
+
+name="cherokee"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${cherokee_enable="NO"}
+: ${cherokee_conf="%%PREFIX%%/etc/cherokee/cherokee.conf"}
+
+command=%%PREFIX%%/sbin/cherokee
+command_args="-C ${cherokee_conf} -b"
+pidfile=/var/run/cherokee.pid
+required_files=${cherokee_conf}
+stop_postcmd=stop_postcmd
+restart_precmd="checkconfig"
+
+checkconfig()
+{
+ echo "Performing sanity check on ${name} configuration:"
+ eval "${command} ${command_args} -t"
+}
+
+stop_postcmd()
+{
+ rm -f ${pidfile}
+}
+
+run_rc_command "$1"
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 41027160890a..4ae23113f620 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cherokee
PORTVERSION= 0.4.30
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.0x50.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
@@ -18,9 +18,9 @@ COMMENT= An extremely fast and flexible web server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GNOME= gnomehack gnometarget pkgconfig
+USE_RC_SUBR= cherokee.sh
USE_GCC= 3.4+
USE_GETOPT_LONG= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/www/cherokee/files/cherokee.sh.in b/www/cherokee/files/cherokee.sh.in
new file mode 100644
index 000000000000..f35381e205da
--- /dev/null
+++ b/www/cherokee/files/cherokee.sh.in
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: cherokee
+# REQUIRE: %%REQUIRE%%
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable cherokee:
+#
+# cherokee_enable (bool): Set it to "YES" to enable cherokee
+# Default is "NO".
+# cherokee_conf (path): Set full path to config file.
+# Default is "%%PREFIX%%/etc/cherokee.conf".
+#
+
+. %%RC_SUBR%%
+
+name="cherokee"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${cherokee_enable="NO"}
+: ${cherokee_conf="%%PREFIX%%/etc/cherokee/cherokee.conf"}
+
+command=%%PREFIX%%/sbin/cherokee
+command_args="-C ${cherokee_conf} -b"
+pidfile=/var/run/cherokee.pid
+required_files=${cherokee_conf}
+stop_postcmd=stop_postcmd
+restart_precmd="checkconfig"
+
+checkconfig()
+{
+ echo "Performing sanity check on ${name} configuration:"
+ eval "${command} ${command_args} -t"
+}
+
+stop_postcmd()
+{
+ rm -f ${pidfile}
+}
+
+run_rc_command "$1"