aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-11-05 19:02:30 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-11-05 19:02:30 +0000
commitfe8762f0a635854614bd051b96b151c7e1fbff0c (patch)
treef6564d9b7f3db1634f6caa926ee9915793a689f9 /www
parent9a44066fbb4a48b41ffee3fa7afad7c49914c00d (diff)
downloadports-fe8762f0a635854614bd051b96b151c7e1fbff0c.tar.gz
ports-fe8762f0a635854614bd051b96b151c7e1fbff0c.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/middleman/Makefile4
-rw-r--r--www/middleman/files/patch-include-types.h11
2 files changed, 11 insertions, 4 deletions
diff --git a/www/middleman/Makefile b/www/middleman/Makefile
index 208720a83aea..d7c2dba3ee88 100644
--- a/www/middleman/Makefile
+++ b/www/middleman/Makefile
@@ -43,10 +43,6 @@ PLIST_SUB+= MMAN_CACHE=${MMAN_CACHE}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700000
-BROKEN= "Does not compile on FreeBSD >= 7.0"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/bin/mman|${PREFIX}/bin/mman|g ; \
diff --git a/www/middleman/files/patch-include-types.h b/www/middleman/files/patch-include-types.h
new file mode 100644
index 000000000000..9cf7c7c71241
--- /dev/null
+++ b/www/middleman/files/patch-include-types.h
@@ -0,0 +1,11 @@
+--- include/types.h.orig Sat Nov 5 19:51:41 2005
++++ include/types.h Sat Nov 5 19:51:54 2005
+@@ -1,6 +1,8 @@
+ #ifndef TYPES_H
+ #define TYPES_H
+
++#include <sys/types.h>
++
+ struct unlink_list {
+ struct unlink_list *next;
+ char *path;