aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-01-24 20:37:55 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-01-24 20:37:55 +0000
commit374a90f9fb7e453b65666709796869e54b5b7820 (patch)
treef774a8a74be5bfe65adf7de8265c7daccaa2e6b4 /www
parent148b6b5731a76a922505bd013a35afd5e6a4c415 (diff)
downloadports-374a90f9fb7e453b65666709796869e54b5b7820.tar.gz
ports-374a90f9fb7e453b65666709796869e54b5b7820.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_geoip/Makefile38
-rw-r--r--www/mod_geoip/distinfo1
-rw-r--r--www/mod_geoip/pkg-comment1
-rw-r--r--www/mod_geoip/pkg-descr4
-rw-r--r--www/mod_geoip/pkg-message14
-rw-r--r--www/mod_geoip/pkg-plist8
7 files changed, 67 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b64d97b47e9e..31183fb0cf60 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -181,6 +181,7 @@
SUBDIR += mod_fastcgi
SUBDIR += mod_filter
SUBDIR += mod_frontpage
+ SUBDIR += mod_geoip
SUBDIR += mod_gzip
SUBDIR += mod_hosts_access
SUBDIR += mod_index_rss
diff --git a/www/mod_geoip/Makefile b/www/mod_geoip/Makefile
new file mode 100644
index 000000000000..529b5556a7f8
--- /dev/null
+++ b/www/mod_geoip/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mod_geoip
+# Date created: 24 Jan 2003
+# Whom: Sean Chittenden <seanc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_geoip
+PORTVERSION= 1.1.1
+CATEGORIES= www
+MASTER_SITES= http://www.maxmind.com/download/geoip/api/mod_geoip/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= seanc@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
+
+APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
+
+DOCS= Changes INSTALL README README.php
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${APXS} -c -L${LOCALBASE}/lib -I${LOCALBASE}/include mod_geoip.c
+
+do-install:
+ ${APXS} -i -A -n geoip ${WRKSRC}/mod_geoip.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/mod_geoip
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/mod_geoip/
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_geoip/distinfo b/www/mod_geoip/distinfo
new file mode 100644
index 000000000000..89a4bb4af50b
--- /dev/null
+++ b/www/mod_geoip/distinfo
@@ -0,0 +1 @@
+MD5 (mod_geoip_1.1.1.tar.gz) = 9696b839f4b754935b3f1f0671618075
diff --git a/www/mod_geoip/pkg-comment b/www/mod_geoip/pkg-comment
new file mode 100644
index 000000000000..5927e4566718
--- /dev/null
+++ b/www/mod_geoip/pkg-comment
@@ -0,0 +1 @@
+An Apache module that provides the country code of the client's IP
diff --git a/www/mod_geoip/pkg-descr b/www/mod_geoip/pkg-descr
new file mode 100644
index 000000000000..f3e8285e67cf
--- /dev/null
+++ b/www/mod_geoip/pkg-descr
@@ -0,0 +1,4 @@
+mod_geoip is an Apache module that looks up the country code for the
+IP address making the request without using reverse DNS.
+
+WWW: http://www.maxmind.com/app/mod_geoip
diff --git a/www/mod_geoip/pkg-message b/www/mod_geoip/pkg-message
new file mode 100644
index 000000000000..06e3376a1a12
--- /dev/null
+++ b/www/mod_geoip/pkg-message
@@ -0,0 +1,14 @@
+************************************************************
+Please edit your apache.conf or httpd.conf to enable and
+setup this module.
+
+You can always refer to the useful documents held in
+${PREFIX}/share/doc/mod_geoip/, where ${PREFIX} is
+typically /usr/local.
+
+When it's done, do the following to take effect:
+
+ apachectl configtest (and correct any errors reported)
+ apachectl restart
+
+************************************************************
diff --git a/www/mod_geoip/pkg-plist b/www/mod_geoip/pkg-plist
new file mode 100644
index 000000000000..81499bdfedd7
--- /dev/null
+++ b/www/mod_geoip/pkg-plist
@@ -0,0 +1,8 @@
+libexec/apache/mod_geoip.so
+@exec %D/sbin/apxs -e -A -n geoip %D/%F
+@unexec %D/sbin/apxs -e -A -n geoip %D/%F
+share/doc/mod_geoip/Changes
+share/doc/mod_geoip/INSTALL
+share/doc/mod_geoip/README
+share/doc/mod_geoip/README.php
+@dirrm share/doc/mod_geoip