aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2013-05-31 17:08:22 +0000
committerTom Judge <tj@FreeBSD.org>2013-05-31 17:08:22 +0000
commitdb54613a4b9d0e6217daeee0917fd0052a7b7f6e (patch)
tree95b31e6718c9d76c88e8c790cd94271446359439 /www
parente4313a22e4961e03f9e5629f1283858b57afc2b2 (diff)
downloadports-db54613a4b9d0e6217daeee0917fd0052a7b7f6e.tar.gz
ports-db54613a4b9d0e6217daeee0917fd0052a7b7f6e.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Dancer-Logger-Log4perl/Makefile23
-rw-r--r--www/p5-Dancer-Logger-Log4perl/distinfo2
-rw-r--r--www/p5-Dancer-Logger-Log4perl/pkg-descr4
-rw-r--r--www/p5-Dancer-Logger-Log4perl/pkg-plist7
5 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3d91508583aa..fd85d4db5159 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -852,6 +852,7 @@
SUBDIR += p5-Continuity
SUBDIR += p5-Corona
SUBDIR += p5-Dancer
+ SUBDIR += p5-Dancer-Logger-Log4perl
SUBDIR += p5-Dancer-Plugin-Feed
SUBDIR += p5-Dancer-Plugin-SiteMap
SUBDIR += p5-Dancer-Plugin-ValidationClass
diff --git a/www/p5-Dancer-Logger-Log4perl/Makefile b/www/p5-Dancer-Logger-Log4perl/Makefile
new file mode 100644
index 000000000000..5e5732b7a639
--- /dev/null
+++ b/www/p5-Dancer-Logger-Log4perl/Makefile
@@ -0,0 +1,23 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Dancer-Logger-Log4perl
+PORTVERSION= 0.8.1
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Dancer logging adapter for Log::Log4perl
+
+LICENSE= ART20
+
+BUILD_DEPENDS= p5-Dancer>=1.2001:${PORTSDIR}/www/p5-Dancer \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Dancer::Logger::Log4perl.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Dancer-Logger-Log4perl/distinfo b/www/p5-Dancer-Logger-Log4perl/distinfo
new file mode 100644
index 000000000000..f3dcdb1b5ad4
--- /dev/null
+++ b/www/p5-Dancer-Logger-Log4perl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Logger-Log4perl-0.8.1.tar.gz) = e880bde9bf24cf196360dfe0072a2301220b6faddf4a9d2ba7bcff1bb96f84ed
+SIZE (Dancer-Logger-Log4perl-0.8.1.tar.gz) = 10549
diff --git a/www/p5-Dancer-Logger-Log4perl/pkg-descr b/www/p5-Dancer-Logger-Log4perl/pkg-descr
new file mode 100644
index 000000000000..bb8ef05511af
--- /dev/null
+++ b/www/p5-Dancer-Logger-Log4perl/pkg-descr
@@ -0,0 +1,4 @@
+An interface between Dancer's logging engine abstraction layer and the
+Log::Log4perl library.
+
+WWW: http://search.cpan.org/dist/Dancer-Logger-Log4perl/
diff --git a/www/p5-Dancer-Logger-Log4perl/pkg-plist b/www/p5-Dancer-Logger-Log4perl/pkg-plist
new file mode 100644
index 000000000000..c9b30df99a0f
--- /dev/null
+++ b/www/p5-Dancer-Logger-Log4perl/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Dancer/Logger/Log4perl.pm
+%%SITE_PERL%%/mach/auto/Dancer/Logger/Log4perl/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/Dancer/Logger/Log4perl
+@dirrmtry %%SITE_PERL%%/mach/auto/Dancer/Logger
+@dirrmtry %%SITE_PERL%%/mach/auto/Dancer
+@dirrmtry %%SITE_PERL%%/Dancer/Logger
+@dirrmtry %%SITE_PERL%%/Dancer