aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-25 09:22:45 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-25 09:22:45 +0000
commitb4f2244de51e471b013dd0235d99e2b60cc44bdf (patch)
tree709535d3f66202b5b3112075ffa1a09a99aea2db /www
parentf072ef3d87faf4654323a314cbbd66a75d37e1b3 (diff)
downloadports-b4f2244de51e471b013dd0235d99e2b60cc44bdf.tar.gz
ports-b4f2244de51e471b013dd0235d99e2b60cc44bdf.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_log_mysql/Makefile35
-rw-r--r--www/mod_log_mysql/distinfo1
-rw-r--r--www/mod_log_mysql/pkg-comment1
-rw-r--r--www/mod_log_mysql/pkg-descr4
-rw-r--r--www/mod_log_mysql/pkg-plist9
-rw-r--r--www/mod_log_sql/Makefile35
-rw-r--r--www/mod_log_sql/distinfo1
-rw-r--r--www/mod_log_sql/pkg-comment1
-rw-r--r--www/mod_log_sql/pkg-descr4
-rw-r--r--www/mod_log_sql/pkg-plist9
11 files changed, 101 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4eaedb6cc748..ddcb367845d4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -148,6 +148,7 @@
SUBDIR += mod_index_rss
SUBDIR += mod_jk
SUBDIR += mod_layout
+ SUBDIR += mod_log_mysql
SUBDIR += mod_mp3
SUBDIR += mod_mylo
SUBDIR += mod_mysqluserdir
diff --git a/www/mod_log_mysql/Makefile b/www/mod_log_mysql/Makefile
new file mode 100644
index 000000000000..86eaadbe791c
--- /dev/null
+++ b/www/mod_log_mysql/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: apache mod_log_mysql
+# Date created: 2001/11/22
+# Whom: lev@serebryakov.spb.ru
+#
+# $FreeBSD$
+
+PORTNAME= mod_log_mysql
+PORTVERSION= 1.09
+CATEGORIES= www databases
+MASTER_SITES= http://www.grubbybaby.com/mod_log_mysql/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= lev@serebryakov.spb.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/${AP_PORT}
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/${AP_PORT}
+
+AP_PORT?= www/apache13
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c -o ${PORTNAME}.so -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib/mysql -lmysqlclient ${PORTNAME}.c
+
+do-install:
+ cd ${WRKSRC} && ${APXS} -i -n ${PORTNAME:S/^mod_//} -A ${PORTNAME}.so
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in CONFIGURATION INSTALL README access_log.sql make_combined_log.pl
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_log_mysql/distinfo b/www/mod_log_mysql/distinfo
new file mode 100644
index 000000000000..a1a51befd13d
--- /dev/null
+++ b/www/mod_log_mysql/distinfo
@@ -0,0 +1 @@
+MD5 (mod_log_mysql.tar.gz) = ced2720abc250f19b4ec8caf1c22cfdb
diff --git a/www/mod_log_mysql/pkg-comment b/www/mod_log_mysql/pkg-comment
new file mode 100644
index 000000000000..c9b381ec2a0e
--- /dev/null
+++ b/www/mod_log_mysql/pkg-comment
@@ -0,0 +1 @@
+Allows Apache to log to a MySQL database
diff --git a/www/mod_log_mysql/pkg-descr b/www/mod_log_mysql/pkg-descr
new file mode 100644
index 000000000000..ed8ade81cda8
--- /dev/null
+++ b/www/mod_log_mysql/pkg-descr
@@ -0,0 +1,4 @@
+This add-on module allows the apache web server to use a MySQL database for
+logging of all operations.
+
+WWW: http://www.grubbybaby.com/mod_log_mysql/
diff --git a/www/mod_log_mysql/pkg-plist b/www/mod_log_mysql/pkg-plist
new file mode 100644
index 000000000000..7523a11ecf52
--- /dev/null
+++ b/www/mod_log_mysql/pkg-plist
@@ -0,0 +1,9 @@
+@exec %D/sbin/apxs -e -A -n log_mysql -A mod_log_mysql.so
+libexec/apache/mod_log_mysql.so
+@unexec %D/sbin/apxs -e -A -n log_mysql %f
+%%PORTDOCS%%share/doc/mod_log_mysql/CONFIGURATION
+%%PORTDOCS%%share/doc/mod_log_mysql/INSTALL
+%%PORTDOCS%%share/doc/mod_log_mysql/README
+%%PORTDOCS%%share/doc/mod_log_mysql/access_log.sql
+%%PORTDOCS%%share/doc/mod_log_mysql/make_combined_log.pl
+%%PORTDOCS%%@dirrm share/doc/mod_log_mysql
diff --git a/www/mod_log_sql/Makefile b/www/mod_log_sql/Makefile
new file mode 100644
index 000000000000..86eaadbe791c
--- /dev/null
+++ b/www/mod_log_sql/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: apache mod_log_mysql
+# Date created: 2001/11/22
+# Whom: lev@serebryakov.spb.ru
+#
+# $FreeBSD$
+
+PORTNAME= mod_log_mysql
+PORTVERSION= 1.09
+CATEGORIES= www databases
+MASTER_SITES= http://www.grubbybaby.com/mod_log_mysql/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= lev@serebryakov.spb.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/${AP_PORT}
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/${AP_PORT}
+
+AP_PORT?= www/apache13
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c -o ${PORTNAME}.so -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib/mysql -lmysqlclient ${PORTNAME}.c
+
+do-install:
+ cd ${WRKSRC} && ${APXS} -i -n ${PORTNAME:S/^mod_//} -A ${PORTNAME}.so
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in CONFIGURATION INSTALL README access_log.sql make_combined_log.pl
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_log_sql/distinfo b/www/mod_log_sql/distinfo
new file mode 100644
index 000000000000..a1a51befd13d
--- /dev/null
+++ b/www/mod_log_sql/distinfo
@@ -0,0 +1 @@
+MD5 (mod_log_mysql.tar.gz) = ced2720abc250f19b4ec8caf1c22cfdb
diff --git a/www/mod_log_sql/pkg-comment b/www/mod_log_sql/pkg-comment
new file mode 100644
index 000000000000..c9b381ec2a0e
--- /dev/null
+++ b/www/mod_log_sql/pkg-comment
@@ -0,0 +1 @@
+Allows Apache to log to a MySQL database
diff --git a/www/mod_log_sql/pkg-descr b/www/mod_log_sql/pkg-descr
new file mode 100644
index 000000000000..ed8ade81cda8
--- /dev/null
+++ b/www/mod_log_sql/pkg-descr
@@ -0,0 +1,4 @@
+This add-on module allows the apache web server to use a MySQL database for
+logging of all operations.
+
+WWW: http://www.grubbybaby.com/mod_log_mysql/
diff --git a/www/mod_log_sql/pkg-plist b/www/mod_log_sql/pkg-plist
new file mode 100644
index 000000000000..7523a11ecf52
--- /dev/null
+++ b/www/mod_log_sql/pkg-plist
@@ -0,0 +1,9 @@
+@exec %D/sbin/apxs -e -A -n log_mysql -A mod_log_mysql.so
+libexec/apache/mod_log_mysql.so
+@unexec %D/sbin/apxs -e -A -n log_mysql %f
+%%PORTDOCS%%share/doc/mod_log_mysql/CONFIGURATION
+%%PORTDOCS%%share/doc/mod_log_mysql/INSTALL
+%%PORTDOCS%%share/doc/mod_log_mysql/README
+%%PORTDOCS%%share/doc/mod_log_mysql/access_log.sql
+%%PORTDOCS%%share/doc/mod_log_mysql/make_combined_log.pl
+%%PORTDOCS%%@dirrm share/doc/mod_log_mysql