aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-05 13:33:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-05 13:33:12 +0000
commit474f5cd212706f48c090cfa9f84c88ea933f32eb (patch)
tree03e3d4fff93419225e4fb2b6b16fd4e4f8a77b96 /www
parentf554ee40ab230dbfec2e9cb5b34e0330eeb94f07 (diff)
downloadports-474f5cd212706f48c090cfa9f84c88ea933f32eb.tar.gz
ports-474f5cd212706f48c090cfa9f84c88ea933f32eb.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/zerowait-httpd/Makefile15
-rw-r--r--www/zerowait-httpd/distinfo6
-rw-r--r--www/zerowait-httpd/files/patch-Makefile9
-rw-r--r--www/zerowait-httpd/files/patch-src_common_settings.h18
-rw-r--r--www/zerowait-httpd/pkg-plist12
5 files changed, 29 insertions, 31 deletions
diff --git a/www/zerowait-httpd/Makefile b/www/zerowait-httpd/Makefile
index 51164b5ca989..f87b98480879 100644
--- a/www/zerowait-httpd/Makefile
+++ b/www/zerowait-httpd/Makefile
@@ -5,21 +5,22 @@
# $FreeBSD$
#
-PORTNAME= zerowait-httpd
-PORTVERSION= 0.7p
+PORTNAME= zerowait
+PORTVERSION= 0.8d
CATEGORIES= www
-MASTER_SITES= http://www.0w.ru/httpd/
-DISTNAME= 0W-httpd-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+MASTER_SITES= http://www.0w.ru/httpd/ \
+ http://mirror.mcx2.org/
+PKGNAMESUFFIX= -httpd
+DISTNAME= 0W-httpd-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= adox@mcx2.org
COMMENT= Lightweight and fast http server
USE_GMAKE= yes
USE_OPENSSL= yes
USE_RC_SUBR= 0W-httpd
-ALL_TARGET= # none
+ALL_TARGET= #none
-MAKE_ARGS= CFLAGS="${CFLAGS}" CPPFLAGS=-I..
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --owner=${WWWOWN} --group=${WWWGRP}
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
diff --git a/www/zerowait-httpd/distinfo b/www/zerowait-httpd/distinfo
index 1f5c6424ed19..536816af66be 100644
--- a/www/zerowait-httpd/distinfo
+++ b/www/zerowait-httpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (0W-httpd-0.7p.tar.gz) = 4d4a3fe0581b5b1e4fad50c34a1c0d7f
-SHA256 (0W-httpd-0.7p.tar.gz) = db4e9c3eca019b61a86abbb0866827d8b344bd316ef8f8ef0738ee54001be4f8
-SIZE (0W-httpd-0.7p.tar.gz) = 99506
+MD5 (0W-httpd-0.8d.tar.gz) = 2fd1db27c4d2950a63da271e2c839197
+SHA256 (0W-httpd-0.8d.tar.gz) = 17e80d7eb9bed49736f696c720d4f6fdb25e974f615e1dd456c455d885233e13
+SIZE (0W-httpd-0.8d.tar.gz) = 111979
diff --git a/www/zerowait-httpd/files/patch-Makefile b/www/zerowait-httpd/files/patch-Makefile
index e9eca3379414..8af6dc3d7e81 100644
--- a/www/zerowait-httpd/files/patch-Makefile
+++ b/www/zerowait-httpd/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Dec 5 15:06:00 2006
-+++ Makefile Tue Dec 5 15:07:24 2006
+--- Makefile.orig 2008-03-16 00:44:45.000000000 +0100
++++ Makefile 2008-09-26 19:44:38.000000000 +0200
@@ -13,13 +13,14 @@
rm -f *~ src/*~
@@ -8,12 +8,12 @@
- install -d -o $(OWNER) -g $(GROUP) $(ROOT)/logs $(ROOT)/data/pids $(ROOT)/data/httpd
- test -f $(ROOT)/conf/httpd.conf || install -m 644 conf/httpd.conf* $(ROOT)/conf
- install -b -m 644 conf/countries* conf/regions* $(ROOT)/conf
-- install -b -m 644 docs/crontab docs/httpd.ru.txt $(ROOT)/docs
+- install -b -m 644 docs/*.txt $(ROOT)/docs
- install -b bin/update-countries.sh src/httpd/convert-ranges src/httpd/convert-geoip $(ROOT)/bin
- install -b -m 6755 -o $(OWNER) -g $(GROUP) src/httpd/0W-httpd $(ROOT)/bin
+ test -d $(ROOT)/0W-httpd || (mkdir $(ROOT)/0W-httpd)
+ install -d $(ROOT)/0W-httpd/data $(ROOT)/0W-httpd/logs $(ROOT)/0W-httpd/pids
-+ install -m 0755 bin/update-countries.sh src/httpd/convert-ranges src/httpd/convert-geoip $(ROOT)/bin
++ install -m 755 bin/update-countries.sh src/httpd/convert-ranges src/httpd/convert-geoip $(ROOT)/bin
+ install -m 6755 -o $(OWNER) -g $(GROUP) src/httpd/0W-httpd $(ROOT)/sbin
+ test -d $(ROOT)/etc/0W-httpd || (mkdir $(ROOT)/etc/0W-httpd && cd conf/ && \
+ cp countries* $(ROOT)/etc/0W-httpd/ && \
@@ -21,4 +21,3 @@
+ chown -R $(OWNER):$(GROUP) $(ROOT)/sbin/0W-httpd $(ROOT)/0W-httpd/logs $(ROOT)/0W-httpd/data $(ROOT)/0W-httpd/pids
@echo
@echo "Installed, run as root: $(ROOT)/bin/0W-httpd [-h]"
-
diff --git a/www/zerowait-httpd/files/patch-src_common_settings.h b/www/zerowait-httpd/files/patch-src_common_settings.h
index 3ad7e92c7e0e..34baf54d18b4 100644
--- a/www/zerowait-httpd/files/patch-src_common_settings.h
+++ b/www/zerowait-httpd/files/patch-src_common_settings.h
@@ -1,6 +1,6 @@
---- src/common/settings.h.orig Sat Apr 16 06:48:58 2005
-+++ src/common/settings.h Wed Jun 22 13:35:16 2005
-@@ -37,18 +37,18 @@
+--- src/common/settings.h.orig 2008-02-04 12:42:36.000000000 +0100
++++ src/common/settings.h 2008-09-26 18:59:48.000000000 +0200
+@@ -40,15 +40,15 @@
#ifndef ROOT
#define ROOT "/var/0W"
#endif
@@ -9,21 +9,17 @@
-#define CMD ROOT "/cmd"
-#define LOGS ROOT "/logs"
-#define TMP ROOT "/tmp"
-+
+#define CONF ROOT "/etc/0W-httpd/"
+#define DATA ROOT "/0W-httpd"
-+#define CMD ROOT "/0W-httpd/cmd"
++#define CMD ROOT "/0W-httpd/cmd"
+#define LOGS ROOT "/0W-httpd/logs"
-+#define TMP ROOT "/0W-httpd/tmp"
++#define TMP ROOT "/0W-httpd/tmp"
#define PIDS DATA "/pids"
#define TMPL DATA "/templates"
-#define WWW ROOT "/www"
-#define HTML WWW "/data"
-+#define WWW ROOT "/0W-httpd"
-+#define HTML ROOT "/0W-httpd/data"
++#define WWW ROOT "/0W-httpd"
++#define HTML WWW "/0W-httpd/data"
#define RN "\r\n"
--
- #if __GLIBC__ == 2 && __GLIBC_MINOR__ >= 1
- #define HAVE_BACKTRACE
diff --git a/www/zerowait-httpd/pkg-plist b/www/zerowait-httpd/pkg-plist
index 0f93ee8c904b..d12cd8e091b6 100644
--- a/www/zerowait-httpd/pkg-plist
+++ b/www/zerowait-httpd/pkg-plist
@@ -1,17 +1,19 @@
@unexec %D/etc/rc.d/0W-httpd stop
-bin/update-countries.sh
-bin/convert-ranges
bin/convert-geoip
-sbin/0W-httpd
+bin/convert-ranges
+bin/update-countries.sh
etc/0W-httpd/countries
etc/0W-httpd/countries.ips
etc/0W-httpd/countries.rus
+@unexec if cmp -s %D/etc/0W-httpd/httpd.conf.sample %D/etc/0W-httpd/httpd.conf; then rm -f %D/etc/0W-httpd/httpd.conf; fi
etc/0W-httpd/httpd.conf.sample
+@exec if [ ! -f %D/etc/0W-httpd/httpd.conf ] ; then cp -p %D/%F %B/httpd.conf; fi
@exec install -d -o %%WWWOWN%% -g %%WWWGRP%% %D/0W-httpd/pids
@exec install -d -o %%WWWOWN%% -g %%WWWGRP%% %D/0W-httpd/data
@exec install -d -o %%WWWOWN%% -g %%WWWGRP%% %D/0W-httpd/logs
-@dirrm etc/0W-httpd/
+sbin/0W-httpd
+@unexec rm -fr %D/0W-httpd/logs > /dev/null 2>&1 || true
+@dirrmtry etc/0W-httpd
@dirrm 0W-httpd/pids
@dirrm 0W-httpd/data
-@unexec rm -fr %D/0W-httpd/logs > /dev/null 2>&1 || true
@dirrm 0W-httpd