aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:17:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:17:53 +0000
commit7efe191d8c25c7e652d5e61ee6c04bfadb251d9d (patch)
treea586d3ce4cbc005a5aadd08bf903a7f7eb6baa76 /www
parent8ff9fe4cde21d5f51465f75c726416afc24eb5ca (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/pear-HTTP_WebDAV_Client/Makefile25
-rw-r--r--www/pear-HTTP_WebDAV_Client/distinfo3
-rw-r--r--www/pear-HTTP_WebDAV_Client/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 024916396bce..3c7d068961b1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1088,6 +1088,7 @@
SUBDIR += pear-HTTP_Server
SUBDIR += pear-HTTP_Session2
SUBDIR += pear-HTTP_Upload
+ SUBDIR += pear-HTTP_WebDAV_Client
SUBDIR += pear-HTTP_WebDAV_Server
SUBDIR += pear-Services_Blogging
SUBDIR += pear-Services_Compete
diff --git a/www/pear-HTTP_WebDAV_Client/Makefile b/www/pear-HTTP_WebDAV_Client/Makefile
new file mode 100644
index 000000000000..936d5922607c
--- /dev/null
+++ b/www/pear-HTTP_WebDAV_Client/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: HTTP_WebDAV_Client
+# Date created: 14 Nov 2008
+# Whom: Wen Heping<wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_WebDAV_Client
+PORTVERSION= 1.0.0
+CATEGORIES= www devel pear
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= WebDAV Stream Wrapper Class
+
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTTP/WebDAV
+FILES= Client.php Client/Stream.php \
+ Tools/_parse_lock_response.php \
+ Tools/_parse_propfind_response.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTTP_WebDAV_Client/distinfo b/www/pear-HTTP_WebDAV_Client/distinfo
new file mode 100644
index 000000000000..2fff7cfa4e1d
--- /dev/null
+++ b/www/pear-HTTP_WebDAV_Client/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/HTTP_WebDAV_Client-1.0.0.tgz) = 733466e90cf1c13c95843139a548b9e7
+SHA256 (PEAR/HTTP_WebDAV_Client-1.0.0.tgz) = 36de10b6754a2a6ade7b4fb96ef01c6471dde94d108bd617da1e07aaf306636a
+SIZE (PEAR/HTTP_WebDAV_Client-1.0.0.tgz) = 7622
diff --git a/www/pear-HTTP_WebDAV_Client/pkg-descr b/www/pear-HTTP_WebDAV_Client/pkg-descr
new file mode 100644
index 000000000000..f0516977420d
--- /dev/null
+++ b/www/pear-HTTP_WebDAV_Client/pkg-descr
@@ -0,0 +1,5 @@
+HTTP_WebDAV_Client is a RFC2518 compliant stream wrapper
+that allows to use WebDAV server resources like a regular
+file system from within PHP.
+
+WWW: http://pear.php.net/package/HTTP_WebDAV_Client/