aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-06-24 15:23:09 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-06-24 15:23:09 +0000
commit9e1daeefa2688fad89efb247c44a42aea07c38f5 (patch)
treec2f7766731e5b21c355aa5b6ade68ca9924ee6e1 /www
parente1acac6966f8881a065f7cb77a998102f2de4434 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/moodle/Makefile14
-rw-r--r--www/moodle/distinfo6
-rw-r--r--www/moodle/files/pkg-message.in51
-rw-r--r--www/moodle/pkg-message36
-rw-r--r--www/moodle2/Makefile14
-rw-r--r--www/moodle2/distinfo6
-rw-r--r--www/moodle2/files/pkg-message.in51
-rw-r--r--www/moodle2/pkg-message36
8 files changed, 126 insertions, 88 deletions
diff --git a/www/moodle/Makefile b/www/moodle/Makefile
index dd8f3622a004..9581178b1372 100644
--- a/www/moodle/Makefile
+++ b/www/moodle/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= moodle
-PORTVERSION= 1.5.3
+PORTVERSION= 1.5.4
CATEGORIES= www
MASTER_SITES= http://download.moodle.org/stable15/
EXTRACT_SUFX= .tgz
@@ -25,10 +25,17 @@ USE_PHP+= mysql
USE_PHP+= pgsql
.endif
+.if defined(WITH_LDAP)
+USE_PHP+= ldap
+.endif
+
.include <bsd.port.pre.mk>
NO_BUILD= yes
PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
MOODLEDIR?= www/moodle
MOODLEDATADIR?= www/moodledata
@@ -38,12 +45,9 @@ pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "o WITH_MYSQL - Use a MySQL database"
@${ECHO_CMD} "o WITH_PGSQL - Use a pgSQL database"
+ @${ECHO_CMD} "o WITH_LDAP - Ensure your PHP has ldap extension"
@${ECHO_CMD} ""
-post-patch:
-####This is an old patched file.
- @${RM} -f ${WRKSRC}/lang/es_es/moodle.php.orig
-
pre-install:
@${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
@${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
diff --git a/www/moodle/distinfo b/www/moodle/distinfo
index 92ff1021d6c8..1a3955f88d9e 100644
--- a/www/moodle/distinfo
+++ b/www/moodle/distinfo
@@ -1,3 +1,3 @@
-MD5 (moodle-1.5.3.tgz) = 52dd50298fc1dd8b1b6d8d499608cdd6
-SHA256 (moodle-1.5.3.tgz) = 26c1fd107f02fbfee96b081c3b321fd6c61dac9fb397b90b1c197a11f38c52ed
-SIZE (moodle-1.5.3.tgz) = 15003431
+MD5 (moodle-1.5.4.tgz) = 86cddfda2b6d9a08b37cc3a16bda1090
+SHA256 (moodle-1.5.4.tgz) = 368d850acd03d9a21786ce7a451466496a93341f7a21db423c5703cdddf994f9
+SIZE (moodle-1.5.4.tgz) = 15126672
diff --git a/www/moodle/files/pkg-message.in b/www/moodle/files/pkg-message.in
new file mode 100644
index 000000000000..bbb879884d21
--- /dev/null
+++ b/www/moodle/files/pkg-message.in
@@ -0,0 +1,51 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql
+ or phpX-mysql packages are installed, as needed.
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On ### Add this directive only for Apache 2.0.30 or later.
+ <Directory %%PREFIX%%/%%MOODLEDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+ <Directory %%PREFIX%%/%%MOODLEDATADIR%%>
+ AllowOverride None
+ Order Deny,Allow
+ Deny from all
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to call the file admin/cron.php
+ every five minutes or so. You can do so by using wget,
+ links or something similar to open the web page
+ http://your.server.com/moodle/admin/cron.php.
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
diff --git a/www/moodle/pkg-message b/www/moodle/pkg-message
deleted file mode 100644
index 661a25a04c9e..000000000000
--- a/www/moodle/pkg-message
+++ /dev/null
@@ -1,36 +0,0 @@
-POST-INSTALL CONFIGURATION FOR MOODLE
-=====================================
-
-1) Create a user and a database for Moodle to store all
- its tables in (or choose an existing database).
- NOTE: this package assumes that either the php4-pgsql
- or php4-mysql packages are installed, as needed.
-
-2) Add the following to your Apache configuration, and
- restart the server:
-
- AcceptPathInfo On
- <Directory ${PREFIX}/www/moodledata>
- AllowOverride None
- Order Deny,Allow
- Deny from all
- </Directory>
-
-3) Visit your Moodle site with a browser (i.e.,
- http://your.server.com/moodle), and you should
- be taken to the install.php script, which will lead
- you through creating a config.php file and then
- setting up Moodle, creating an admin account etc.
-
-4) Set up a cron task to call the file admin/cron.php
- every five minutes or so. You can do so by using wget,
- links or something similar to open the web page
- http://your.server.com/moodle/admin/cron.php.
-
-
-For more information, see the INSTALL DOCUMENTATION:
-
- http://moodle.org/doc
-
-If you have real trouble, please visit the Moodle course
-"Using Moodle" on moodle.org.
diff --git a/www/moodle2/Makefile b/www/moodle2/Makefile
index dd8f3622a004..9581178b1372 100644
--- a/www/moodle2/Makefile
+++ b/www/moodle2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= moodle
-PORTVERSION= 1.5.3
+PORTVERSION= 1.5.4
CATEGORIES= www
MASTER_SITES= http://download.moodle.org/stable15/
EXTRACT_SUFX= .tgz
@@ -25,10 +25,17 @@ USE_PHP+= mysql
USE_PHP+= pgsql
.endif
+.if defined(WITH_LDAP)
+USE_PHP+= ldap
+.endif
+
.include <bsd.port.pre.mk>
NO_BUILD= yes
PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
MOODLEDIR?= www/moodle
MOODLEDATADIR?= www/moodledata
@@ -38,12 +45,9 @@ pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "o WITH_MYSQL - Use a MySQL database"
@${ECHO_CMD} "o WITH_PGSQL - Use a pgSQL database"
+ @${ECHO_CMD} "o WITH_LDAP - Ensure your PHP has ldap extension"
@${ECHO_CMD} ""
-post-patch:
-####This is an old patched file.
- @${RM} -f ${WRKSRC}/lang/es_es/moodle.php.orig
-
pre-install:
@${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
@${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
diff --git a/www/moodle2/distinfo b/www/moodle2/distinfo
index 92ff1021d6c8..1a3955f88d9e 100644
--- a/www/moodle2/distinfo
+++ b/www/moodle2/distinfo
@@ -1,3 +1,3 @@
-MD5 (moodle-1.5.3.tgz) = 52dd50298fc1dd8b1b6d8d499608cdd6
-SHA256 (moodle-1.5.3.tgz) = 26c1fd107f02fbfee96b081c3b321fd6c61dac9fb397b90b1c197a11f38c52ed
-SIZE (moodle-1.5.3.tgz) = 15003431
+MD5 (moodle-1.5.4.tgz) = 86cddfda2b6d9a08b37cc3a16bda1090
+SHA256 (moodle-1.5.4.tgz) = 368d850acd03d9a21786ce7a451466496a93341f7a21db423c5703cdddf994f9
+SIZE (moodle-1.5.4.tgz) = 15126672
diff --git a/www/moodle2/files/pkg-message.in b/www/moodle2/files/pkg-message.in
new file mode 100644
index 000000000000..bbb879884d21
--- /dev/null
+++ b/www/moodle2/files/pkg-message.in
@@ -0,0 +1,51 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql
+ or phpX-mysql packages are installed, as needed.
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On ### Add this directive only for Apache 2.0.30 or later.
+ <Directory %%PREFIX%%/%%MOODLEDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+ <Directory %%PREFIX%%/%%MOODLEDATADIR%%>
+ AllowOverride None
+ Order Deny,Allow
+ Deny from all
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to call the file admin/cron.php
+ every five minutes or so. You can do so by using wget,
+ links or something similar to open the web page
+ http://your.server.com/moodle/admin/cron.php.
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
diff --git a/www/moodle2/pkg-message b/www/moodle2/pkg-message
deleted file mode 100644
index 661a25a04c9e..000000000000
--- a/www/moodle2/pkg-message
+++ /dev/null
@@ -1,36 +0,0 @@
-POST-INSTALL CONFIGURATION FOR MOODLE
-=====================================
-
-1) Create a user and a database for Moodle to store all
- its tables in (or choose an existing database).
- NOTE: this package assumes that either the php4-pgsql
- or php4-mysql packages are installed, as needed.
-
-2) Add the following to your Apache configuration, and
- restart the server:
-
- AcceptPathInfo On
- <Directory ${PREFIX}/www/moodledata>
- AllowOverride None
- Order Deny,Allow
- Deny from all
- </Directory>
-
-3) Visit your Moodle site with a browser (i.e.,
- http://your.server.com/moodle), and you should
- be taken to the install.php script, which will lead
- you through creating a config.php file and then
- setting up Moodle, creating an admin account etc.
-
-4) Set up a cron task to call the file admin/cron.php
- every five minutes or so. You can do so by using wget,
- links or something similar to open the web page
- http://your.server.com/moodle/admin/cron.php.
-
-
-For more information, see the INSTALL DOCUMENTATION:
-
- http://moodle.org/doc
-
-If you have real trouble, please visit the Moodle course
-"Using Moodle" on moodle.org.