aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-28 08:10:54 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-28 08:10:54 +0000
commita5e36659f4126577dbe411e113199c0742f18682 (patch)
tree9e4ecab82104956aa9ac33f3def7157375958ffb /www
parent0f8d106ae4886b0eb4f81dae949b23ca883a27fa (diff)
Update to 0.2.6.
Add xfce to Categories, clean up depends that are pulled in by webkit already. Add options for api and user documents. Add a freshports entry for the search bar. Fix the openssl detection test. Based on PR: ports/144830 (update to 0.2.4), ports/146710 (update to 0.2.5) Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com> Approved by: maintainer (implicit)
Notes
Notes: svn path=/head/; revision=255228
Diffstat (limited to 'www')
-rw-r--r--www/midori/Makefile52
-rw-r--r--www/midori/distinfo6
-rw-r--r--www/midori/files/patch-data_search16
-rw-r--r--www/midori/files/patch-wscript12
-rw-r--r--www/midori/pkg-plist65
5 files changed, 134 insertions, 17 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 4ac941f82603..8f42e99df48e 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -7,38 +7,46 @@
#
PORTNAME= midori
-PORTVERSION= 0.2.5
-CATEGORIES= www
+PORTVERSION= 0.2.6
+PORTREVISION= 1
+CATEGORIES= www xfce
MASTER_SITES= http://archive.xfce.org/src/apps/${PORTNAME}/${PORTVERSION:R}/
+DIST_SUBDIR= xfce4
MAINTAINER= ahze@FreeBSD.org
COMMENT= Lightweight web browser using WebKit browser engine
LIB_DEPENDS= webkit-1.0:${PORTSDIR}/www/webkit-gtk2 \
- sqlite3.8:${PORTSDIR}/databases/sqlite3 \
notify.1:${PORTSDIR}/devel/libnotify \
- vala.0:${PORTSDIR}/lang/vala \
- soup-2.4:${PORTSDIR}/devel/libsoup
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
- rsvg-convert:${PORTSDIR}/graphics/librsvg2
+ vala.0:${PORTSDIR}/lang/vala
+BUILD_DEPENDS= rsvg-convert:${PORTSDIR}/graphics/librsvg2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+=--disable-unique \
+ --disable-libidn \
+ --enable-sqlite \
+ --enable-libnotify \
+ --enable-addons \
--jobs=${MAKE_JOBS_NUMBER}
MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
-USE_GMAKE= yes
+USE_PYTHON_BUILD= yes
USE_BZIP2= yes
USE_GNOME= glib20 gtk20 intltool libxml2 pkgconfig
+USE_XORG= xscrnsaver
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
+OPTIONS= NLS "Enable Native Language support" on \
+ USERDOCS "Build user documentation" off \
+ APIDOCS "Build api documentation" off
+
.include <bsd.port.pre.mk>
# WAF needs that
-CONFIGURE_ENV+= CC=${CC}
+CONFIGURE_ENV+= CC="${CC}"
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
@@ -48,4 +56,30 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.if defined(WITH_USERDOCS)
+BUILD_DEPENDS+=rst2html:${PORTSDIR}/textproc/py-docutils
+CONFIGURE_ARGS+=--enable-userdocs
+PLIST_SUB+= USERDOCS=""
+.else
+CONFIGURE_ARGS+=--disable-userdocs
+PLIST_SUB+= USERDOCS="@comment "
+.endif
+
+.if defined(WITH_APIDOCS)
+BUILD_DEPENDS+= gtkdoc-scan:${PORTSDIR}/textproc/gtk-doc
+CONFIGURE_ARGS+=--enable-apidocs
+PLIST_SUB+= APIDOCS=""
+.else
+CONFIGURE_ARGS+=--disable-apidocs
+PLIST_SUB+= APIDOCS="@comment "
+.endif
+
+post-install:
+.if defined(WITH_APIDOCS)
+ ${MKDIR} ${DOCSDIR}/api/katze/html
+ ${MKDIR} ${DOCSDIR}/api/midori/html
+ (cd ${WRKSRC}/_build_/docs/api/katze/html && ${COPYTREE_SHARE} \* ${DOCSDIR}/api/katze/html)
+ (cd ${WRKSRC}/_build_/docs/api/midori/html && ${COPYTREE_SHARE} \* ${DOCSDIR}/api/midori/html)
+.endif
+
.include <bsd.port.post.mk>
diff --git a/www/midori/distinfo b/www/midori/distinfo
index 348cd3b60929..60f25541b70f 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,3 +1,3 @@
-MD5 (midori-0.2.5.tar.bz2) = 3aeacd04d4d3e5c3bc16824696ff57b2
-SHA256 (midori-0.2.5.tar.bz2) = 88247235f3873d11f00e653adfbcc34b836e188b96b5d8a1c54d4de6fd940f2a
-SIZE (midori-0.2.5.tar.bz2) = 705277
+MD5 (xfce4/midori-0.2.6.tar.bz2) = 249ddb3485d8246e0fda25dd735953f0
+SHA256 (xfce4/midori-0.2.6.tar.bz2) = 2da90265db44b23161e9b78ea5f78a42db8a10cfaae7dcf6287c880a4b2a6db2
+SIZE (xfce4/midori-0.2.6.tar.bz2) = 712959
diff --git a/www/midori/files/patch-data_search b/www/midori/files/patch-data_search
new file mode 100644
index 000000000000..4fafcf236f60
--- /dev/null
+++ b/www/midori/files/patch-data_search
@@ -0,0 +1,16 @@
+--- data/search.orig 2010-05-26 12:31:56.000000000 +0200
++++ data/search 2010-05-26 12:34:03.000000000 +0200
+@@ -6,6 +6,13 @@
+ icon=
+ token=g
+
++[FreshPorts]
++name=FreshPorts
++text=The changes made to the FreeBSD ports tree
++uri=http://www.freshports.org/search.php?query=%s
++icon=
++token=fp
++
+ [Wikipedia]
+ name=Wikipedia
+ text=The free encyclopedia
diff --git a/www/midori/files/patch-wscript b/www/midori/files/patch-wscript
new file mode 100644
index 000000000000..ccab30837188
--- /dev/null
+++ b/www/midori/files/patch-wscript
@@ -0,0 +1,12 @@
+--- wscript.orig 2010-05-26 12:34:09.000000000 +0200
++++ wscript 2010-05-26 12:35:30.000000000 +0200
+@@ -267,8 +267,7 @@
+ if not conf.env['HAVE_UNIQUE']:
+ if Options.platform == 'win32':
+ conf.check (lib='ws2_32')
+- check_pkg ('openssl', mandatory=False)
+- conf.define ('USE_SSL', [0,1][conf.env['HAVE_OPENSSL'] == 1])
++ conf.define ('HAVE_OPENSSL', [0,1][conf.check (header_name='openssl/opensslv.h')])
+ conf.define ('HAVE_NETDB_H', [0,1][conf.check (header_name='netdb.h')])
+ conf.check (header_name='sys/wait.h')
+ conf.check (header_name='sys/select.h')
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index dada8ffbe71c..e493f63f1fba 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -17,12 +17,62 @@ lib/midori/libtab-panel.so
lib/midori/libtab-switcher.so
lib/midori/libtoolbar-editor.so
lib/midori/libweb-cache.so
-%%NLS%%share/applications/midori.desktop
+share/applications/midori.desktop
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/COPYING
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/EXPAT
%%DOCSDIR%%/README
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/api-index-full.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/ch01.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/home.png
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/index.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/index.sgml
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-KatzeItem.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-KatzePreferences.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-KatzeScrolled.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-array.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-arrayaction.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-http-auth.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-http-cookies.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-net.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-separatoraction.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-throbber.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-utils.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze.devhelp
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze.devhelp2
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/left.png
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/right.png
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/style.css
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/up.png
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/api-index-full.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/ch01.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/home.png
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/index.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/index.sgml
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/left.png
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-GtkIconEntry.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-MidoriBrowser.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-MidoriExtension.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-MidoriPreferences.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-MidoriViewable.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-app.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-array.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-locationaction.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-panel.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-searchaction.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-stock.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-view.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-websettings.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-socket.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-sokoke.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori.devhelp
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori.devhelp2
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/right.png
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/style.css
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/up.png
+%%USERDOCS%%%%DOCSDIR%%/user/midori.html
share/icons/hicolor/16x16/apps/midori.png
share/icons/hicolor/16x16/categories/extension.png
share/icons/hicolor/16x16/status/news-feed.png
@@ -70,6 +120,7 @@ share/icons/hicolor/48x48/status/news-feed.png
%%NLS%%share/locale/sr@latin/LC_MESSAGES/midori.mo
%%NLS%%share/locale/sv/LC_MESSAGES/midori.mo
%%NLS%%share/locale/tr/LC_MESSAGES/midori.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/midori.mo
%%NLS%%share/locale/uk/LC_MESSAGES/midori.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/midori.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/midori.mo
@@ -86,14 +137,18 @@ share/vala/vapi/external-applications.vapi
@dirrmtry share/vala
@dirrm %%DATADIR%%/res
@dirrm %%DATADIR%%
+%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ug
%%NLS%%@dirrmtry share/locale/sr@latin/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/sr@latin
-%%NLS%%@dirrmtry share/locale/pa/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/pa
-%%NLS%%@dirrmtry share/locale/hr/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/hr
%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ast
+%%APIDOCS%%@dirrm %%DOCSDIR%%/api/midori/html
+%%APIDOCS%%@dirrm %%DOCSDIR%%/api/midori
+%%APIDOCS%%@dirrm %%DOCSDIR%%/api/katze/html
+%%APIDOCS%%@dirrm %%DOCSDIR%%/api/katze
+%%APIDOCS%%@dirrm %%DOCSDIR%%/api
+%%USERDOCS%%@dirrm %%DOCSDIR%%/user
@dirrm %%DOCSDIR%%
@dirrmtry share/applications
@dirrm lib/midori