aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2003-04-02 20:12:08 +0000
committerAnton Berezin <tobez@FreeBSD.org>2003-04-02 20:12:08 +0000
commitab35a4fd2e4dd87c395cdab4dcaaea697f456e42 (patch)
tree0f601351233d5f6ab6109a81103f983bf1e462d6 /www
parentac04cdaac3b7eef0b3956f41754d393daa4f37a1 (diff)
downloadports-ab35a4fd2e4dd87c395cdab4dcaaea697f456e42.tar.gz
ports-ab35a4fd2e4dd87c395cdab4dcaaea697f456e42.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-Mechanize/Makefile41
-rw-r--r--www/p5-WWW-Mechanize/distinfo1
-rw-r--r--www/p5-WWW-Mechanize/pkg-descr9
-rw-r--r--www/p5-WWW-Mechanize/pkg-plist5
5 files changed, 57 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ff383c10e61b..a76f7bf22d06 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -357,6 +357,7 @@
SUBDIR += p5-WWW-Babelfish
SUBDIR += p5-WWW-IMDb
SUBDIR += p5-WWW-Link
+ SUBDIR += p5-WWW-Mechanize
SUBDIR += p5-WWW-Robot
SUBDIR += p5-WWW-Search
SUBDIR += p5-WWW-Search-AltaVista
diff --git a/www/p5-WWW-Mechanize/Makefile b/www/p5-WWW-Mechanize/Makefile
new file mode 100644
index 000000000000..be64d282cc63
--- /dev/null
+++ b/www/p5-WWW-Mechanize/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: www/p5-WWW-Mechanize
+# Date created: 02 April 2003
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Mechanize
+PORTVERSION= 0.39
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= This module is to help you automate interaction with a website
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Mechanize.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+post-patch:
+ ${PERL} -pi \
+ -e 's/^our\s+([\$$\@]\w+)/use vars qw($$1);$$1/;' \
+ -e 's/^our\s+([\%]\w+)/use vars qw($$1)/;' \
+ -e '$$_="" if /require 5/;' \
+ -e '$$_="" if /use warnings/;' \
+ ${WRKSRC}/lib/WWW/Mechanize.pm
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Mechanize/distinfo b/www/p5-WWW-Mechanize/distinfo
new file mode 100644
index 000000000000..162b8ff18927
--- /dev/null
+++ b/www/p5-WWW-Mechanize/distinfo
@@ -0,0 +1 @@
+MD5 (WWW-Mechanize-0.39.tar.gz) = 5fd8530ab187b1d37d385b7c8ba02c45
diff --git a/www/p5-WWW-Mechanize/pkg-descr b/www/p5-WWW-Mechanize/pkg-descr
new file mode 100644
index 000000000000..d146d98e91c8
--- /dev/null
+++ b/www/p5-WWW-Mechanize/pkg-descr
@@ -0,0 +1,9 @@
+WWW::Mechanize is a fork of Kirrily Robert's excellent WWW::Automate
+module. W::A works fine except for some memory-eating bugs that the
+author of this module has fixed.
+
+Author: Andy Lester <andy@petdance.com>
+WWW: http://search.cpan.org/search?dist=WWW-Mechanize
+
+-Anton
+<tobez@FreeBSD.org>
diff --git a/www/p5-WWW-Mechanize/pkg-plist b/www/p5-WWW-Mechanize/pkg-plist
new file mode 100644
index 000000000000..11be76fb2da2
--- /dev/null
+++ b/www/p5-WWW-Mechanize/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/i386-freebsd/auto/WWW/Mechanize/.packlist
+%%SITE_PERL%%/WWW/Mechanize.pm
+@unexec rmdir %D/%%SITE_PERL%%/i386-freebsd/auto/WWW/Mechanize 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/i386-freebsd/auto/WWW 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WWW 2>/dev/null || true