aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-10-16 10:25:06 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-10-16 10:25:06 +0000
commitbc378b505083444f32d33a36ec664361635e7622 (patch)
treecd3c83ac6c1a0c387bd1065d3b497717a4437f19 /www
parentb1909aa96cf3ac82fc5eb3f15561450910dbf0fe (diff)
downloadports-bc378b505083444f32d33a36ec664361635e7622.tar.gz
ports-bc378b505083444f32d33a36ec664361635e7622.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/opera/Makefile1
-rw-r--r--www/opera/files/operapluginwrapper20
2 files changed, 17 insertions, 4 deletions
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 09a97bb20aad..295ef4a95d21 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.opera.com/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/en/${OPERA_ARCH}/${OPERA_LIB}/ \
ftp://opera.inode.at/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/en/${OPERA_ARCH}/${OPERA_LIB}/ \
diff --git a/www/opera/files/operapluginwrapper b/www/opera/files/operapluginwrapper
index 20fc5d1c16ea..bb5e450c2220 100644
--- a/www/opera/files/operapluginwrapper
+++ b/www/opera/files/operapluginwrapper
@@ -1,7 +1,19 @@
#!/bin/sh
-if [ brandelf $3 | grep "FreeBSD" ]; then
- exec $0.freebsd $@
-else
- exec $0.linux $@
+if [ -n "$4" ]; then
+ELFTYPE=`brandelf $4`
+elif [ -n "$3" ]; then
+ELFTYPE=`brandelf $3`
fi
+
+WRAPPER="freebsd"
+case "${ELFTYPE}" in
+*SVR4*|*Linux*)
+if [ -x "$0.linux" ]; then
+WRAPPER="linux"
+fi
+;;
+esac
+
+exec $0.$WRAPPER $@
+