aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-10-30 01:29:17 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-10-30 01:29:17 +0000
commitc1b47ce9b78bcfb3e08799f1144b28dfc009b52e (patch)
tree99b6e8708fb694554e079cb42bb9a02e54ff92a6 /www
parentbc17a3ecc12469d0f2a9653623c91b369ca9c26c (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Response-Encoding/Makefile30
-rw-r--r--www/p5-HTTP-Response-Encoding/distinfo3
-rw-r--r--www/p5-HTTP-Response-Encoding/pkg-descr3
-rw-r--r--www/p5-HTTP-Response-Encoding/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f5d541747aeb..bbd15c3f7c4a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -789,6 +789,7 @@
SUBDIR += p5-HTTP-Recorder
SUBDIR += p5-HTTP-Request-AsCGI
SUBDIR += p5-HTTP-Request-Params
+ SUBDIR += p5-HTTP-Response-Encoding
SUBDIR += p5-HTTP-Server-Simple
SUBDIR += p5-HTTP-Server-Simple-Mason
SUBDIR += p5-HTTP-Server-Simple-Recorder
diff --git a/www/p5-HTTP-Response-Encoding/Makefile b/www/p5-HTTP-Response-Encoding/Makefile
new file mode 100644
index 000000000000..6af56102871d
--- /dev/null
+++ b/www/p5-HTTP-Response-Encoding/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-HTTP-Response-Encoding
+# Date created: 2007-10-27
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Response-Encoding
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Adds encoding() to HTTP::Response
+
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Response.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Response::Encoding.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500805
+IGNORE= requires Perl 5.8.5 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Response-Encoding/distinfo b/www/p5-HTTP-Response-Encoding/distinfo
new file mode 100644
index 000000000000..8d636108b232
--- /dev/null
+++ b/www/p5-HTTP-Response-Encoding/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Response-Encoding-0.05.tar.gz) = bb5880687bfb8b1e220c5c3c2b7d1408
+SHA256 (HTTP-Response-Encoding-0.05.tar.gz) = 26d4e978d3a5b78b4b09ef59694863eeae3c85aaacc77fec6442833786a1ed11
+SIZE (HTTP-Response-Encoding-0.05.tar.gz) = 5199
diff --git a/www/p5-HTTP-Response-Encoding/pkg-descr b/www/p5-HTTP-Response-Encoding/pkg-descr
new file mode 100644
index 000000000000..cbc45258b7f4
--- /dev/null
+++ b/www/p5-HTTP-Response-Encoding/pkg-descr
@@ -0,0 +1,3 @@
+This module adds the following methods to HTTP::Response objects.
+
+WWW: http://search.cpan.org/dist/HTTP-Response-Encoding/
diff --git a/www/p5-HTTP-Response-Encoding/pkg-plist b/www/p5-HTTP-Response-Encoding/pkg-plist
new file mode 100644
index 000000000000..cb16a4380936
--- /dev/null
+++ b/www/p5-HTTP-Response-Encoding/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Response/Encoding/.packlist
+%%SITE_PERL%%/HTTP/Response/Encoding.pm
+@dirrmtry %%SITE_PERL%%/HTTP/Response
+@dirrmtry %%SITE_PERL%%/HTTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Response/Encoding
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Response
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP