aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-01-22 00:59:20 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-01-22 00:59:20 +0000
commitc8e83b865181e27c3ccf103049f3668bd253f4e3 (patch)
treee149e00d6401e62dd0fe7d9746ce20480e3ae327 /www
parent8e5f454ba99da876270ac268d97bab3c48f5109e (diff)
downloadports-c8e83b865181e27c3ccf103049f3668bd253f4e3.tar.gz
ports-c8e83b865181e27c3ccf103049f3668bd253f4e3.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Session/Makefile42
-rw-r--r--www/p5-HTTP-Session/distinfo3
-rw-r--r--www/p5-HTTP-Session/pkg-descr5
-rw-r--r--www/p5-HTTP-Session/pkg-plist25
5 files changed, 76 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d2fa43711d0f..1debae487ddd 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -927,6 +927,7 @@
SUBDIR += p5-HTTP-Server-Simple-Mason
SUBDIR += p5-HTTP-Server-Simple-Recorder
SUBDIR += p5-HTTP-Server-Simple-Static
+ SUBDIR += p5-HTTP-Session
SUBDIR += p5-HTTP-SimpleLinkChecker
SUBDIR += p5-HTTP-Size
SUBDIR += p5-HTTP-WebTest
diff --git a/www/p5-HTTP-Session/Makefile b/www/p5-HTTP-Session/Makefile
new file mode 100644
index 000000000000..c3d418abb126
--- /dev/null
+++ b/www/p5-HTTP-Session/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: HTTP::Session
+# Date created: 22 Jan 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Session
+PORTVERSION= 0.28
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of yet another session manager
+
+RUN_DEPENDS= \
+ p5-Class-Accessor>=0.31:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-CGI-Simple>=1.103:${PORTSDIR}/www/p5-CGI-Simple \
+ p5-Digest-SHA1>=2.11:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-libwww>=5.818:${PORTSDIR}/www/p5-libwww \
+ p5-UNIVERSAL-require>=0.05:${PORTSDIR}/devel/p5-UNIVERSAL-require
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Session.3 \
+ HTTP::Session::State::Cookie.3 \
+ HTTP::Session::State::GUID.3 \
+ HTTP::Session::State::MobileAgentID.3 \
+ HTTP::Session::State::MobileAttributeID.3 \
+ HTTP::Session::State::Null.3 \
+ HTTP::Session::State::Test.3 \
+ HTTP::Session::State::URI.3 \
+ HTTP::Session::Store::CHI.3 \
+ HTTP::Session::Store::DBM.3 \
+ HTTP::Session::Store::File.3 \
+ HTTP::Session::Store::Memcached.3 \
+ HTTP::Session::Store::Null.3 \
+ HTTP::Session::Store::OnMemory.3 \
+ HTTP::Session::Store::Test.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Session/distinfo b/www/p5-HTTP-Session/distinfo
new file mode 100644
index 000000000000..c402ef9b6fe8
--- /dev/null
+++ b/www/p5-HTTP-Session/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Session-0.28.tar.gz) = 3bb512d338a25d705c7646eb4689f242
+SHA256 (HTTP-Session-0.28.tar.gz) = 26acdcf3d9359ed9f55a64d25cf032e89706be120a8d728809980fa990c420d1
+SIZE (HTTP-Session-0.28.tar.gz) = 50992
diff --git a/www/p5-HTTP-Session/pkg-descr b/www/p5-HTTP-Session/pkg-descr
new file mode 100644
index 000000000000..e33175153ad1
--- /dev/null
+++ b/www/p5-HTTP-Session/pkg-descr
@@ -0,0 +1,5 @@
+Yet another session manager.
+
+Easy to integrate with HTTP::Engine.
+
+WWW: http://search.cpan.org/dist/HTTP-Session/
diff --git a/www/p5-HTTP-Session/pkg-plist b/www/p5-HTTP-Session/pkg-plist
new file mode 100644
index 000000000000..9dd2d1c2cc98
--- /dev/null
+++ b/www/p5-HTTP-Session/pkg-plist
@@ -0,0 +1,25 @@
+%%SITE_PERL%%/HTTP/Session/ID/SHA1.pm
+%%SITE_PERL%%/HTTP/Session/ID/MD5.pm
+%%SITE_PERL%%/HTTP/Session/State/Cookie.pm
+%%SITE_PERL%%/HTTP/Session/State/Null.pm
+%%SITE_PERL%%/HTTP/Session/State/Base.pm
+%%SITE_PERL%%/HTTP/Session/State/GUID.pm
+%%SITE_PERL%%/HTTP/Session/State/URI.pm
+%%SITE_PERL%%/HTTP/Session/State/Test.pm
+%%SITE_PERL%%/HTTP/Session/State/MobileAttributeID.pm
+%%SITE_PERL%%/HTTP/Session/State/MobileAgentID.pm
+%%SITE_PERL%%/HTTP/Session/Store/DBM.pm
+%%SITE_PERL%%/HTTP/Session/Store/Test.pm
+%%SITE_PERL%%/HTTP/Session/Store/CHI.pm
+%%SITE_PERL%%/HTTP/Session/Store/OnMemory.pm
+%%SITE_PERL%%/HTTP/Session/Store/File.pm
+%%SITE_PERL%%/HTTP/Session/Store/Null.pm
+%%SITE_PERL%%/HTTP/Session/Store/Memcached.pm
+%%SITE_PERL%%/HTTP/Session.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Session/.packlist
+@dirrm %%SITE_PERL%%/HTTP/Session/Store
+@dirrm %%SITE_PERL%%/HTTP/Session/State
+@dirrm %%SITE_PERL%%/HTTP/Session/ID
+@dirrm %%SITE_PERL%%/HTTP/Session
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Session
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP