aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-10-04 13:30:54 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-10-04 13:30:54 +0000
commitca31c422448a03a32afb01bd014b865db585c609 (patch)
treeecb6f8eb9d3c24754ffb6b8b2eb2eeccbd129a18 /www
parenta1bb849ee3bb8a5ed1a042fc6f04127b2cd111a0 (diff)
downloadports-ca31c422448a03a32afb01bd014b865db585c609.tar.gz
ports-ca31c422448a03a32afb01bd014b865db585c609.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/myfaces/Makefile44
-rw-r--r--www/myfaces/distinfo2
-rw-r--r--www/myfaces/pkg-descr8
4 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb8200a82dc8..a8ad654293d9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -375,6 +375,7 @@
SUBDIR += mozilla-devel
SUBDIR += mozplugger
SUBDIR += mplayer-plugin
+ SUBDIR += myfaces
SUBDIR += myghty
SUBDIR += nanoblogger
SUBDIR += nd
diff --git a/www/myfaces/Makefile b/www/myfaces/Makefile
new file mode 100644
index 000000000000..48f0f5d4a00a
--- /dev/null
+++ b/www/myfaces/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Apache MyFaces
+# Date created: October 04, 2005
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= myfaces
+PORTVERSION= 1.1.0
+CATEGORIES= www devel java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= ${PORTNAME}/binaries
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Free open source JavaServer(tm) Faces implementation
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+.if !defined(NOPORTDOCS)
+PORTDOCS= javadoc tlddoc LICENSE.txt NOTICE.txt
+.endif
+JAR_FILES= myfaces-all.jar myfaces-api.jar myfaces-impl.jar tomahawk.jar
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
+ ${JAR_FILES:S|^|%%DATADIR%%/|}
+PLIST_DIRS= %%DATADIR%%
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/myfaces-all.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${MKDIR} ${DATADIR}
+.for jarfile in ${JAR_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${jarfile} ${DATADIR}/${jarfile}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ cd ${WRKSRC} && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/myfaces/distinfo b/www/myfaces/distinfo
new file mode 100644
index 000000000000..e3d482b05155
--- /dev/null
+++ b/www/myfaces/distinfo
@@ -0,0 +1,2 @@
+MD5 (myfaces-1.1.0.tar.gz) = 0688e987418de9ee40895697b824f721
+SIZE (myfaces-1.1.0.tar.gz) = 4012930
diff --git a/www/myfaces/pkg-descr b/www/myfaces/pkg-descr
new file mode 100644
index 000000000000..b95bba872da4
--- /dev/null
+++ b/www/myfaces/pkg-descr
@@ -0,0 +1,8 @@
+The first free open source JavaServer(tm) Faces implementation.
+
+JavaServer(tm) Faces is a new and upcoming web application framework that
+accomplishes the MVC paradigm. It is comparable to the well-known Struts
+Framework but has features and concepts that are beyond those of Struts;
+especially the component orientation.
+
+WWW: http://myfaces.apache.org/