aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-27 02:20:45 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-27 02:20:45 +0000
commitca9f43a18e9c37b09129166efe4449951794b8ea (patch)
treeef27de0dca3fe7f53ff1478762346f48dbcc3ddc /www
parentd80c18dc775af0890423823152cecea1f2874f4f (diff)
downloadports-ca9f43a18e9c37b09129166efe4449951794b8ea.tar.gz
ports-ca9f43a18e9c37b09129166efe4449951794b8ea.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-DBI/Makefile29
-rw-r--r--www/p5-Apache-DBI/distinfo1
-rw-r--r--www/p5-Apache-DBI/pkg-comment1
-rw-r--r--www/p5-Apache-DBI/pkg-descr20
-rw-r--r--www/p5-Apache-DBI/pkg-plist5
6 files changed, 57 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6f03858b2378..ccf1f50fc690 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -80,6 +80,7 @@
SUBDIR += netscape47-navigator.us
SUBDIR += npc
SUBDIR += p5-Apache
+ SUBDIR += p5-Apache-DBI
SUBDIR += p5-Apache-Radius
SUBDIR += p5-CGI
SUBDIR += p5-CGI_Lite
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
new file mode 100644
index 000000000000..8c78e2eea252
--- /dev/null
+++ b/www/p5-Apache-DBI/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Apache-DBI
+# Version required: 0.87
+# Date created: 21 December 1999
+# Whom: Igor Vinokurov <igor@zynaps.ru>
+#
+# $FreeBSD$
+#
+
+DISTNAME= ApacheDBI-0.87
+PKGNAME= p5-Apache-DBI-0.87
+CATEGORIES= www databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+
+MAINTAINER= igor@zynaps.ru
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+
+USE_PERL5= YES
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Apache::DBI.3 \
+ Apache::AuthDBI.3
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-DBI/distinfo b/www/p5-Apache-DBI/distinfo
new file mode 100644
index 000000000000..341751314954
--- /dev/null
+++ b/www/p5-Apache-DBI/distinfo
@@ -0,0 +1 @@
+MD5 (ApacheDBI-0.87.tar.gz) = 6ee243d7a0d738e61837b9760f50e1a8
diff --git a/www/p5-Apache-DBI/pkg-comment b/www/p5-Apache-DBI/pkg-comment
new file mode 100644
index 000000000000..ffb230083113
--- /dev/null
+++ b/www/p5-Apache-DBI/pkg-comment
@@ -0,0 +1 @@
+DBI persistent connection, authentication and authorization
diff --git a/www/p5-Apache-DBI/pkg-descr b/www/p5-Apache-DBI/pkg-descr
new file mode 100644
index 000000000000..b3a7746db609
--- /dev/null
+++ b/www/p5-Apache-DBI/pkg-descr
@@ -0,0 +1,20 @@
+From the README file:
+
+These modules are supposed to be used with the Apache server together with
+an embedded perl interpreter like mod_perl. They provide support for basic
+authentication and authorization as well as support for persistent database
+connections via Perl's Database Independent Interface (DBI).
+
+o AuthDBI.pm provides authentication and authorization:
+
+ - optional shared cache for passwords to minimize database load
+ - configurable cleanup-handler deletes outdated entries from the cache
+
+o DBI.pm provides persistent database connections:
+
+ - connections can be established during server-startup
+ - configurable rollback to ensure data integrity
+ - configurable verification of the connections to avoid time-outs.
+
+-- Igor
+igor@zynaps.ru
diff --git a/www/p5-Apache-DBI/pkg-plist b/www/p5-Apache-DBI/pkg-plist
new file mode 100644
index 000000000000..93e1e10a8d01
--- /dev/null
+++ b/www/p5-Apache-DBI/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Apache/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/AuthDBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Apache
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/DBI