aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-01-25 15:14:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-01-25 15:14:12 +0000
commit2c4faf13b2ac6e80e3744a9d5871a594d7328ebb (patch)
treef41afb3d31d9d3eafe3ebd26e760e9ab47f0d1c3 /www
parent9a885c614bacb1567aba6144e29667d045d6dcf6 (diff)
downloadports-2c4faf13b2ac6e80e3744a9d5871a594d7328ebb.tar.gz
ports-2c4faf13b2ac6e80e3744a9d5871a594d7328ebb.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WebService-YouTube/Makefile41
-rw-r--r--www/p5-WebService-YouTube/distinfo3
-rw-r--r--www/p5-WebService-YouTube/pkg-descr6
-rw-r--r--www/p5-WebService-YouTube/pkg-plist8
5 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 00b0c777b6f7..36032510ce37 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -858,6 +858,7 @@
SUBDIR += p5-WebService-ISBNDB
SUBDIR += p5-WebService-NoPaste
SUBDIR += p5-WebService-Technorati
+ SUBDIR += p5-WebService-YouTube
SUBDIR += p5-Xango
SUBDIR += p5-libapreq
SUBDIR += p5-libapreq-static
diff --git a/www/p5-WebService-YouTube/Makefile b/www/p5-WebService-YouTube/Makefile
new file mode 100644
index 000000000000..da254f755583
--- /dev/null
+++ b/www/p5-WebService-YouTube/Makefile
@@ -0,0 +1,41 @@
+# ex:ts=8
+# Ports collection makefile for: WebService::YouTube
+# Date created: Jan 25, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-YouTube
+PORTVERSION= 1.0.0
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl interfece to YouTube
+
+RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-version>0:${PORTSDIR}/devel/p5-version
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= WebService::YouTube.3 \
+ WebService::YouTube::Feeds.3 \
+ WebService::YouTube::User.3 \
+ WebService::YouTube::Util.3 \
+ WebService::YouTube::Video.3 \
+ WebService::YouTube::Videos.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BROKEN= Does not compile with perl ${PERL_VERSION}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WebService-YouTube/distinfo b/www/p5-WebService-YouTube/distinfo
new file mode 100644
index 000000000000..2f1650a5e137
--- /dev/null
+++ b/www/p5-WebService-YouTube/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebService-YouTube-v1.0.0.tar.gz) = 516c82034ab8e743c2b415043c0357bd
+SHA256 (WebService-YouTube-v1.0.0.tar.gz) = b52998bce6a90497e13e759ae266235439e45766d256510711cec17b487bc57c
+SIZE (WebService-YouTube-v1.0.0.tar.gz) = 46944
diff --git a/www/p5-WebService-YouTube/pkg-descr b/www/p5-WebService-YouTube/pkg-descr
new file mode 100644
index 000000000000..c7fb7eac5964
--- /dev/null
+++ b/www/p5-WebService-YouTube/pkg-descr
@@ -0,0 +1,6 @@
+This is a Perl interface to YouTube API and RSS. See
+Developers Page http://www.youtube.com/dev and
+About RSS http://www.youtube.com/rssls
+for details.
+
+WWW: http://search.cpan.org/dist/WebService-YouTube/
diff --git a/www/p5-WebService-YouTube/pkg-plist b/www/p5-WebService-YouTube/pkg-plist
new file mode 100644
index 000000000000..ab05e79584c2
--- /dev/null
+++ b/www/p5-WebService-YouTube/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/WebService/YouTube.pm
+%%SITE_PERL%%/WebService/YouTube/Feeds.pm
+%%SITE_PERL%%/WebService/YouTube/User.pm
+%%SITE_PERL%%/WebService/YouTube/Util.pm
+%%SITE_PERL%%/WebService/YouTube/Video.pm
+%%SITE_PERL%%/WebService/YouTube/Videos.pm
+@dirrm %%SITE_PERL%%/WebService/YouTube
+@dirrmtry %%SITE_PERL%%/WebService