aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2001-06-23 13:02:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2001-06-23 13:02:26 +0000
commit149769a68349f5d39e055ff5eaf6875564e023fa (patch)
treeebcbc2278929afac23d383a67ad58441d1de680d /www
parentd79db80401254414e4dd22e989315455092ee437 (diff)
downloadports-149769a68349f5d39e055ff5eaf6875564e023fa.tar.gz
ports-149769a68349f5d39e055ff5eaf6875564e023fa.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/webalizer/Makefile3
-rw-r--r--www/webalizer/files/patch-linklist42
2 files changed, 44 insertions, 1 deletions
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index ea8ad1c60e43..c1f8238a8f5f 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webalizer
PORTVERSION= 2.1.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= www
MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/ \
ftp://ftp.dinoex.de/pub/FreeBSD/distfiles/
@@ -34,6 +34,7 @@ CONFIGURE_ARGS+= --enable-dns \
--with-gdlib=${PREFIX}/lib \
--with-gd=${PREFIX}/include/gd
CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib"
+CFLAGS+= -DLINKLIST_MAX_STRING=256
MAKE_ARGS+= CFLAGS="${CFLAGS}"
MAN1= ${PKGNAMEPREFIX}webalizer.1
DOC1= CHANGES COPYING Copyright INSTALL \
diff --git a/www/webalizer/files/patch-linklist b/www/webalizer/files/patch-linklist
new file mode 100644
index 000000000000..7320ad7233a5
--- /dev/null
+++ b/www/webalizer/files/patch-linklist
@@ -0,0 +1,42 @@
+--- linklist.c.orig Sat Jun 23 11:12:40 2001
++++ linklist.c Sat Jun 23 11:19:54 2001
+@@ -190,12 +190,12 @@
+ int add_glist(char *str, GLISTPTR *list)
+ {
+ GLISTPTR newptr,cptr,pptr;
+- char temp_buf[80];
++ char temp_buf[LINKLIST_MAX_STRING];
+ char *name=temp_buf;
+
+ /* make local copy of string */
+- strncpy(temp_buf,str,79);
+- temp_buf[79]=0;
++ strncpy(temp_buf,str,LINKLIST_MAX_STRING - 1);
++ temp_buf[LINKLIST_MAX_STRING - 1]=0;
+
+ while (!isspace((unsigned char)*name)&&*name!=0) name++;
+ if (*name==0) name=temp_buf;
+--- linklist.h.orig Fri Sep 29 05:50:30 2000
++++ linklist.h Sat Jun 23 11:15:57 2001
+@@ -1,12 +1,18 @@
+ #ifndef _LINKLIST_H
+ #define _LINKLIST_H
+
+-struct nlist { char string[80]; /* list struct for HIDE items */
++#ifndef LINKLIST_MAX_STRING
++#define LINKLIST_MAX_STRING 80
++#endif
++
++struct nlist { /* list struct for HIDE items */
++ char string[LINKLIST_MAX_STRING];
+ struct nlist *next; };
+ typedef struct nlist *NLISTPTR;
+
+-struct glist { char string[80]; /* list struct for GROUP items */
+- char name[80];
++struct glist { /* list struct for GROUP items */
++ char string[LINKLIST_MAX_STRING];
++ char name[LINKLIST_MAX_STRING];
+ struct glist *next; };
+ typedef struct glist *GLISTPTR;
+