aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-07-17 15:15:32 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-07-17 15:15:32 +0000
commit3be31e5a84ac6409efe88fc3f41b17158aacc7c5 (patch)
tree1d594355b7403054b343339a245d375929fd4ffb /www
parenta54356cb1a0712f42c9c79ddae9ef2bdd2071646 (diff)
downloadports-3be31e5a84ac6409efe88fc3f41b17158aacc7c5.tar.gz
ports-3be31e5a84ac6409efe88fc3f41b17158aacc7c5.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/w3m/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index b3fe29205cad..30504a686c30 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -23,9 +23,6 @@ CONFLICTS?= ja-w3m-0.5.* ja-w3m-img-0.5.* w3m-m17n-0.5.* w3m-img-0.5.* w3m-m17n-
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS}"
-
MAN1= w3m.1 w3mman.1
MANLANG= "" ja
@@ -82,6 +79,16 @@ PKGMESSAGE= ${NONEXISTENT}
CONFIGURE_ARGS+= --enable-keymap=lynx
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500016
+CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="${LIBS} ${PTHREAD_LIBS} -lc_r"
+.else
+CONFIGURE_ENV= DEFS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="${LIBS} ${PTHREAD_LIBS} -lc"
+.endif
+
pre-everything::
@${ECHO_MSG} "===>"
@${ECHO_MSG} "===> You can enable some features by defining following variables."
@@ -144,4 +151,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>