aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-19 07:23:57 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-19 07:23:57 +0000
commit73c739cceffa9ecdebec6669cd02b76b44abf43e (patch)
tree61d9356c6559c7bb9a1c0768b16c8a40c61aecf4 /www
parenta65a3cb84b73a218fd001117cbbc0e657651c1da (diff)
downloadports-73c739cceffa9ecdebec6669cd02b76b44abf43e.tar.gz
ports-73c739cceffa9ecdebec6669cd02b76b44abf43e.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Size/Makefile33
-rw-r--r--www/p5-HTTP-Size/distinfo3
-rw-r--r--www/p5-HTTP-Size/pkg-descr4
-rw-r--r--www/p5-HTTP-Size/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 805d525b0bec..4fb697c10486 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -639,6 +639,7 @@
SUBDIR += p5-HTTP-Server-Simple-Recorder
SUBDIR += p5-HTTP-Server-Simple-Static
SUBDIR += p5-HTTP-SimpleLinkChecker
+ SUBDIR += p5-HTTP-Size
SUBDIR += p5-HTTP-WebTest
SUBDIR += p5-HTTPD-Log-Filter
SUBDIR += p5-HTTPD-User-Manage
diff --git a/www/p5-HTTP-Size/Makefile b/www/p5-HTTP-Size/Makefile
new file mode 100644
index 000000000000..d372ab33b79b
--- /dev/null
+++ b/www/p5-HTTP-Size/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-HTTP-Size
+# Date created: 19 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Size
+PORTVERSION= 1.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Get the byte size of an internet resource
+
+BUILD_DEPENDS= p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-HTML-SimpleLinkExtor>0:${PORTSDIR}/www/p5-HTML-SimpleLinkExtor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= HTTP::Size.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from p5-libwww
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Size/distinfo b/www/p5-HTTP-Size/distinfo
new file mode 100644
index 000000000000..140a7f5aaa08
--- /dev/null
+++ b/www/p5-HTTP-Size/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Size-1.11.tar.gz) = 3b5e368c0f9b08285ad92cc86e60b50d
+SHA256 (HTTP-Size-1.11.tar.gz) = 6d3faabc2f682b50a11ab2db6150e105e41d8b3471075d397ae05cb8b7111caf
+SIZE (HTTP-Size-1.11.tar.gz) = 25680
diff --git a/www/p5-HTTP-Size/pkg-descr b/www/p5-HTTP-Size/pkg-descr
new file mode 100644
index 000000000000..ea8640777efa
--- /dev/null
+++ b/www/p5-HTTP-Size/pkg-descr
@@ -0,0 +1,4 @@
+Gets the byte size of an internet resource.
+
+WWW: http://search.cpan.org/dist/HTTP-Size
+Author: brian d foy <bdfoy@cpan.org>
diff --git a/www/p5-HTTP-Size/pkg-plist b/www/p5-HTTP-Size/pkg-plist
new file mode 100644
index 000000000000..f26e0de22481
--- /dev/null
+++ b/www/p5-HTTP-Size/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTTP/Size.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Size/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Size
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP
+@dirrmtry %%SITE_PERL%%/HTTP