aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
commit67971bd0fb8a440f973d12606b0f496ba216d7df (patch)
tree72fd93ae39b43490b34dc8479465e07b453d126e /www
parentf13c234d6c664c916b5c0d0e6f089d8ef0c93d55 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/calendarserver/Makefile1
-rw-r--r--www/joomla25/Makefile11
-rw-r--r--www/joomla31/Makefile13
-rw-r--r--www/libhpack/Makefile1
-rw-r--r--www/py-GinGin/Makefile2
-rw-r--r--www/py-djblets/Makefile1
-rw-r--r--www/varnish4/Makefile1
7 files changed, 10 insertions, 20 deletions
diff --git a/www/calendarserver/Makefile b/www/calendarserver/Makefile
index 24c0c0604eff..2607e5d606dd 100644
--- a/www/calendarserver/Makefile
+++ b/www/calendarserver/Makefile
@@ -41,7 +41,6 @@ USE_PYTHON= autoplist distutils
SUB_FILES= pkg-message
SUB_LIST+= USER=${USERS}
-python_OLD_CMD= /usr/bin/env python
SHEBANG_FILES= bin/calendarserver_* \
bin/icalendar_split \
diff --git a/www/joomla25/Makefile b/www/joomla25/Makefile
index 4585b1867613..dd8c189507c2 100644
--- a/www/joomla25/Makefile
+++ b/www/joomla25/Makefile
@@ -16,10 +16,10 @@ GH_PROJECT= ${PORTNAME}-cms
NO_BUILD= yes
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-php_OLD_CMD= C:\\\xampp\\\php\\\.\\\php.exe
-REINPLACE_ARGS= -i '' -e 's,${php_OLD_CMD},${LOCALBASE}/bin/php,g'
-REINPLACE_FILES= tests/unit/phpunit.php tests/system/phpunit.php
+USES= shebangfix
+php_OLD_CMD= C:\\\xampp\\\php\\\.\\\php.exe
+SHEBANG_FILES= tests/unit/phpunit.php tests/system/phpunit.php
SUB_FILES= pkg-message
@@ -28,10 +28,7 @@ USE_MYSQL= yes
USE_PHP= gd json mbstring mysql mysqli pcre pdf session simplexml xml zip zlib
WANT_PHP_WEB= yes
-WWWDIR= ${PREFIX}/www/${PORTNAME}${PORTVERSION:R:R}
-
-pre-patch:
- @(cd ${WRKSRC} && ${REINPLACE_CMD} ${REINPLACE_FILES})
+WWWDIR= ${PREFIX}/www/${PORTNAME}${PORTVERSION:R:R}
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
diff --git a/www/joomla31/Makefile b/www/joomla31/Makefile
index c42c25432d3c..179fe7c74e17 100644
--- a/www/joomla31/Makefile
+++ b/www/joomla31/Makefile
@@ -16,11 +16,11 @@ GH_PROJECT= ${PORTNAME}-cms
NO_BUILD= yes
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-php_OLD_CMD= C:\\\xampp\\\php\\\.\\\php.exe
-REINPLACE_ARGS= -i '' -E -e 's,(${php_OLD_CMD})|(/usr/bin/php),${LOCALBASE}/bin/php,g'
-REINPLACE_FILES= build/indexmaker.php tests/system/phpunit.php \
- tests/system/webdriver/tests/phpunit.php
+USES= shebangfix
+php_OLD_CMD= C:\\\xampp\\\php\\\.\\\php.exe
+SHEBANG_FILES= build/indexmaker.php tests/system/phpunit.php \
+ tests/system/webdriver/tests/phpunit.php
SUB_FILES= pkg-message
@@ -29,10 +29,7 @@ USE_MYSQL= yes
USE_PHP= gd json mbstring mysql mysqli pcre pdf session simplexml xml zip zlib
WANT_PHP_WEB= yes
-WWWDIR= ${PREFIX}/www/${PORTNAME}${PORTVERSION:R:R}
-
-pre-patch:
- @(cd ${WRKSRC} && ${REINPLACE_CMD} ${REINPLACE_FILES})
+WWWDIR= ${PREFIX}/www/${PORTNAME}${PORTVERSION:R:R}
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
diff --git a/www/libhpack/Makefile b/www/libhpack/Makefile
index f55378bc6775..345ed409d6b9 100644
--- a/www/libhpack/Makefile
+++ b/www/libhpack/Makefile
@@ -21,7 +21,6 @@ USE_LDCONFIG= yes
USES= cmake pkgconfig python:2,build shebangfix tar:xz
SHEBANG_FILES= gen-config.py libhpack/huffman-gen.py
-python_OLD_CMD= /usr/bin/env python
post-patch:
@${REINPLACE_CMD} -e 's|STATIC|SHARED|' ${WRKSRC}/libchula/CMakeLists.txt ${WRKSRC}/libhpack/CMakeLists.txt
diff --git a/www/py-GinGin/Makefile b/www/py-GinGin/Makefile
index 07ef5df716eb..42d7d53350cf 100644
--- a/www/py-GinGin/Makefile
+++ b/www/py-GinGin/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
USES= python:2 shebangfix
SHEBANG_FILES= GinGin/data/config.py.example
-python_OLD_CMD= env python
+python_OLD_CMD= "env python"
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/www/py-djblets/Makefile b/www/py-djblets/Makefile
index c6c5c49eab37..77dedf82b9d3 100644
--- a/www/py-djblets/Makefile
+++ b/www/py-djblets/Makefile
@@ -25,7 +25,6 @@ USES= python:2 shebangfix
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= Djblets
-python_OLD_CMD= /usr/bin/env python
SHEBANG_FILES= contrib/internal/build-media.py
.include <bsd.port.mk>
diff --git a/www/varnish4/Makefile b/www/varnish4/Makefile
index 2b5ed4289ee2..a6a412291d4b 100644
--- a/www/varnish4/Makefile
+++ b/www/varnish4/Makefile
@@ -19,7 +19,6 @@ CONFLICTS= varnish-2.* varnish-3.*
USES= autoreconf cpe gmake libtool pkgconfig python:2,build readline shebangfix
SHEBANG_FILES= lib/libvcc/vmodtool.py
-python_OLD_CMD= /usr/bin/env python
CPE_VENDOR= varnish-cache
CFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes