aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-12-06 12:17:51 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-12-06 12:17:51 +0000
commit6aad64b3fe721492b00a66b906df2e649c70a6de (patch)
tree1609876f81c2ad143c0849f3c1e97cf1a4f8fac9 /www
parent869e179c9861f338ad0934efbc3c94958aea14df (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/httpd/Makefile41
-rw-r--r--www/httpd/distinfo2
-rw-r--r--www/httpd/files/obhttpd.in25
-rw-r--r--www/httpd/pkg-descr3
5 files changed, 72 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b3edd479098b..b00c829b7ed2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -334,6 +334,7 @@
SUBDIR += httpasyncclient
SUBDIR += httpclient
SUBDIR += httpcore
+ SUBDIR += httpd
SUBDIR += httpie
SUBDIR += httpsqs
SUBDIR += httptunnel
diff --git a/www/httpd/Makefile b/www/httpd/Makefile
new file mode 100644
index 000000000000..27e42e5ff907
--- /dev/null
+++ b/www/httpd/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= httpd
+PORTVERSION= 5.7.20150508
+CATEGORIES= www
+
+MAINTAINER= koue@chaosophia.net
+COMMENT= OpenBSD http server
+
+LICENSE= BSD3CLAUSE
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/usr.sbin/${PORTNAME}
+
+USE_GITHUB= yes
+GH_ACCOUNT= koue
+
+USE_OPENSSL= yes
+USE_RC_SUBR= obhttpd
+
+WITH_OPENSSL_PORT=yes
+OPENSSL_PORT= security/libressl
+
+CFLAGS+= -Wall
+
+MAKE_ARGS+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
+
+USERS= www
+GROUPS= www
+
+PLIST_FILES= sbin/obhttpd \
+ man/man5/httpd.conf.5.gz \
+ man/man8/obhttpd.8.gz
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|httpd$$|obhttpd|g" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|httpd.8|obhttpd.8|g' ${WRKSRC}/Makefile
+ ${MV} ${WRKSRC}/httpd.8 ${WRKSRC}/obhttpd.8
+ ${REINPLACE_CMD} -e 's|/etc/httpd.conf|${PREFIX}/etc/obhttpd.conf|g' \
+ ${WRKSRC}/httpd.h
+
+.include <bsd.port.mk>
diff --git a/www/httpd/distinfo b/www/httpd/distinfo
new file mode 100644
index 000000000000..79e99b151a39
--- /dev/null
+++ b/www/httpd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (koue-httpd-5.7.20150508_GH0.tar.gz) = 559aa2092a03f63735dfd36e5e930173e4486d14ec2d4ab74f6c014a791b78a8
+SIZE (koue-httpd-5.7.20150508_GH0.tar.gz) = 125247
diff --git a/www/httpd/files/obhttpd.in b/www/httpd/files/obhttpd.in
new file mode 100644
index 000000000000..9cff29f15ed9
--- /dev/null
+++ b/www/httpd/files/obhttpd.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: obhttpd
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
+# KEYWORD: shutdown
+
+# Add the following lines to /etc/rc.conf to enable obhttpd:
+# obhttpd_enable="YES"
+# obhttpd_flags="<set as needed>"
+
+. /etc/rc.subr
+
+name=obhttpd
+rcvar=obhttpd_enable
+
+command="%%PREFIX%%/sbin/obhttpd"
+
+obhttpd_enable=${obhttpd_enable:-"NO"}
+obhttpd_flags=${obhttpd_flags:-"-f %%PREFIX%%/etc/obhttpd.conf"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/www/httpd/pkg-descr b/www/httpd/pkg-descr
new file mode 100644
index 000000000000..ea3c00d2710a
--- /dev/null
+++ b/www/httpd/pkg-descr
@@ -0,0 +1,3 @@
+This is the FreeBSD port of the OpenBSD http server.
+
+WWW: https://github.com/koue/httpd