aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-06-05 06:21:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-06-05 06:21:31 +0000
commit987d7f8fbc393931a606f6ab427fb91a82382b1c (patch)
tree5921073680fd32670d9682ae387a26215107586a /www
parent2230b5736338f5b847972e3f886b8dae064dd423 (diff)
downloadports-987d7f8fbc393931a606f6ab427fb91a82382b1c.tar.gz
ports-987d7f8fbc393931a606f6ab427fb91a82382b1c.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Encoding/Makefile28
-rw-r--r--www/p5-HTML-Encoding/distinfo3
-rw-r--r--www/p5-HTML-Encoding/pkg-descr3
-rw-r--r--www/p5-HTML-Encoding/pkg-plist5
5 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7cf346a01788..2005233afee0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -581,6 +581,7 @@
SUBDIR += p5-HTML-Diff
SUBDIR += p5-HTML-Element-Extended
SUBDIR += p5-HTML-Embperl
+ SUBDIR += p5-HTML-Encoding
SUBDIR += p5-HTML-FillInForm
SUBDIR += p5-HTML-FromText
SUBDIR += p5-HTML-LinkExtractor
diff --git a/www/p5-HTML-Encoding/Makefile b/www/p5-HTML-Encoding/Makefile
new file mode 100644
index 000000000000..194c8c4d56ab
--- /dev/null
+++ b/www/p5-HTML-Encoding/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: HTML::Encoding
+# Date created: Jun 5, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Encoding
+PORTVERSION= 0.52
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Determine the encoding of HTML/XML/XHTML documents
+
+BUILD_DEPENDS= p5-Encode>=0:${PORTSDIR}/converters/p5-Encode \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Encoding.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Encoding/distinfo b/www/p5-HTML-Encoding/distinfo
new file mode 100644
index 000000000000..49aab38259ab
--- /dev/null
+++ b/www/p5-HTML-Encoding/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Encoding-0.52.tar.gz) = ee31564305ffdaf24d99f26588f8eb9f
+SHA256 (HTML-Encoding-0.52.tar.gz) = cd0cf7b45f46ea47bc993e62260dabf7d9afba36f2aa1d95cf46f2ed292bb54c
+SIZE (HTML-Encoding-0.52.tar.gz) = 10768
diff --git a/www/p5-HTML-Encoding/pkg-descr b/www/p5-HTML-Encoding/pkg-descr
new file mode 100644
index 000000000000..9ef593c61649
--- /dev/null
+++ b/www/p5-HTML-Encoding/pkg-descr
@@ -0,0 +1,3 @@
+HTML::Encoding helps to determine the encoding of HTML and XML/XHTML documents.
+
+WWW: http://search.cpan.org/dist/HTML-Encoding/
diff --git a/www/p5-HTML-Encoding/pkg-plist b/www/p5-HTML-Encoding/pkg-plist
new file mode 100644
index 000000000000..2a6b666ff720
--- /dev/null
+++ b/www/p5-HTML-Encoding/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTML/Encoding.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Encoding/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Encoding
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML