aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-10 23:09:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-10 23:09:06 +0000
commiteb9ca73379a57d2ab8807f46827d29c2e58bf9cb (patch)
tree4247ba47b082a665162cceefb9b143a54ba37489 /www
parent379c8a06c3a2071f3640288a3bfce55ba7cc4e44 (diff)
downloadports-eb9ca73379a57d2ab8807f46827d29c2e58bf9cb.tar.gz
ports-eb9ca73379a57d2ab8807f46827d29c2e58bf9cb.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mediawiki17/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/www/mediawiki17/Makefile b/www/mediawiki17/Makefile
index c4581fd6665c..83291d4e192a 100644
--- a/www/mediawiki17/Makefile
+++ b/www/mediawiki17/Makefile
@@ -16,18 +16,27 @@ COMMENT= The wiki engine used by Wikipedia
CONFLICTS= mediawiki-1.[0-68-9].*
+NO_LATEST_LINK= yes
+
NO_BUILD= yes
USE_MYSQL= yes
IGNORE_WITH_MYSQL= 323
-USE_PHP= iconv mbstring pcre session xml zlib readline mysql
+USE_PHP= iconv mbstring pcre session xml zlib readline
IGNORE_WITH_PHP= 4
WANT_PHP_WEB= yes
MEDIAWIKIDIR?= www/mediawiki
-OPTIONS= LDAP "Use LDAP authentication" off
+OPTIONS= PGSQL "Use PostgreSQL instead of MySQL (not funtional)" off \
+ LDAP "Use LDAP authentication" off
.include <bsd.port.pre.mk>
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.else
+USE_PHP+= mysql
+.endif
+
.if defined(WITH_LDAP)
USE_PHP+= ldap
.endif