aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-11-26 20:03:02 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-11-26 20:03:02 +0000
commit04efb5ec1b3f659df306466a26bafc285244f7e8 (patch)
tree85ae2bf461f0f462a9874fc45c00c89cc34a8675 /www
parent9c0fcef425003920ccfb4590b1ef110f4f209924 (diff)
downloadports-04efb5ec1b3f659df306466a26bafc285244f7e8.tar.gz
ports-04efb5ec1b3f659df306466a26bafc285244f7e8.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/p5-Apache-Gallery/Makefile27
-rw-r--r--www/p5-Apache-Gallery/pkg-plist6
2 files changed, 24 insertions, 9 deletions
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index 0c955261e9f3..b3753b670025 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -6,12 +6,13 @@
#
PORTNAME= Apache-Gallery
-PORTVERSION= 1.0RC3
-PORTREVISION= 1
+PORTVERSION= 1.0
+PORTEPOCH= 1
CATEGORIES= www perl5
MASTER_SITES= http://apachegallery.dk/download/ \
CPAN
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}${PORTSUBVER}
MAINTAINER= kvs@pil.dk
COMMENT= Apache::Gallery - mod_perl handler to create an image gallery
@@ -37,21 +38,29 @@ BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
PERL_CONFIGURE= yes
APACHE_COMPAT= yes
+PORTSUBVER= RC3
MAN3= Apache::Gallery.3
+DOC_FILES= INSTALL LICENSE README TODO UPGRADE
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/www/icons/gallery/
+ @${MKDIR} ${PREFIX}/www/icons/gallery/
${INSTALL_DATA} ${WRKSRC}/htdocs/* \
- ${PREFIX}/www/icons/gallery
- ${MKDIR} ${DATADIR}/templates/default
- ${MKDIR} ${DATADIR}/templates/new
+ ${PREFIX}/www/icons/gallery/
+ @${MKDIR} ${DATADIR}/templates/default
+ @${MKDIR} ${DATADIR}/templates/new
${INSTALL_DATA} ${WRKSRC}/templates/default/* \
- ${DATADIR}/templates/default
+ ${DATADIR}/templates/default/
${INSTALL_DATA} ${WRKSRC}/templates/new/* \
- ${DATADIR}/templates/new
+ ${DATADIR}/templates/new/
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/
+.endfor
.endif
+
.if !defined(BATCH)
@${SED} s!%%DATADIR%%!${DATADIR}!g ${PKGMESSAGE}
.endif
diff --git a/www/p5-Apache-Gallery/pkg-plist b/www/p5-Apache-Gallery/pkg-plist
index 63d7e7e5d7f6..2f6d2b6af3c4 100644
--- a/www/p5-Apache-Gallery/pkg-plist
+++ b/www/p5-Apache-Gallery/pkg-plist
@@ -58,6 +58,11 @@ www/icons/gallery/video-mov.png
www/icons/gallery/video-mpeg.png
www/icons/gallery/video-mpg.png
www/icons/gallery/video-wmv.png
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Gallery
@dirrmtry %%SITE_PERL%%/Apache
@dirrm %%DATADIR%%/templates/default
@@ -65,3 +70,4 @@ www/icons/gallery/video-wmv.png
@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%
@dirrm www/icons/gallery
+%%PORTDOCS%%@dirrm %%DOCSDIR%%