aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2019-09-29 03:23:31 +0000
committerSanthosh Raju <fox@FreeBSD.org>2019-09-29 03:23:31 +0000
commit559820717e113c53afddaa8743da03adeba7c346 (patch)
tree1afa7fffdc1e4683bcee8df57d60657a1ecb816d /www
parent9661d72379e39a04be08a1697a668df64f03ce40 (diff)
downloadports-559820717e113c53afddaa8743da03adeba7c346.tar.gz
ports-559820717e113c53afddaa8743da03adeba7c346.zip
www/cliqz: update to 1.29.0
- Updates maintainer email. - Adds xorg to USES to prevent the deprecated only USES_XORG warning. - Moves the configure options to be handled in Makefile. - Forces the package to use latest LLVM (borrowed from bsd.gecko.mk). - Restricts latest LLVM to 8 for i386 arch, due to a linker error (borrowed from bsd.gecko.mk). - Removes obsolete patches no longer applicable to cliqz 1.29.0 - Minor portlint(1) and portfmt(1) improvements. Changes (since 1.28.2): https://github.com/cliqz-oss/browser-f/releases/tag/1.29.0 Approved by: philip (mentor)
Notes
Notes: svn path=/head/; revision=513189
Diffstat (limited to 'www')
-rw-r--r--www/cliqz/Makefile41
-rw-r--r--www/cliqz/distinfo18
-rw-r--r--www/cliqz/files/patch-mozilla-release_media_mtransport_third__party_nICEr_src_stun_stun.h16
-rw-r--r--www/cliqz/files/patch-mozilla-release_third__party_rust_cssparser_src_parser.rs103
4 files changed, 42 insertions, 136 deletions
diff --git a/www/cliqz/Makefile b/www/cliqz/Makefile
index d65b882240e9..eac45622f121 100644
--- a/www/cliqz/Makefile
+++ b/www/cliqz/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cliqz
-DISTVERSION= 1.28.2
-PORTREVISION= 2
+DISTVERSION= 1.29.0
CATEGORIES= www
MASTER_SITES= https://s3.amazonaws.com/cdn.cliqz.com/browser-f/APT/:amazon \
http://repository.cliqz.com/dist/${CLIQZ_CHANNEL}/${DISTVERSION}/${CLIQZ_LAST_BUILD_ID}/:cliqz
@@ -13,7 +12,7 @@ DISTFILES= adult-domains.bin:amazon \
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${_GITHUB_EXTRACT_SUFX}
-MAINTAINER= santhosh.raju@gmail.com
+MAINTAINER= fox@FreeBSD.org
COMMENT= Secure browser (Mozilla based) with built-in quick search
LICENSE= MPL20
@@ -54,7 +53,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/pulse/pulseaudio.h:audio/pulseaudio \
zip:archivers/zip
USES= compiler:c11 desktop-file-utils gmake gnome pkgconfig \
- python:2.7,build shebangfix tar:xz
+ python:2.7,build shebangfix tar:xz xorg
USE_GNOME= cairo gconf2 gdkpixbuf2 gtk20 gtk30
@@ -74,7 +73,7 @@ SHEBANG_FILES= magic_build_and_package.sh
CLIQZ_CHANNEL= release
# If the DISTVERSION is updated, make sure to update the last build id from
# fetch -qo - https://repository.cliqz.com/dist/${CLIQZ_CHANNEL}/${DISTVERSION}/lastbuildid
-CLIQZ_LAST_BUILD_ID= 20190816174655
+CLIQZ_LAST_BUILD_ID= 20190920100917
CLIQZ_ICON= ${PORTNAME}.png
CLIQZ_ICON_SRC= ${WRKSRC}/mozilla-release/browser/branding/${PORTNAME}/default48.png
MOZ_DESKTOP= ${WRKSRC}/mozilla-release/toolkit/mozapps/installer/linux/rpm/mozilla.desktop
@@ -86,6 +85,30 @@ MAKE_ENV+= CQZ_BUILD_ID=${CLIQZ_LAST_BUILD_ID} \
LLVM_OBJDUMP=${LOCALBASE}/llvm${LLVM_DEFAULT}/bin/llvm-objdump \
MOZBUILD_STATE_PATH=${WRKDIR}
+# Configure args passed into mach build system
+MOZ_CONFIGURE_ARGS+= "ac_add_options --disable-crashreporter" \
+ "ac_add_options --disable-debug" \
+ "ac_add_options --disable-debug-symbols" \
+ "ac_add_options --disable-tests" \
+ "ac_add_options --disable-updater" \
+ "ac_add_options --libclang-path=${LOCALBASE}/llvm${LLVM_DEFAULT}/lib"
+
+.include <bsd.port.pre.mk>
+
+# Default to llvm 8 for i386
+.if ${ARCH} == i386 && ${LLVM_DEFAULT:S,-devel,990,} >= 90
+LLVM_DEFAULT= 80
+.endif
+
+# Require newer Clang than what's in base system unless user opted out
+.if ${CC} == cc && ${CXX} == c++ && exists(/usr/lib/libc++.so)
+CPP= ${LOCALBASE}/bin/clang-cpp${LLVM_DEFAULT}
+CC= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
+CXX= ${LOCALBASE}/bin/clang++${LLVM_DEFAULT}
+# XXX avoid warnings
+USES:= ${USES:Ncompiler\:*}
+.endif
+
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/adult-domains.bin ${WRKSRC}
${MKDIR} ${WRKSRC}/obj/dist/bin/browser/features
@@ -94,8 +117,6 @@ post-extract:
${DISTDIR}/${DIST_SUBDIR}/gdprtool@cliqz.com.xpi \
${WRKSRC}/obj/dist/bin/browser/features
-.include <bsd.port.pre.mk>
-
post-patch:
@${CP} ${MOZ_DESKTOP} ${CLIQZ_DESKTOP}
@${REINPLACE_CMD} -e 's/@MOZ_APP_DISPLAYNAME@/Cliqz Internet/g' \
@@ -103,8 +124,12 @@ post-patch:
-e '/Icon=${PORTNAME}/ s/${PORTNAME}/${CLIQZ_ICON}/' \
-e '/StartupWMClass/d' \
${CLIQZ_DESKTOP}
+.for MOZ_CONFIGURE_ARG in ${MOZ_CONFIGURE_ARGS}
+ @${ECHO_CMD} ${MOZ_CONFIGURE_ARG} >> \
+ ${WRKSRC}/mozilla-release/browser/config/cliqz.mozconfig;
+.endfor
+# This prevents linker exhausting memory in i386 builds
.if ${ARCH} == "i386"
- # This prevents linker exhausting memory in i386 builds
@${ECHO_CMD} 'export LDFLAGS="-Wl,--no-keep-memory -Wl,--as-needed"' >> \
${WRKSRC}/mozilla-release/browser/config/cliqz.mozconfig
.endif
diff --git a/www/cliqz/distinfo b/www/cliqz/distinfo
index cda075520ff2..1b6d107fa3b5 100644
--- a/www/cliqz/distinfo
+++ b/www/cliqz/distinfo
@@ -1,11 +1,11 @@
-TIMESTAMP = 1566401840
+TIMESTAMP = 1569573921
SHA256 (cliqz/adult-domains.bin) = 3d018d6ffa75107fdfbf39658e4adaa092d9b8a90c7865b21376855f7c382b65
SIZE (cliqz/adult-domains.bin) = 528392
-SHA256 (cliqz/cliqz@cliqz.com.xpi) = 833455156987be6100e444df4cb12aa0f8a1a4df45b82198bed8f50958045a1c
-SIZE (cliqz/cliqz@cliqz.com.xpi) = 7795084
-SHA256 (cliqz/gdprtool@cliqz.com.xpi) = 1b07623b967694ca0bf45a2f88c52317f90bda1436633800cf4d02b3de54fb76
-SIZE (cliqz/gdprtool@cliqz.com.xpi) = 222806
-SHA256 (cliqz/https-everywhere@cliqz.com.xpi) = 92d43d3c7313bd890cb8ded3229aa1814ca3ebaec1b74bb317154a823b35355b
-SIZE (cliqz/https-everywhere@cliqz.com.xpi) = 1765469
-SHA256 (cliqz/cliqz-oss-browser-f-1.28.2_GH0.tar.gz) = eb22c3c06530a78012e300cd0be28d03e386270477fee29087941ec19d093982
-SIZE (cliqz/cliqz-oss-browser-f-1.28.2_GH0.tar.gz) = 496816279
+SHA256 (cliqz/cliqz@cliqz.com.xpi) = 3617f21e0ba06df20022eb95aaa87fd55109d346939f7eaba66a67d821540c6a
+SIZE (cliqz/cliqz@cliqz.com.xpi) = 5914074
+SHA256 (cliqz/gdprtool@cliqz.com.xpi) = 95ce7bd4ba1ea301246ce45bc3cdcff550acf7d8f1af1b42fd22984614cd9018
+SIZE (cliqz/gdprtool@cliqz.com.xpi) = 222247
+SHA256 (cliqz/https-everywhere@cliqz.com.xpi) = 094516da166aa984c836130075184315c5636033899c49fe6bca5b7190f488fc
+SIZE (cliqz/https-everywhere@cliqz.com.xpi) = 2147608
+SHA256 (cliqz/cliqz-oss-browser-f-1.29.0_GH0.tar.gz) = 10850fa992b8d1cac92bb8f0c06148248a0fb1568d36a408768420b20248d0f6
+SIZE (cliqz/cliqz-oss-browser-f-1.29.0_GH0.tar.gz) = 501511014
diff --git a/www/cliqz/files/patch-mozilla-release_media_mtransport_third__party_nICEr_src_stun_stun.h b/www/cliqz/files/patch-mozilla-release_media_mtransport_third__party_nICEr_src_stun_stun.h
deleted file mode 100644
index ac7e79ac4268..000000000000
--- a/www/cliqz/files/patch-mozilla-release_media_mtransport_third__party_nICEr_src_stun_stun.h
+++ /dev/null
@@ -1,16 +0,0 @@
-Firefox pulls in if_var.h which causes "class thread" conflicts with
-"struct thread" in sys/lock.h.
-
-https://lists.freebsd.org/pipermail/svn-src-all/2019-August/184844.html
-
---- mozilla-release/media/mtransport/third_party/nICEr/src/stun/stun.h.orig 2019-08-23 20:05:51 UTC
-+++ mozilla-release/media/mtransport/third_party/nICEr/src/stun/stun.h
-@@ -41,7 +41,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY O
- #include <sys/socket.h>
- #ifndef LINUX
- #include <net/if.h>
--#if !defined(__OpenBSD__) && !defined(__NetBSD__)
-+#if !defined(__OpenBSD__) && !defined(__NetBSD__) && !defined(__FreeBSD__)
- #include <net/if_var.h>
- #endif
- #include <net/if_dl.h>
diff --git a/www/cliqz/files/patch-mozilla-release_third__party_rust_cssparser_src_parser.rs b/www/cliqz/files/patch-mozilla-release_third__party_rust_cssparser_src_parser.rs
deleted file mode 100644
index a7b5a71df68c..000000000000
--- a/www/cliqz/files/patch-mozilla-release_third__party_rust_cssparser_src_parser.rs
+++ /dev/null
@@ -1,103 +0,0 @@
-From 3c98d22c5de3b696bf1fde2b6c90069812312aa6 Mon Sep 17 00:00:00 2001
-From: Simon Sapin <simon.sapin@exyr.org>
-Date: Tue, 23 Apr 2019 13:47:25 +0200
-Subject: [PATCH] Fix a future-compat warning
-
-```
-warning[E0506]: cannot assign to `self.input.cached_token` because it is borrowed
- --> src/parser.rs:591:17
- |
-566 | pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> {
- | - let's call the lifetime of this reference `'1`
-...
-579 | Some(ref cached_token)
- | ---------------- borrow of `self.input.cached_token` occurs here
-...
-591 | self.input.cached_token = Some(CachedToken {
- | ^^^^^^^^^^^^^^^^^^^^^^^ assignment to borrowed `self.input.cached_token` occurs here
-...
-603 | Ok(token)
- | --------- returning this value requires that `self.input.cached_token.0` is borrowed for `'1`
- |
- = warning: this error has been downgraded to a warning for backwards compatibility with previous releases
- = warning: this represents potential undefined behavior in your code and this warning will become a hard error in the future
-```
---- mozilla-release/third_party/rust/cssparser/.cargo-checksum.json.orig 2019-08-26 16:52:35 UTC
-+++ mozilla-release/third_party/rust/cssparser/.cargo-checksum.json
-@@ -1 +1 @@
--{"files":{"Cargo.toml":"150d450e43bcb9e523941408be883997ecffce7ff5f224329372edfe56334a55","LICENSE":"fab3dd6bdab226f1c08630b1dd917e11fcb4ec5e1e020e2c16f83a0a13863e85","README.md":"b9d6c5dc56ccc267db9e0e2389061dc2524daefa4baed88b36c98efc7a51c2a9","build.rs":"310d6d7b1931ff783a8aa1a4c6baee87b4c9130c858e4694ef69cc96df5e38dc","build/match_byte.rs":"6f7ec4235c9f2da403ea0be9339661ecd8e1f5e1c788cf88a41448b1080c59b8","docs/404.html":"025861f76f8d1f6d67c20ab624c6e418f4f824385e2dd8ad8732c4ea563c6a2e","docs/index.html":"025861f76f8d1f6d67c20ab624c6e418f4f824385e2dd8ad8732c4ea563c6a2e","src/color.rs":"43f996fbd8da54bd8ffa870f5e3610e5ba6e61543f92a129fa6c850e9b10db7e","src/cow_rc_str.rs":"541216f8ef74ee3cc5cbbc1347e5f32ed66588c401851c9a7d68b867aede1de0","src/from_bytes.rs":"331fe63af2123ae3675b61928a69461b5ac77799fff3ce9978c55cf2c558f4ff","src/lib.rs":"a474ee88ef8f73fcb7b7272d426e5eafb4ad10d104797a5a188d1676c8180972","src/macros.rs":"adb9773c157890381556ea83d7942dcc676f99eea71abbb6afeffee1e3f28960","src/nth.rs":"5c70fb542d1376cddab69922eeb4c05e4fcf8f413f27563a2af50f72a47c8f8c","src/parser.rs":"22067562160a1294fa92779b66c25cbccf259a2ef7dcf687c791fecdd020ce7f","src/rules_and_declarations.rs":"622ce07c117a511d40ce595602d4f4730659a59273388f28553d1a2b0fac92ce","src/serializer.rs":"3e2dfc60613f885cb6f99abfc854fde2a1e00de507431bd2e51178b61abfd69b","src/size_of_tests.rs":"385a0d77fbd6f86cb8013fd8d7541886980876a9da1da714bf175954c0e726cf","src/tests.rs":"9d08b3943d453664e01d58e307f79345e240f9f9ce6f8d36a842eff37155563e","src/tokenizer.rs":"adcf5811955e8df57a519e3d1e44fe3afeb5afeb1076daeb8d36fed1abcf1327","src/unicode_range.rs":"ae159d2ebe4123a6666e18dc0362f89b475240a6b7ed5fb6fe21b9e7a4139da8"},"package":"ba1ab4e1814be64bf6b6064ff532db0e34087f11b37706d6c96a21d32478761d"}
-\ No newline at end of file
-+{"files":{},"package":"ba1ab4e1814be64bf6b6064ff532db0e34087f11b37706d6c96a21d32478761d"}
---- mozilla-release/third_party/rust/cssparser/src/parser.rs.orig 2019-08-26 16:52:35 UTC
-+++ mozilla-release/third_party/rust/cssparser/src/parser.rs
-@@ -556,39 +556,47 @@ impl<'i: 't, 't> Parser<'i, 't> {
- /// where comments are preserved.
- /// When parsing higher-level values, per the CSS Syntax specification,
- /// comments should always be ignored between tokens.
-- pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> {
-+ pub fn next_including_whitespace_and_comments(
-+ &mut self
-+ ) -> Result<&Token<'i>, BasicParseError<'i>> {
- if let Some(block_type) = self.at_start_of.take() {
- consume_until_end_of_block(block_type, &mut self.input.tokenizer);
- }
-
- let byte = self.input.tokenizer.next_byte();
- if self.stop_before.contains(Delimiters::from_byte(byte)) {
-- return Err(self.new_basic_error(BasicParseErrorKind::EndOfInput))
-+ return Err(self.new_basic_error(BasicParseErrorKind::EndOfInput));
- }
-
- let token_start_position = self.input.tokenizer.position();
-- let token;
-- match self.input.cached_token {
-- Some(ref cached_token)
-- if cached_token.start_position == token_start_position => {
-- self.input.tokenizer.reset(&cached_token.end_state);
-- match cached_token.token {
-- Token::Function(ref name) => self.input.tokenizer.see_function(name),
-- _ => {}
-- }
-- token = &cached_token.token
-+ let using_cached_token = self
-+ .input
-+ .cached_token
-+ .as_ref()
-+ .map_or(false, |cached_token| {
-+ cached_token.start_position == token_start_position
-+ });
-+ let token = if using_cached_token {
-+ let cached_token = self.input.cached_token.as_ref().unwrap();
-+ self.input.tokenizer.reset(&cached_token.end_state);
-+ match cached_token.token {
-+ Token::Function(ref name) => self.input.tokenizer.see_function(name),
-+ _ => {}
- }
-- _ => {
-- let new_token = self.input.tokenizer.next()
-- .map_err(|()| self.new_basic_error(BasicParseErrorKind::EndOfInput))?;
-- self.input.cached_token = Some(CachedToken {
-- token: new_token,
-- start_position: token_start_position,
-- end_state: self.input.tokenizer.state(),
-- });
-- token = self.input.cached_token_ref()
-- }
-- }
-+ &cached_token.token
-+ } else {
-+ let new_token = self
-+ .input
-+ .tokenizer
-+ .next()
-+ .map_err(|()| self.new_basic_error(BasicParseErrorKind::EndOfInput))?;
-+ self.input.cached_token = Some(CachedToken {
-+ token: new_token,
-+ start_position: token_start_position,
-+ end_state: self.input.tokenizer.state(),
-+ });
-+ self.input.cached_token_ref()
-+ };
-
- if let Some(block_type) = BlockType::opening(token) {
- self.at_start_of = Some(block_type);