aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2011-04-04 18:33:35 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2011-04-04 18:33:35 +0000
commit7b560971012d3cd75f47018bffba6781660071d5 (patch)
tree0b9d2e0972c822a4636ca1be87e2981fc475dc82 /www
parentb48961454d9380c03bcabe0326daf612b923ade0 (diff)
downloadports-7b560971012d3cd75f47018bffba6781660071d5.tar.gz
ports-7b560971012d3cd75f47018bffba6781660071d5.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile9
-rw-r--r--www/nginx-devel/distinfo2
-rw-r--r--www/nginx/Makefile9
-rw-r--r--www/nginx/distinfo2
4 files changed, 22 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 94e319bcf46f..1ff6f599c345 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -63,6 +63,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_PUSH_MODULE "3rd party push module" off \
HTTP_REDIS_MODULE "3rd party http_redis module" off \
HTTP_RESPONSE_MODULE "3rd party http_response module" off \
+ HTTP_SUBS_FILTER_MODULE "3rd party subs filter module" off \
HTTP_UPLOAD_MODULE "3rd party upload module" off \
HTTP_UPLOAD_PROGRESS "3rd party uploadprogress module" off \
HTTP_UPSTREAM_FAIR "3rd party upstream fair module" off \
@@ -310,6 +311,14 @@ DISTFILES+= ngx_http_response-${NGINX_RESPONSE_MODULE_VERSION}.tar.gz:response
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_MODULE_VERSION}
.endif
+.if defined(WITH_HTTP_SUBS_FILTER_MODULE)
+NGINX_HTTP_SUBS_FILTER_MODULE_VERSION= 0.5.2.r44
+MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
+MASTER_SITE_SUBDIR+= osa/:subs_filter
+DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}.tar.gz:subs_filter
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_SECURE_LINK_MODULE)
CONFIGURE_ARGS+=--with-http_secure_link_module
.endif
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 9acddf7d803f..f92765c99672 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -32,6 +32,8 @@ SHA256 (ngx_http_redis-0.3.2.tar.gz) = eb7bcbcb0382b82050f06d80aa6c05c17b576d572
SIZE (ngx_http_redis-0.3.2.tar.gz) = 6346
SHA256 (ngx_http_response-0.3.tar.gz) = 0835584029f053051c624adbe33a826ab0205c9d85a02af6019e6b57607e9045
SIZE (ngx_http_response-0.3.tar.gz) = 2244
+SHA256 (ngx_http_subs_filter_module-0.5.2.r44.tar.gz) = 130a186a5bd137e84cc78a9d599dca576882b3c0808c54849b8d4e28c305f59c
+SIZE (ngx_http_subs_filter_module-0.5.2.r44.tar.gz) = 143281
SHA256 (nginx_upload_module-2.2.0.tar.gz) = b1c26abe0427180602e257627b4ed21848c93cc20cefc33af084983767d65805
SIZE (nginx_upload_module-2.2.0.tar.gz) = 25796
SHA256 (nginx_uploadprogress_module-0.8.2.tar.gz) = 277a00d92907620a8aa1891d93d226ddf087af4b21258c1a118698044520aae1
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 472746ecf492..ed29b9692f51 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -63,6 +63,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_PUSH_MODULE "3rd party push module" off \
HTTP_REDIS_MODULE "3rd party http_redis module" off \
HTTP_RESPONSE_MODULE "3rd party http_response module" off \
+ HTTP_SUBS_FILTER_MODULE "3rd party subs filter module" off \
HTTP_UPLOAD_MODULE "3rd party upload module" off \
HTTP_UPLOAD_PROGRESS "3rd party uploadprogress module" off \
HTTP_UPSTREAM_FAIR "3rd party upstream fair module" off \
@@ -312,6 +313,14 @@ DISTFILES+= ngx_http_response-${NGINX_RESPONSE_MODULE_VERSION}.tar.gz:response
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_MODULE_VERSION}
.endif
+.if defined(WITH_HTTP_SUBS_FILTER_MODULE)
+NGINX_HTTP_SUBS_FILTER_MODULE_VERSION= 0.5.2.r44
+MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
+MASTER_SITE_SUBDIR+= osa/:subs_filter
+DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}.tar.gz:subs_filter
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_SECURE_LINK_MODULE)
CONFIGURE_ARGS+=--with-http_secure_link_module
.endif
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index b7e6d0b5e3c6..491e09a20a6c 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -32,6 +32,8 @@ SHA256 (ngx_http_redis-0.3.2.tar.gz) = eb7bcbcb0382b82050f06d80aa6c05c17b576d572
SIZE (ngx_http_redis-0.3.2.tar.gz) = 6346
SHA256 (ngx_http_response-0.3.tar.gz) = 0835584029f053051c624adbe33a826ab0205c9d85a02af6019e6b57607e9045
SIZE (ngx_http_response-0.3.tar.gz) = 2244
+SHA256 (ngx_http_subs_filter_module-0.5.2.r44.tar.gz) = 130a186a5bd137e84cc78a9d599dca576882b3c0808c54849b8d4e28c305f59c
+SIZE (ngx_http_subs_filter_module-0.5.2.r44.tar.gz) = 143281
SHA256 (nginx_upload_module-2.2.0.tar.gz) = b1c26abe0427180602e257627b4ed21848c93cc20cefc33af084983767d65805
SIZE (nginx_upload_module-2.2.0.tar.gz) = 25796
SHA256 (nginx_uploadprogress_module-0.8.2.tar.gz) = 277a00d92907620a8aa1891d93d226ddf087af4b21258c1a118698044520aae1