aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2012-08-04 08:13:01 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2012-08-04 08:13:01 +0000
commitb5afbb67e29365a8f3a9a66f2c99e55558d0c7d5 (patch)
tree80bca21befdf061321f271888bfe7c83594fd6f4 /www
parent950da2ba42e6656b6d66f8dcdfb49713fffbbe7b (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mythplugin-mythweb/Makefile4
-rw-r--r--www/mythplugin-mythweb/distinfo4
-rw-r--r--www/mythplugin-mythweb/files/patch-mythweb__includes__sorting.php11
-rw-r--r--www/mythplugin-mythweb/files/patch-mythweb__modules__tv__tmpl__default__schedules.php13
-rw-r--r--www/mythplugin-mythweb/pkg-plist4
5 files changed, 30 insertions, 6 deletions
diff --git a/www/mythplugin-mythweb/Makefile b/www/mythplugin-mythweb/Makefile
index ea799a173e69..be0656140bcd 100644
--- a/www/mythplugin-mythweb/Makefile
+++ b/www/mythplugin-mythweb/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mythweb
-PORTVERSION= 0.25
+PORTVERSION= 0.25.2
CATEGORIES= www
MASTER_SITES= http://ftp.osuosl.org/pub/mythtv/ \
http://ftp.osuosl.org/pub/mythtv/old_releases/ \
@@ -48,7 +48,7 @@ post-patch:
do-install:
${MKDIR} ${WWWDIR}
${MKDIR} ${WWWDIR}/data
- (cd ${WRKSRC}/mythweb/ && ${COPYTREE_SHARE} "*" ${WWWDIR})
+ (cd ${WRKSRC}/mythweb/ && ${COPYTREE_SHARE} "*" ${WWWDIR} "! -name *.orig")
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
${CHMOD} -R 775 ${WWWDIR}/data
diff --git a/www/mythplugin-mythweb/distinfo b/www/mythplugin-mythweb/distinfo
index 85f8b20b145e..f909e59ab41f 100644
--- a/www/mythplugin-mythweb/distinfo
+++ b/www/mythplugin-mythweb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mythplugins-0.25.tar.bz2) = 8b74e84a11772274f6f90752d8ce2adf8156162879e4ff716f763bbc695d3b4d
-SIZE (mythplugins-0.25.tar.bz2) = 36795780
+SHA256 (mythplugins-0.25.2.tar.bz2) = e8507dcddfbb63ab50fe738400639c20bf2f2a278a8947fa85d9096e537f11f3
+SIZE (mythplugins-0.25.2.tar.bz2) = 36763594
diff --git a/www/mythplugin-mythweb/files/patch-mythweb__includes__sorting.php b/www/mythplugin-mythweb/files/patch-mythweb__includes__sorting.php
new file mode 100644
index 000000000000..6b8761107a7c
--- /dev/null
+++ b/www/mythplugin-mythweb/files/patch-mythweb__includes__sorting.php
@@ -0,0 +1,11 @@
+--- mythweb/includes/sorting.php.orig 2012-05-30 23:22:20.000000000 +0200
++++ mythweb/includes/sorting.php 2012-07-29 14:17:07.402674096 +0200
+@@ -119,7 +119,7 @@
+ function by_user_choice(&$a, &$b) {
+ foreach ($GLOBALS['user_sort_choice'] as $sort) {
+ $function = 'by_'.$sort['field'];
+- $response = $function(&$a, &$b);
++ $response = $function($a, $b);
+ // Identical response, go on to the next sort choice
+ if (!$response)
+ continue;
diff --git a/www/mythplugin-mythweb/files/patch-mythweb__modules__tv__tmpl__default__schedules.php b/www/mythplugin-mythweb/files/patch-mythweb__modules__tv__tmpl__default__schedules.php
new file mode 100644
index 000000000000..1daf3b11fc94
--- /dev/null
+++ b/www/mythplugin-mythweb/files/patch-mythweb__modules__tv__tmpl__default__schedules.php
@@ -0,0 +1,13 @@
+--- mythweb/modules/tv/tmpl/default/schedules.php.orig 2012-05-30 23:22:20.000000000 +0200
++++ mythweb/modules/tv/tmpl/default/schedules.php 2012-07-29 14:17:07.405673220 +0200
+@@ -85,6 +85,10 @@
+ </tr>
+ </thead>
+ <?php
++ // Hack: Disable warnings about "Creating default
++ // object from empty value" from below line
++ // "$schedule->channel->name = '[ '.t('Any').' ]';"
++ ini_set('error_reporting', E_ERROR);
+ $prev_group = '';
+ $cur_group = '';
+ foreach ($the_schedules as $schedule) {
diff --git a/www/mythplugin-mythweb/pkg-plist b/www/mythplugin-mythweb/pkg-plist
index 607712683cf0..057d95249897 100644
--- a/www/mythplugin-mythweb/pkg-plist
+++ b/www/mythplugin-mythweb/pkg-plist
@@ -709,8 +709,8 @@
@dirrm %%WWWDIR%%/js/dialog
@dirrm %%WWWDIR%%/js
@dirrm %%WWWDIR%%/includes
-@dirrm %%WWWDIR%%/data/tv_icons
-@dirrm %%WWWDIR%%/data/cache
+@dirrmtry %%WWWDIR%%/data/tv_icons
+@dirrmtry %%WWWDIR%%/data/cache
@dirrmtry %%WWWDIR%%/data
@dirrm %%WWWDIR%%/configuration
@dirrm %%WWWDIR%%/classes/UPnP