aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-09-27 09:35:20 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-09-27 09:35:20 +0000
commitdeaa22d85c723390e0a8a8d18d783d82f9a07dcc (patch)
tree8f6d2407afa434eb97adf4d5cae76c4fd1897123 /www
parent3362bfdd01e4eb0461404cd0b9202132a26d27da (diff)
downloadports-deaa22d85c723390e0a8a8d18d783d82f9a07dcc.tar.gz
ports-deaa22d85c723390e0a8a8d18d783d82f9a07dcc.zip
lang/rust: Update to 1.38.0
- Force rebuild all consumers to catch regressions early Thanks to Mikaƫl Urankar for providing updated bootstraps for aarch64, armv6, armv7, powerpc64. Changes: https://blog.rust-lang.org/2019/09/26/Rust-1.38.0.html Tested by: jbeich, mikael.urankar@gmail.com, tobik With hat: rust Differential Revision: https://reviews.freebsd.org/D21778
Notes
Notes: svn path=/head/; revision=513013
Diffstat (limited to 'www')
-rw-r--r--www/cliqz/Makefile2
-rw-r--r--www/cliqz/files/patch-mozilla-release_third__party_rust_cssparser_src_parser.rs103
-rw-r--r--www/ffsend/Makefile2
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-third__party_rust_cssparser_src_parser.rs103
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/geckodriver/Makefile2
-rw-r--r--www/jwt-cli/Makefile1
-rw-r--r--www/miniserve/Makefile2
-rw-r--r--www/newsboat/Makefile1
-rw-r--r--www/websocat/Makefile1
-rw-r--r--www/zola/Makefile2
12 files changed, 216 insertions, 7 deletions
diff --git a/www/cliqz/Makefile b/www/cliqz/Makefile
index a28f9574e8b1..d65b882240e9 100644
--- a/www/cliqz/Makefile
+++ b/www/cliqz/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cliqz
DISTVERSION= 1.28.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://s3.amazonaws.com/cdn.cliqz.com/browser-f/APT/:amazon \
http://repository.cliqz.com/dist/${CLIQZ_CHANNEL}/${DISTVERSION}/${CLIQZ_LAST_BUILD_ID}/:cliqz
diff --git a/www/cliqz/files/patch-mozilla-release_third__party_rust_cssparser_src_parser.rs b/www/cliqz/files/patch-mozilla-release_third__party_rust_cssparser_src_parser.rs
new file mode 100644
index 000000000000..a7b5a71df68c
--- /dev/null
+++ b/www/cliqz/files/patch-mozilla-release_third__party_rust_cssparser_src_parser.rs
@@ -0,0 +1,103 @@
+From 3c98d22c5de3b696bf1fde2b6c90069812312aa6 Mon Sep 17 00:00:00 2001
+From: Simon Sapin <simon.sapin@exyr.org>
+Date: Tue, 23 Apr 2019 13:47:25 +0200
+Subject: [PATCH] Fix a future-compat warning
+
+```
+warning[E0506]: cannot assign to `self.input.cached_token` because it is borrowed
+ --> src/parser.rs:591:17
+ |
+566 | pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> {
+ | - let's call the lifetime of this reference `'1`
+...
+579 | Some(ref cached_token)
+ | ---------------- borrow of `self.input.cached_token` occurs here
+...
+591 | self.input.cached_token = Some(CachedToken {
+ | ^^^^^^^^^^^^^^^^^^^^^^^ assignment to borrowed `self.input.cached_token` occurs here
+...
+603 | Ok(token)
+ | --------- returning this value requires that `self.input.cached_token.0` is borrowed for `'1`
+ |
+ = warning: this error has been downgraded to a warning for backwards compatibility with previous releases
+ = warning: this represents potential undefined behavior in your code and this warning will become a hard error in the future
+```
+--- mozilla-release/third_party/rust/cssparser/.cargo-checksum.json.orig 2019-08-26 16:52:35 UTC
++++ mozilla-release/third_party/rust/cssparser/.cargo-checksum.json
+@@ -1 +1 @@
+-{"files":{"Cargo.toml":"150d450e43bcb9e523941408be883997ecffce7ff5f224329372edfe56334a55","LICENSE":"fab3dd6bdab226f1c08630b1dd917e11fcb4ec5e1e020e2c16f83a0a13863e85","README.md":"b9d6c5dc56ccc267db9e0e2389061dc2524daefa4baed88b36c98efc7a51c2a9","build.rs":"310d6d7b1931ff783a8aa1a4c6baee87b4c9130c858e4694ef69cc96df5e38dc","build/match_byte.rs":"6f7ec4235c9f2da403ea0be9339661ecd8e1f5e1c788cf88a41448b1080c59b8","docs/404.html":"025861f76f8d1f6d67c20ab624c6e418f4f824385e2dd8ad8732c4ea563c6a2e","docs/index.html":"025861f76f8d1f6d67c20ab624c6e418f4f824385e2dd8ad8732c4ea563c6a2e","src/color.rs":"43f996fbd8da54bd8ffa870f5e3610e5ba6e61543f92a129fa6c850e9b10db7e","src/cow_rc_str.rs":"541216f8ef74ee3cc5cbbc1347e5f32ed66588c401851c9a7d68b867aede1de0","src/from_bytes.rs":"331fe63af2123ae3675b61928a69461b5ac77799fff3ce9978c55cf2c558f4ff","src/lib.rs":"a474ee88ef8f73fcb7b7272d426e5eafb4ad10d104797a5a188d1676c8180972","src/macros.rs":"adb9773c157890381556ea83d7942dcc676f99eea71abbb6afeffee1e3f28960","src/nth.rs":"5c70fb542d1376cddab69922eeb4c05e4fcf8f413f27563a2af50f72a47c8f8c","src/parser.rs":"22067562160a1294fa92779b66c25cbccf259a2ef7dcf687c791fecdd020ce7f","src/rules_and_declarations.rs":"622ce07c117a511d40ce595602d4f4730659a59273388f28553d1a2b0fac92ce","src/serializer.rs":"3e2dfc60613f885cb6f99abfc854fde2a1e00de507431bd2e51178b61abfd69b","src/size_of_tests.rs":"385a0d77fbd6f86cb8013fd8d7541886980876a9da1da714bf175954c0e726cf","src/tests.rs":"9d08b3943d453664e01d58e307f79345e240f9f9ce6f8d36a842eff37155563e","src/tokenizer.rs":"adcf5811955e8df57a519e3d1e44fe3afeb5afeb1076daeb8d36fed1abcf1327","src/unicode_range.rs":"ae159d2ebe4123a6666e18dc0362f89b475240a6b7ed5fb6fe21b9e7a4139da8"},"package":"ba1ab4e1814be64bf6b6064ff532db0e34087f11b37706d6c96a21d32478761d"}
+\ No newline at end of file
++{"files":{},"package":"ba1ab4e1814be64bf6b6064ff532db0e34087f11b37706d6c96a21d32478761d"}
+--- mozilla-release/third_party/rust/cssparser/src/parser.rs.orig 2019-08-26 16:52:35 UTC
++++ mozilla-release/third_party/rust/cssparser/src/parser.rs
+@@ -556,39 +556,47 @@ impl<'i: 't, 't> Parser<'i, 't> {
+ /// where comments are preserved.
+ /// When parsing higher-level values, per the CSS Syntax specification,
+ /// comments should always be ignored between tokens.
+- pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> {
++ pub fn next_including_whitespace_and_comments(
++ &mut self
++ ) -> Result<&Token<'i>, BasicParseError<'i>> {
+ if let Some(block_type) = self.at_start_of.take() {
+ consume_until_end_of_block(block_type, &mut self.input.tokenizer);
+ }
+
+ let byte = self.input.tokenizer.next_byte();
+ if self.stop_before.contains(Delimiters::from_byte(byte)) {
+- return Err(self.new_basic_error(BasicParseErrorKind::EndOfInput))
++ return Err(self.new_basic_error(BasicParseErrorKind::EndOfInput));
+ }
+
+ let token_start_position = self.input.tokenizer.position();
+- let token;
+- match self.input.cached_token {
+- Some(ref cached_token)
+- if cached_token.start_position == token_start_position => {
+- self.input.tokenizer.reset(&cached_token.end_state);
+- match cached_token.token {
+- Token::Function(ref name) => self.input.tokenizer.see_function(name),
+- _ => {}
+- }
+- token = &cached_token.token
++ let using_cached_token = self
++ .input
++ .cached_token
++ .as_ref()
++ .map_or(false, |cached_token| {
++ cached_token.start_position == token_start_position
++ });
++ let token = if using_cached_token {
++ let cached_token = self.input.cached_token.as_ref().unwrap();
++ self.input.tokenizer.reset(&cached_token.end_state);
++ match cached_token.token {
++ Token::Function(ref name) => self.input.tokenizer.see_function(name),
++ _ => {}
+ }
+- _ => {
+- let new_token = self.input.tokenizer.next()
+- .map_err(|()| self.new_basic_error(BasicParseErrorKind::EndOfInput))?;
+- self.input.cached_token = Some(CachedToken {
+- token: new_token,
+- start_position: token_start_position,
+- end_state: self.input.tokenizer.state(),
+- });
+- token = self.input.cached_token_ref()
+- }
+- }
++ &cached_token.token
++ } else {
++ let new_token = self
++ .input
++ .tokenizer
++ .next()
++ .map_err(|()| self.new_basic_error(BasicParseErrorKind::EndOfInput))?;
++ self.input.cached_token = Some(CachedToken {
++ token: new_token,
++ start_position: token_start_position,
++ end_state: self.input.tokenizer.state(),
++ });
++ self.input.cached_token_ref()
++ };
+
+ if let Some(block_type) = BlockType::opening(token) {
+ self.at_start_of = Some(block_type);
diff --git a/www/ffsend/Makefile b/www/ffsend/Makefile
index 1cfe1db9415a..bbf7cbf5f0b5 100644
--- a/www/ffsend/Makefile
+++ b/www/ffsend/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ffsend
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.46
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MAINTAINER= 0mp@FreeBSD.org
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index ceeb5dc5e08d..77a8cce112e9 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 68.1.0
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-third__party_rust_cssparser_src_parser.rs b/www/firefox-esr/files/patch-third__party_rust_cssparser_src_parser.rs
new file mode 100644
index 000000000000..a677ec2ef397
--- /dev/null
+++ b/www/firefox-esr/files/patch-third__party_rust_cssparser_src_parser.rs
@@ -0,0 +1,103 @@
+From 3c98d22c5de3b696bf1fde2b6c90069812312aa6 Mon Sep 17 00:00:00 2001
+From: Simon Sapin <simon.sapin@exyr.org>
+Date: Tue, 23 Apr 2019 13:47:25 +0200
+Subject: [PATCH] Fix a future-compat warning
+
+```
+warning[E0506]: cannot assign to `self.input.cached_token` because it is borrowed
+ --> src/parser.rs:591:17
+ |
+566 | pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> {
+ | - let's call the lifetime of this reference `'1`
+...
+579 | Some(ref cached_token)
+ | ---------------- borrow of `self.input.cached_token` occurs here
+...
+591 | self.input.cached_token = Some(CachedToken {
+ | ^^^^^^^^^^^^^^^^^^^^^^^ assignment to borrowed `self.input.cached_token` occurs here
+...
+603 | Ok(token)
+ | --------- returning this value requires that `self.input.cached_token.0` is borrowed for `'1`
+ |
+ = warning: this error has been downgraded to a warning for backwards compatibility with previous releases
+ = warning: this represents potential undefined behavior in your code and this warning will become a hard error in the future
+```
+--- third_party/rust/cssparser/.cargo-checksum.json.orig 2019-08-26 16:52:35 UTC
++++ third_party/rust/cssparser/.cargo-checksum.json
+@@ -1 +1 @@
+-{"files":{"Cargo.toml":"150d450e43bcb9e523941408be883997ecffce7ff5f224329372edfe56334a55","LICENSE":"fab3dd6bdab226f1c08630b1dd917e11fcb4ec5e1e020e2c16f83a0a13863e85","README.md":"b9d6c5dc56ccc267db9e0e2389061dc2524daefa4baed88b36c98efc7a51c2a9","build.rs":"310d6d7b1931ff783a8aa1a4c6baee87b4c9130c858e4694ef69cc96df5e38dc","build/match_byte.rs":"6f7ec4235c9f2da403ea0be9339661ecd8e1f5e1c788cf88a41448b1080c59b8","docs/404.html":"025861f76f8d1f6d67c20ab624c6e418f4f824385e2dd8ad8732c4ea563c6a2e","docs/index.html":"025861f76f8d1f6d67c20ab624c6e418f4f824385e2dd8ad8732c4ea563c6a2e","src/color.rs":"43f996fbd8da54bd8ffa870f5e3610e5ba6e61543f92a129fa6c850e9b10db7e","src/cow_rc_str.rs":"541216f8ef74ee3cc5cbbc1347e5f32ed66588c401851c9a7d68b867aede1de0","src/from_bytes.rs":"331fe63af2123ae3675b61928a69461b5ac77799fff3ce9978c55cf2c558f4ff","src/lib.rs":"a474ee88ef8f73fcb7b7272d426e5eafb4ad10d104797a5a188d1676c8180972","src/macros.rs":"adb9773c157890381556ea83d7942dcc676f99eea71abbb6afeffee1e3f28960","src/nth.rs":"5c70fb542d1376cddab69922eeb4c05e4fcf8f413f27563a2af50f72a47c8f8c","src/parser.rs":"22067562160a1294fa92779b66c25cbccf259a2ef7dcf687c791fecdd020ce7f","src/rules_and_declarations.rs":"622ce07c117a511d40ce595602d4f4730659a59273388f28553d1a2b0fac92ce","src/serializer.rs":"3e2dfc60613f885cb6f99abfc854fde2a1e00de507431bd2e51178b61abfd69b","src/size_of_tests.rs":"385a0d77fbd6f86cb8013fd8d7541886980876a9da1da714bf175954c0e726cf","src/tests.rs":"9d08b3943d453664e01d58e307f79345e240f9f9ce6f8d36a842eff37155563e","src/tokenizer.rs":"adcf5811955e8df57a519e3d1e44fe3afeb5afeb1076daeb8d36fed1abcf1327","src/unicode_range.rs":"ae159d2ebe4123a6666e18dc0362f89b475240a6b7ed5fb6fe21b9e7a4139da8"},"package":"ba1ab4e1814be64bf6b6064ff532db0e34087f11b37706d6c96a21d32478761d"}
+\ No newline at end of file
++{"files":{},"package":"ba1ab4e1814be64bf6b6064ff532db0e34087f11b37706d6c96a21d32478761d"}
+--- third_party/rust/cssparser/src/parser.rs.orig 2019-08-26 16:52:35 UTC
++++ third_party/rust/cssparser/src/parser.rs
+@@ -556,39 +556,47 @@ impl<'i: 't, 't> Parser<'i, 't> {
+ /// where comments are preserved.
+ /// When parsing higher-level values, per the CSS Syntax specification,
+ /// comments should always be ignored between tokens.
+- pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> {
++ pub fn next_including_whitespace_and_comments(
++ &mut self
++ ) -> Result<&Token<'i>, BasicParseError<'i>> {
+ if let Some(block_type) = self.at_start_of.take() {
+ consume_until_end_of_block(block_type, &mut self.input.tokenizer);
+ }
+
+ let byte = self.input.tokenizer.next_byte();
+ if self.stop_before.contains(Delimiters::from_byte(byte)) {
+- return Err(self.new_basic_error(BasicParseErrorKind::EndOfInput))
++ return Err(self.new_basic_error(BasicParseErrorKind::EndOfInput));
+ }
+
+ let token_start_position = self.input.tokenizer.position();
+- let token;
+- match self.input.cached_token {
+- Some(ref cached_token)
+- if cached_token.start_position == token_start_position => {
+- self.input.tokenizer.reset(&cached_token.end_state);
+- match cached_token.token {
+- Token::Function(ref name) => self.input.tokenizer.see_function(name),
+- _ => {}
+- }
+- token = &cached_token.token
++ let using_cached_token = self
++ .input
++ .cached_token
++ .as_ref()
++ .map_or(false, |cached_token| {
++ cached_token.start_position == token_start_position
++ });
++ let token = if using_cached_token {
++ let cached_token = self.input.cached_token.as_ref().unwrap();
++ self.input.tokenizer.reset(&cached_token.end_state);
++ match cached_token.token {
++ Token::Function(ref name) => self.input.tokenizer.see_function(name),
++ _ => {}
+ }
+- _ => {
+- let new_token = self.input.tokenizer.next()
+- .map_err(|()| self.new_basic_error(BasicParseErrorKind::EndOfInput))?;
+- self.input.cached_token = Some(CachedToken {
+- token: new_token,
+- start_position: token_start_position,
+- end_state: self.input.tokenizer.state(),
+- });
+- token = self.input.cached_token_ref()
+- }
+- }
++ &cached_token.token
++ } else {
++ let new_token = self
++ .input
++ .tokenizer
++ .next()
++ .map_err(|()| self.new_basic_error(BasicParseErrorKind::EndOfInput))?;
++ self.input.cached_token = Some(CachedToken {
++ token: new_token,
++ start_position: token_start_position,
++ end_state: self.input.tokenizer.state(),
++ });
++ self.input.cached_token_ref()
++ };
+
+ if let Some(block_type) = BlockType::opening(token) {
+ self.at_start_of = Some(block_type);
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index abf6cb894bf7..d443ed95cc9c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 69.0.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/geckodriver/Makefile b/www/geckodriver/Makefile
index b1d836b49949..ddbe462afbc0 100644
--- a/www/geckodriver/Makefile
+++ b/www/geckodriver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= geckodriver
DISTVERSIONPREFIX= v
DISTVERSION= 0.24.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MAINTAINER= daniel@blodan.se
diff --git a/www/jwt-cli/Makefile b/www/jwt-cli/Makefile
index 7f9217613d87..ae9f94f62903 100644
--- a/www/jwt-cli/Makefile
+++ b/www/jwt-cli/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jwt-cli
PORTVERSION= 2.5.0
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= osa@FreeBSD.org
diff --git a/www/miniserve/Makefile b/www/miniserve/Makefile
index f6de78b44c38..39d404b7f7e6 100644
--- a/www/miniserve/Makefile
+++ b/www/miniserve/Makefile
@@ -3,7 +3,7 @@
PORTNAME= miniserve
DISTVERSIONPREFIX= v
DISTVERSION= 0.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MAINTAINER= tobik@FreeBSD.org
diff --git a/www/newsboat/Makefile b/www/newsboat/Makefile
index f45196e580ce..fb5256b22d10 100644
--- a/www/newsboat/Makefile
+++ b/www/newsboat/Makefile
@@ -3,6 +3,7 @@
PORTNAME= newsboat
PORTVERSION= 2.17
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://newsboat.org/releases/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/www/websocat/Makefile b/www/websocat/Makefile
index cbb267497d2b..054ee7b39930 100644
--- a/www/websocat/Makefile
+++ b/www/websocat/Makefile
@@ -4,6 +4,7 @@
PORTNAME= websocat
DISTVERSIONPREFIX= v
DISTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= osa@FreeBSD.org
diff --git a/www/zola/Makefile b/www/zola/Makefile
index 4d8a8bfe58d1..54799c9bb672 100644
--- a/www/zola/Makefile
+++ b/www/zola/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zola
DISTVERSIONPREFIX= v
DISTVERSION= 0.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= tobik@FreeBSD.org