aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-21 19:33:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-21 19:33:36 +0000
commite075d037c3a168c867c30b45d962d90daf5e038c (patch)
tree88c67dd1b25761a081305ba979cec06c8f2573c7 /www
parent036c38aa5b513a69591b490f4854ae12b3422c58 (diff)
downloadports-e075d037c3a168c867c30b45d962d90daf5e038c.tar.gz
ports-e075d037c3a168c867c30b45d962d90daf5e038c.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/npm/Makefile6
-rw-r--r--www/npm/distinfo4
-rw-r--r--www/npm/pkg-plist12
3 files changed, 7 insertions, 15 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 97b44cd49b89..beb4d8b73149 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= npm
-PORTVERSION= 2.7.1
+PORTVERSION= 2.7.3
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -52,9 +52,9 @@ MS_VERSIONFILE= ${MS_WRKSRC}/.version
MS_WRKSRC= ${WRKSRC}/tmp
GITHUB_PROJECT= ${PORTNAME}
-GITHUB_RELEASES=https://github.com/npm/npm/releases/latest
+GITHUB_RELEASES=https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/releases/latest
GITHUB_TARBALL= https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/${GITHUB_VERSION}.tar.gz
-GITHUB_USER= npm
+GITHUB_USER= ${PORTNAME}
GITHUB_VERSION= v${MS_VERSION}
maketar: do-clean
diff --git a/www/npm/distinfo b/www/npm/distinfo
index 1cc74c0d4bc3..7f7cf737cc6e 100644
--- a/www/npm/distinfo
+++ b/www/npm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (npm-2.7.1.tar.xz) = 076ff3a5ea27f401210c04845203aa65f4ba7ab09cd8b3b2284261394d2a08a5
-SIZE (npm-2.7.1.tar.xz) = 2093284
+SHA256 (npm-2.7.3.tar.xz) = 0f6372eccd704dc62514e516b0bcb458347f46aabf530397db94fc18f4bb4ff3
+SIZE (npm-2.7.3.tar.xz) = 2090400
diff --git a/www/npm/pkg-plist b/www/npm/pkg-plist
index 31d998f12be1..61c552468334 100644
--- a/www/npm/pkg-plist
+++ b/www/npm/pkg-plist
@@ -870,18 +870,14 @@ lib/node_modules/npm/node_modules/lru-cache/package.json
lib/node_modules/npm/node_modules/lru-cache/test/basic.js
lib/node_modules/npm/node_modules/lru-cache/test/foreach.js
lib/node_modules/npm/node_modules/lru-cache/test/memory-leak.js
-lib/node_modules/npm/node_modules/minimatch/.npmignore
-lib/node_modules/npm/node_modules/minimatch/.travis.yml
lib/node_modules/npm/node_modules/minimatch/LICENSE
lib/node_modules/npm/node_modules/minimatch/README.md
-lib/node_modules/npm/node_modules/minimatch/benchmark.js
lib/node_modules/npm/node_modules/minimatch/browser.js
lib/node_modules/npm/node_modules/minimatch/minimatch.js
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/.npmignore
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/.travis.yml
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/README.md
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/example.js
-lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/index.bak
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/index.js
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/balanced-match/.npmignore
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/balanced-match/.travis.yml
@@ -892,6 +888,7 @@ lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_mo
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/balanced-match/package.json
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/balanced-match/test/balanced.js
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/concat-map/.travis.yml
+lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/concat-map/LICENSE
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/concat-map/README.markdown
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/concat-map/example/map.js
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/node_modules/concat-map/index.js
@@ -911,10 +908,6 @@ lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/test/pa
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/test/same-type.js
lib/node_modules/npm/node_modules/minimatch/node_modules/brace-expansion/test/sequence.js
lib/node_modules/npm/node_modules/minimatch/package.json
-lib/node_modules/npm/node_modules/minimatch/test/basic.js
-lib/node_modules/npm/node_modules/minimatch/test/brace-expand.js
-lib/node_modules/npm/node_modules/minimatch/test/defaults.js
-lib/node_modules/npm/node_modules/minimatch/test/extglob-ending-with-state-char.js
lib/node_modules/npm/node_modules/mkdirp/.npmignore
lib/node_modules/npm/node_modules/mkdirp/.travis.yml
lib/node_modules/npm/node_modules/mkdirp/LICENSE
@@ -2157,11 +2150,10 @@ lib/node_modules/npm/test/tap/search.js
lib/node_modules/npm/test/tap/semver-doc.js
lib/node_modules/npm/test/tap/semver-tag.js
lib/node_modules/npm/test/tap/shrinkwrap-dev-dependency.js
-lib/node_modules/npm/test/tap/shrinkwrap-dev-dependency/desired-shrinkwrap-results.json
-lib/node_modules/npm/test/tap/shrinkwrap-dev-dependency/package.json
lib/node_modules/npm/test/tap/shrinkwrap-empty-deps.js
lib/node_modules/npm/test/tap/shrinkwrap-empty-deps/package.json
lib/node_modules/npm/test/tap/shrinkwrap-local-dependency.js
+lib/node_modules/npm/test/tap/shrinkwrap-prod-dependency.js
lib/node_modules/npm/test/tap/shrinkwrap-scoped-auth.js
lib/node_modules/npm/test/tap/shrinkwrap-shared-dev-dependency.js
lib/node_modules/npm/test/tap/shrinkwrap-shared-dev-dependency/desired-shrinkwrap-results.json